PDA

View Full Version : linkstation 2.x



wooke01
2005-10-14, 23:43
Hi

I just installed slimserver and openlink (this includes perl and telnet) from the wiki pages for linkstation.
I also installed the libarries on the wiki page for slimstation. However when i try and start slimserver i get this error:

I think it is important to note as well that the 2.x linkstation is the mips version so the perl version at fieldnetworks did not work for me, everythign that comes from wiki seems fine.

Can't locate Slim/Utils/Misc.pm in @INC (@INC contains: /mnt/slimserver /mnt/sli
mserver/CPAN /mnt/slimserver/CPAN/arch/5.8.7/mipsel-linux-gnu-thread-multi /mnt/
slimserver/CPAN/arch/5.8.7/mipsel-linux-gnu-thread-multi/auto /mnt/slimserver/CP
AN/arch/5.8/mipsel-linux-gnu-thread-multi /mnt/slimserver/CPAN/arch/5.8/mipsel-l
inux-gnu-thread-multi/auto /mnt/slimserver/CPAN/arch/mipsel-linux-gnu-thread-mul
ti /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl
5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_per
l .) at ./slimserver.pl line 203.
BEGIN failed--compilation aborted at ./slimserver.pl line 203.

I also downloaded Misc.pm from the yagoo linkstation group as i didnt have it and put it in my path but still no luck.

Any idea what I am missing or not doing? This is slimserver 6.1.1

Thanks

mherger
2005-10-14, 23:56
> Can't locate Slim/Utils/Misc.pm in @INC (@INC contains: /mnt/slimserver
[..]
> I also downloaded Misc.pm from the yagoo linkstation group as i didnt
> have it and put it in my path but still no luck.

This is a slimserver own library. Where did you install slimserver? How
did you start it? You should see the file from within the slimserver
folder launching "ls Slim/Utils".

And rather start off using 6.2 - it contains a lot of improvements and is
going to be official beta really soon.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

wooke01
2005-10-15, 05:35
thanks the tar ball i downloaded was corrupt so works now. has anybody compiled FAAD or LAME for mips linkstation? if not can anybody recommend and AAC to MP3 encoder? I was going to use dbpower amp or foobar 2000 but dbpower amp wont let me point just to a input directory and outputfir and foobar 2000 crashes!

i just want to [play AAC or ran a converter where i can point the converter at a tp dir and specifiy and output dir and leave it alone for a while.

if anybody else is doing the same i just installed openlink to add ftp, (install via normal firmware update method) and then installed the mips compiled libs from wiki and it worked. Installing openlink means you just login with root priviledges and dont have to bother with a lot of teh stuff on the field networks site, also note that the 2.x install uses shadow password file not /etc/passwd for passwords.


Thanks

gingerneil
2005-10-15, 23:47
I am planning on doing thise sometime soon. Can you post peformance results once you;re up and running ?? Can you stream to multiple SB2s at the same time without skipping ?? Can you browse the web interface OK whilst streaming ??

wooke01
2005-10-24, 02:39
we only use 1xsbv so cant help there but 3.5k songs take around 2-3 hours to rescan. when playing it seems ok but the disk when not used just doesnt seem to spin down, i have read elsewhere that this is because i have dropbear installed and it cannot shutdown the services on the box.

Anybody else had this issue?

ugarit
2005-11-17, 05:00
Where did you get the openlink firmware from?

I went here and download

http://linkstationwiki.org/downloads/openlink/hg-openlink-051b.zip

but the zip file corrupt. I downloaded again without success :-(

Should I be using this instead

http://linkstationwiki.org/downloads/openlink/ppc-openlink-052b.zip