PDA

View Full Version : Deleting files



Newbie
2005-10-14, 12:33
I want to delete an audio file (mp3) from S.D. but cannot seem to get it to go away. It is not on my hard drive any longer but still appears in my "Artist" category. How do I delete from S.D.

Also, I intially (and legally) downloaded to CD an audio file which WAS protected. I then copied to hard drive and it now shows it is NOT protected, but it still won't play. Any thoughts/suggestions? Is it lying?

Thanks,

Newbie

kdf
2005-10-14, 13:08
>
> I want to delete an audio file (mp3) from S.D. but cannot seem to get it
> to go away. It is not on my hard drive any longer but still appears in
> my "Artist" category. How do I delete from S.D.

a rescan may be necessary (access from server settings). Also make sure you
dont have that file referenced in any of the playlists that you created.

>
> Also, I intially (and legally) downloaded to CD an audio file which WAS
> protected. I then copied to hard drive and it now shows it is NOT
> protected, but it still won't play. Any thoughts/suggestions? Is it
> lying?

Maybe, maybe not. A rescan may also be to blame for this if the protected
version was the same filename and location. However, if slimserver is showing
it as unprotected, then this should be unlikely.

I'm guessing you have the latest official release of slimserver and you are
using with a SqueezeBox2, in which case the format shouldn't matter. Go into
server settings->debugging. check d_source and click change. Then click the
link in the text at the top to open a browser window that shows the log (hint,
the link is the word "here", but it can be hard to spot in the Default skin)

When you try to play the song, the log will show what the server is doing when
it tries to play the song including any errors as it fails. you can post
sections of that log in here and that will help us narrow down what might be
wrong.

-kdf

Newbie
2005-10-14, 14:27
I am using Squeezebox1 version 6.1.1. I ran a rescan after checking rescan playlist only. Nothing changed, I have 2 copies of this file. Should I check "clear library before scan" and try again? What is the difference in these two functions?

Checked all playlists, artists, etc and song is not anywhere. But when I do a search it gives me the directory and shows under "artist" but it has been deleted from my C Drive. Cannot get rid of it!!

I got this after doing the debugging:

2005-10-14 14:33:06.9419 Setting maxBitRate for 192.168.2.101 to: 0

kdf
2005-10-14, 15:12
Quoting Newbie <Newbie.1wwvg0 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> I am using Squeezebox1 version 6.1.1. I ran a rescan after checking
> rescan playlist only. Nothing changed, I have 2 copies of this file.
> Should I check "clear library before scan" and try again? What is the
> difference in these two functions?

a simple rescan will look for files that show signs of changes and
update. 'clear library' wipes all records in the library and starts
building from
scratch. it is very effective at wiping out any stray data, but does
take some
time.

> Checked all playlists, artists, etc and song is not anywhere. But when
> I do a search it gives me the directory and shows under "artist" but it
> has been deleted from my C Drive. Cannot get rid of it!!

Doing a clear library and scan should fix this with 6.1.1. The 6.2
builds are a
bit better a this, and are nearing an official beta release. If you
want to try
a nightly build, they are available for download at:
http://www.slimdevices.com/downloads/nightly/latest/

However, if you want to go that route, I'd wait until tomorrow. There was a
problem in today's build that doesn't like radio urls.

-kdf

Newbie
2005-10-14, 15:53
Thanks so much. I'll try the clear library first.