PDA

View Full Version : gslimp3: a SLIMP3 player emulator in python



Jefke
2005-10-09, 15:05
Hi,

A post to mention a new SLIMP3 player emulator I've just released. It's python-gtk2 based. It has been tested on Debian (sarge, sid) and Ubuntu (Hoary, Breezy). It should work on all flavors of Linux, and other Unixes as well.

For more details:

http://jefke.free.fr/coding/python/
http://jefke.free.fr/coding/python/gslimp3

Feedbacks are welcome.

methane
2006-05-01, 20:46
Hi, I am trying to install the gslimp3 player on Ubuntu Breezy Badger. But I keep getting this error which seems to tell me that the version of python I'm running is too new. Is that right? Can someone help me fix this? Maybe I need a different Debian Package?

Regards,
Brad


brad@Azkaban1:~/Desktop$ wget http://jefke.free.fr/debian/sarge/binary/gslimp3_0.4_i386.deb

brad@Azkaban1:~/Desktop$ sudo dpkg -i gslimp3_0.4_i386.deb
Selecting previously deselected package gslimp3.
(Reading database ... 78677 files and directories currently installed.)
Unpacking gslimp3 (from gslimp3_0.4_i386.deb) ...
dpkg: dependency problems prevent configuration of gslimp3:
gslimp3 depends on python (<< 2.4); however:
Version of python on system is 2.4.2-0ubuntu2.
dpkg: error processing gslimp3 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
gslimp3

mherger
2006-05-01, 23:27
> Hi, I am trying to install the gslimp3 player on Ubuntu Breezy Badger.

I'm sorry I can't help. But I think you'd do yourself a favor in using
Softsqueeze instead. It's much more up to date.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

Jefke
2006-05-02, 12:48
Hi, I am trying to install the gslimp3 player on Ubuntu Breezy Badger. But I keep getting this error which seems to tell me that the version of python I'm running is too new. Is that right? Can someone help me fix this? Maybe I need a different Debian Package?

Regards,
Brad


brad@Azkaban1:~/Desktop$ wget http://jefke.free.fr/debian/sarge/binary/gslimp3_0.4_i386.deb

brad@Azkaban1:~/Desktop$ sudo dpkg -i gslimp3_0.4_i386.deb
Selecting previously deselected package gslimp3.
(Reading database ... 78677 files and directories currently installed.)
Unpacking gslimp3 (from gslimp3_0.4_i386.deb) ...
dpkg: dependency problems prevent configuration of gslimp3:
gslimp3 depends on python (<< 2.4); however:
Version of python on system is 2.4.2-0ubuntu2.
dpkg: error processing gslimp3 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
gslimp3

Hi,

I've created a package dedicated to unbuntu breezy:

http://jefke.free.fr/ubuntu/breezy/binary/gslimp3_0.5_i386.deb

Have fun.

methane
2006-05-02, 19:52
jefke,
that installed no problem. Thanks a lot.
Michael, I wasn't aware that Softsqueeze could be run on Linux (Debian). Is there a page somewhere addressing how to install it?

Regards,
Brad

mherger
2006-05-03, 01:58
> Michael, I wasn't aware that Softsqueeze could be run on Linux
> (Debian). Is there a page somewhere addressing how to install it?

It's written in Java. You'll best install JRE 1.5, then "java -jar
Softsqueeze.jar" from the appropriate folder (Slimserver/HTML/EN/html or
something).

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)