PDA

View Full Version : Trouble tunneling SoftSqueeze over ssh



Wendy Seltzer
2005-10-05, 08:11
I can't seem to make SoftSqueeze tunnel over ssh, even though I can start a
normal ssh session to the machine. It shows "ssh connecting" then
"Connection failed. Please check server settings." The not-very-informative
messages on the command line are below.

Thanks for any suggestions.
--Wendy

wseltzer@wmstab ~/c/Program Files/Softsqueeze
$ java -jar SoftSqueeze.jar
16 [main] ERROR ssh - Cannot connect ssh tunnel
com.jcraft.jsch.JSchException: Auth fail
at com.jcraft.jsch.Session.connect(Unknown Source)
at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:116)
at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
at com.slim.softsqueeze.Application.main(Application. java:53)
16 [main] WARN softsqueeze - Exception in connect
java.io.IOException: Auth fail
at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:142)
at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
at com.slim.softsqueeze.Application.main(Application. java:53)


--
Wendy Seltzer
http://wendy.seltzer.org/blog/

Roy Owen
2005-10-05, 10:20
You didn't say what OS you are using, I'll assume MS Windows. Have you tried
using a client like tunnelier from BitVise or PuTTy? I've found that using a
seperate ssh client to create the tunnel and forward the ports is quite
often more reliable.

On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
>
> I can't seem to make SoftSqueeze tunnel over ssh, even though I can start
> a normal ssh session to the machine. It shows "ssh connecting" then
> "Connection failed. Please check server settings." The not-very-informative
> messages on the command line are below.
>
> Thanks for any suggestions.
> --Wendy
>
> wseltzer@wmstab ~/c/Program Files/Softsqueeze
> $ java -jar SoftSqueeze.jar
> 16 [main] ERROR ssh - Cannot connect ssh tunnel
> com.jcraft.jsch.JSchException: Auth fail
> at com.jcraft.jsch.Session.connect(Unknown Source)
> at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:116)
> at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> at com.slim.softsqueeze.Application.main(Application. java:53)
> 16 [main] WARN softsqueeze - Exception in connect
> java.io.IOException: Auth fail
> at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:142)
> at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> at com.slim.softsqueeze.Application.main(Application. java:53)
>
>
> --
> Wendy Seltzer
> http://wendy.seltzer.org/blog/
>

Wendy Seltzer
2005-10-05, 11:11
On 10/5/05, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
>
> You didn't say what OS you are using, I'll assume MS Windows. Have you
> tried using a client like tunnelier from BitVise or PuTTy? I've found that
> using a seperate ssh client to create the tunnel and forward the ports is
> quite often more reliable.


I'll start with SoftSqueeze on Windows (cygwin available) to access
slimserver on Linux. On which side are you suggesting to build the tunnel?

Thanks.
--Wendy


On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
>
> > I can't seem to make SoftSqueeze tunnel over ssh, even though I can
> > start a normal ssh session to the machine. It shows "ssh connecting" then
> > "Connection failed. Please check server settings." The not-very-informative
> > messages on the command line are below.
> >
> > Thanks for any suggestions.
> > --Wendy
> >
> > wseltzer@wmstab ~/c/Program Files/Softsqueeze
> > $ java -jar SoftSqueeze.jar
> > 16 [main] ERROR ssh - Cannot connect ssh tunnel
> > com.jcraft.jsch.JSchException: Auth fail
> > at com.jcraft.jsch.Session.connect(Unknown Source)
> > at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:116)
> > at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> > at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> > at com.slim.softsqueeze.Application.main(Application. java:53)
> > 16 [main] WARN softsqueeze - Exception in connect
> > java.io.IOException: Auth fail
> > at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:142)
> > at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> > at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> > at com.slim.softsqueeze.Application.main(Application. java:53)
> >
>

Roy Owen
2005-10-05, 12:00
The tunnel should be started from the same machine that is running
softsqueeze. If you have Cygwin installed the ssh client there will work.
Add the following to your ~/.ssh/ssh_config

Host MyServer
HostName Myserver
GatewayPorts no
TCPKeepAlive yes
Compression no

#port forwarding for slimserver
LocalForward 9000 LocalHost:9000
LocalForward 3483 LocalHost:3483

Then in xterm type ssh MyServer -N -f If every thing is set up correctly
this will create a tunnel with out the need to keep xterm open. I use a
similar setup to create a tunnel for my SBG.

On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
>
> On 10/5/05, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
> >
> > You didn't say what OS you are using, I'll assume MS Windows. Have you
> > tried using a client like tunnelier from BitVise or PuTTy? I've found that
> > using a seperate ssh client to create the tunnel and forward the ports is
> > quite often more reliable.
>
>
> I'll start with SoftSqueeze on Windows (cygwin available) to access
> slimserver on Linux. On which side are you suggesting to build the tunnel?
>
> Thanks.
> --Wendy
>
>
> On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
> >
> > > I can't seem to make SoftSqueeze tunnel over ssh, even though I can
> > > start a normal ssh session to the machine. It shows "ssh connecting" then
> > > "Connection failed. Please check server settings." The not-very-informative
> > > messages on the command line are below.
> > >
> > > Thanks for any suggestions.
> > > --Wendy
> > >
> > > wseltzer@wmstab ~/c/Program Files/Softsqueeze
> > > $ java -jar SoftSqueeze.jar
> > > 16 [main] ERROR ssh - Cannot connect ssh tunnel
> > > com.jcraft.jsch.JSchException: Auth fail
> > > at com.jcraft.jsch.Session.connect(Unknown Source)
> > > at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:116)
> > > at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> > > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> > > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> > > at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> > > at com.slim.softsqueeze.Application.main(Application. java:53)
> > > 16 [main] WARN softsqueeze - Exception in connect
> > > java.io.IOException: Auth fail
> > > at com.slim.softsqueeze.SSHTunnel.connect(SSHTunnel.j ava:142)
> > > at com.slim.softsqueeze.SoftSqueeze.connect(SoftSquee ze.java:263)
> > > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:159)
> > > at com.slim.softsqueeze.SoftSqueeze.<init>(SoftSqueeze.java:98)
> > > at com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:459)
> > > at com.slim.softsqueeze.Application.main(Application. java:53)
> > >
> >
>

Wendy Seltzer
2005-10-05, 13:35
Thanks for the thorough response. That works beautifully. (until the network
connection gets congested and the flac streams start stuttering or
echoing...)

--Wendy

On 10/5/05, Roy Owen <yddraig (AT) gmail (DOT) com> wrote:
>
> The tunnel should be started from the same machine that is running
> softsqueeze. If you have Cygwin installed the ssh client there will work.
> Add the following to your ~/.ssh/ssh_config
>
> Host MyServer
> HostName Myserver
> GatewayPorts no
> TCPKeepAlive yes
> Compression no
>
> #port forwarding for slimserver
> LocalForward 9000 LocalHost:9000
> LocalForward 3483 LocalHost:3483
>
> Then in xterm type ssh MyServer -N -f If every thing is set up correctly
> this will create a tunnel with out the need to keep xterm open. I use a
> similar setup to create a tunnel for my SBG.
>
> On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
>
> > On 10/5/05, Roy Owen < yddraig (AT) gmail (DOT) com> wrote:
> > >
> > > You didn't say what OS you are using, I'll assume MS Windows. Have you
> > > tried using a client like tunnelier from BitVise or PuTTy? I've found that
> > > using a seperate ssh client to create the tunnel and forward the ports is
> > > quite often more reliable.
> >
> >
--
Wendy Seltzer
http://wendy.seltzer.org/blog/

geoffb
2005-10-05, 14:00
On 10/5/05, Wendy Seltzer <wseltzer (AT) gmail (DOT) com> wrote:
> Thanks for the thorough response. That works beautifully. (until the
> network connection gets congested and the flac streams start stuttering or
> echoing...)
>
> --Wendy

FWIW, I use Bitvise's Tunnelier (as suggested by another poster),
available free for non-commercial use here:
http://www.bitvise.com/tunnelier.html

This works beautifully with my (windows) OpenSSH server. It does a
great job of automating the login, and firing up SoftSqueeze
automatically.

It also sets up the correct port forwarding for web / CLI ports, and
includes a remote terminal server tunneling / activation (won't affect
you on Linux of course).

Cheers
Geoff