PDA

View Full Version : Help! Problems connecting wirelessly with WEP



shane79
2005-10-04, 15:57
Hi all:

I love my Squeezebox 1 but I have had not had any success with connecting to a secure (128 bit WEP) network. Thus, I have had to leave my network unsecure just so that I can use my SB!

Basically, I enter in my network key (triple-checked it for accuracy) into the SB, it says it is trying to connect to the network, but times out. It recognizes the SSID.

I have tried playing around with the settings on my router (D-Link DI-624), but to no avail. Also, I have no problems connecting two different laptops to the WEP network. It's just the SB that is having a problem.

Please keep your suggestions to an intermediate to high-level, as I do have a pretty good understanding of wireless networks. That's not to say I have missed something totally basic in my troubleshooting! :)

I saw some other guy in the forums having a similar issue: http://forums.slimdevices.com/showthread.php?t=16269&highlight=encryption
However, his fix didn't make any sense.

Thanks in advance!

-Shane

P.S. I have a second issue of lesser importance: when I fast-forward a song on the SB, the song becomes garbled when it returns to normal playback. Any ideas?

radish
2005-10-04, 16:25
I think this is a mode problem. WEP has 2 modes - Open and Shared, and your devices all have to be set to the same mode. Most support both (Open is considered more secure), but the SB1 only supports Shared (last time I checked). Most APs/Routers will allow you to select Shared mode, but some don't (my old SMC was one) - these won't work with an SB1.

According to this thread : http://forums.slimdevices.com/showthread.php?t=7414&highlight=DI-624 someone else has had the same problem with a DI-624, it might be worth checking if there's a newer firmware available for your hardware rev. Otherwise, chase up Dean on his promised firmware patch :)

shane79
2005-10-04, 17:10
Thanks a lot for the quick reply, Radish! I guess I read over the fact that Open mode was not allowed. Everything works now with the 128 bit encryption.

Do you have any ideas for my second problem?: fast forwarding causes the normal playback to be garbled - kind of like the fast forward function is "stuck" after I release the button on the remote. It's a major annoyance when I am trying to change positions in an audio book, for example.

Are there any performance (e.g. buffer size) parameters I could change that might affect this?

Thanks again!
-Shane

radish
2005-10-04, 19:51
FF doesn't work as a press-and-release, you have to press play to return to normal speed.

shane79
2005-10-04, 21:01
Radish,

Ahhhhh....OK. It's all making sense now :).

Thanks again for all your help. Thanks to you, my Squeezebox has reached "perfect" status from its previous rating of "near-perfect" :). I just needed to learn how to use it!

-Shane

radish
2005-10-04, 21:03
Glad to be of service :)