View Full Version : Missing files scandinavian letters

2005-10-03, 12:42
Since ver. 6 files with the norwegian letters ,, is not recognized and will not show up in the Slimserver. I have tried beta 6.2 where some unicode issues should have been resolved, but no luck. so its back to ver 5.4.1 for me. Any ideas out there? Changing filenames is not an option.
Using slimserver on Linux, managing collection with iTunes on mac


2005-10-03, 13:28
I've reported a number of bugs with handling of accents in 6.2 but now these characters (such as ) are all displayed correctly for me - using iTunes and Slimserver on a Mac.

2005-10-03, 13:30
Which version are you using? Dan did some work last Friday that helped with scanning of some of my files.

2005-10-03, 22:37
I tried 6.2 from 2. and 3. oct. nightlies, At the moment im back with 5.4.

2005-10-04, 09:44
One thing that I've done to try to help diagnose issues of this sort is to create a suite of test files that reflect the problematic filenames and metadata, but that contain no audio data so they are small enough to be easily emailed to the developers or posted to bugs.slimdevices.com. In my case, I created a WAV file of 60 seconds of silence using Goldwave and then encoded it with FLAC. My "null.flac" file that I use as a template for the test files is only 9kb before I add metadata.

Would it be possible for you to create some small "empty" test files in whatever encoding scheme you are using that duplicate the problems you are seeing and post them in a zip file to bug #2219? http://bugs.slimdevices.com/show_bug.cgi?id=2219

2005-10-04, 11:39
In order to try out your request, i installed Slimserver 6.1.1 (witch has displayed the same problems) on my powerbook, and imported a short audio file named with the letters in question. Viola, it shows up in Slimserver. To doublecheck i imported one of the tracks I earlier have been missing to itunes, and it to surfaced in the slimserver. Possible conclusion: its a linux problem ?? Im running mandrake 10.1

BTW will uppload a file to the bug report.

Thanks for helping guys, i appreciate it.

2005-10-04, 14:23
It turned out that my iMac (witch i use for ripping) is using UTF-8, and my Linux server (witch hosts the slimserver and music files) was using ISO-8859-1. I changed the locale on the linux box, and everything is ok. Thank you for your help guys. The thread http://forums.slimdevices.com/showthread.php?t=13007 explains.