PDA

View Full Version : Problem with 10-2-05 nightly build



mkosma
2005-10-03, 12:05
Having such horrid problems with stuttering and such, I decided maybe a clean install was the ticket. So I uninstalled SlimServer 6.1.2 and then installed 6.2 from the nightly 10-2 build.

Looks like everything installed correctly. I start up softsqueeze, select an album, but as soon as I hit the "play" button, softsqueeze displays a message that it has lost contact with slimserver. The process slim.exe appears to have vanished as soon as I hit "play."

Question 1: should that (a clean install of 6.2) have worked, or does it need to go "over" a previous version?

dean
2005-10-03, 13:11
Yes, it should have worked, but it looks like the server crashed.

It would be good to know why. Open the Event Viewer and see if there
are some events that happened when the server crashed. The text in
that event would be very helpful to post.



On Oct 3, 2005, at 12:05 PM, mkosma wrote:

>
> Having such horrid problems with stuttering and such, I decided
> maybe a
> clean install was the ticket. So I uninstalled SlimServer 6.1.2 and
> then installed 6.2 from the nightly 10-2 build.
>
> Looks like everything installed correctly. I start up softsqueeze,
> select an album, but as soon as I hit the "play" button, softsqueeze
> displays a message that it has lost contact with slimserver. The
> process slim.exe appears to have vanished as soon as I hit "play."
>
> Question 1: should that (a clean install of 6.2) have worked, or does
> it need to go "over" a previous version?
>
>
> --
> mkosma
>

mkosma
2005-10-03, 14:47
Ah. Good idea, that event viewer thingy. Here is the message (after the help and support stuff):


Undefined subroutine &Slim::Music::Info::info called at C:/Program Files/SlimServer/server/Plugins/Transitions.pm line 98.

mkosma
2005-10-03, 14:50
Hmm ... looks like I may have a stray plugin that didn't get deleted with my so-called clean install. You think?

mkosma
2005-10-03, 14:55
In fact, here is what's in my plugins directory. In terms of debugging this thing and eliminating my stuttering, are there any of these that do not belong? i.e., what's included there by default?

I'd like to keep scrobbler but not if it will cause troubles. Otherwise I only want the minimum needed....

DateTime
Picks
Rescan.pm
ShoutcastBrowser
Visualizer.pm
Favorites
Podcast
RssNews.pm
SlimScrobbleSupport
iTunes.pm
Live365
RPC.pm
SavePlaylist.pm
SlimTris.pm
MoodLogic
RadioIO
Scrobbler.pm
Snow.pm
MusicMagic
RandomPlay
ScrobblerReadMe.txt
TT

kdf
2005-10-03, 14:56
Quoting mkosma <mkosma.1wcj1c (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Ah. Good idea, that event viewer thingy. Here is the message (after
> the help and support stuff):
>
>
> Undefined subroutine &Slim::Music::Info::info called at C:/Program
> Files/SlimServer/server/Plugins/Transitions.pm line 98.
>
ah... This is a known bug. You have to get an updated version of the
Transitions lugin.
http://forums.slimdevices.com/archive/index.php/t-16418.html
-kdf

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

Triode
2005-10-03, 14:58
Transitions.pm isn't in this list - have you deleted it?

mkosma
2005-10-03, 15:21
By the way, thanks for the tip -- deleting transitions.pm eliminated the problem. Unfortunately, I am still experiencing the occasional stutter at the beginning of songs. Wish I could get this problem fixed, it's driving me batty.

mkosma
2005-10-03, 19:30
thanks, guys. I am going to leave out the transitions plugin (and other unneeded plugins) for now, because I am trying to debug this stuttering problem. Reportedly the next nightly is going to have the perfmon stuff built in, so hopefully I'll have more to share in the next couple days.