View Full Version : SlimServer 6.2 never opens

2005-09-30, 17:17
I have attempted to install SlimServer6.2 Beta a number of times now. The first couple times it would hork my machine. However, the last 4 attempts it never opens. It says that SlimServer is starting but never does. 6.1.1 and 6.1.2 work just fine.

- no error messages. SlimServer just never opens.
- OS: Windows XP Pro SP2
- Memory: 1GB
- Proc: AMD 64 2800+
- HD Space: 200GB with 130GB remaining

2005-09-30, 17:24
Try a quick uninstall/reinstall. Upon reinstall, check or uncheck the Automatic start, as you see fit. Once installed, use the slimtray to Start/Open slimserver.

Look at the Event Viewer (eventvwr.exe in Run is fastest way to start) - check Application logs, looking or messages from the slimserver service.

Check if slim.exe is running in TaskManager.

Report findings.

2005-09-30, 17:28
Already did all of that. Nothing in the Event Viewer. Yes, TaskManager says Slimserver.exe is running however, it never opens.

2005-09-30, 17:35
I know of slim.exe, not slimserver.exe. Is that what you meant?

I'm not sure if/how it matters, did you uninstall the old slimserver (6.1) software? There might be a conflict with the server\Cache folder w/the old software and the new. You could stop slim.exe, remove the Cache folder, and start it again.

2005-09-30, 17:37

Yup... always uninstall prior to re-installing SlimServer (including removing the folder form Program Files as it typically horks the machine if I don't

2005-09-30, 17:38
and you cannot connect via browser to:



2005-09-30, 17:38
it never starts....................... as in never!

2005-09-30, 17:43
tonymuffin, you'll have too be more specific. You say "it" never starts, meaning slim.exe, but then later you confirm that slim.exe is running. Then I ask if you can connect via browser, and you say "it never starts". Your browswer never starts? You get a timeout and an error page in IE when trying to get to http://localhost:9000 ?

Sorry, I just can't read minds yet, nor can I see your screen.

2005-09-30, 17:48
- Slim.exe is running in Task Manager
- Right clicking on The System Tray icon indicates it is running as well.
- SlimServer/Browser never launches, never starts ups, never starts...nada!
- As already stated....NO ERROR MESSAGES

2005-09-30, 17:54
Slow down... eat less sugar... and please read the questions a little more carefully. I'm trying to help you, but you're making it very difficult! :-0

What I'm trying to discover, is if you can manually launch your own browswer, and enter the URL i've indicated. What happens when you do that?

2005-09-30, 17:58
I am sitting down.... don't eat sugar.... am answering the questions

Yes, I can launch my browser. The browser works just fine. I can open the browser or feed the following into Start/Run: http://yahoo.com, http://msn.com etc, etc, etc...

NO, I cannot launch slimserver in the browser. NO, SlimServer will not launch in the browser with the URL you indicated, by clicking on the Desktop icon, by clicking on the System Tray icon... NO... SlimServer does not launch in the browser at all. I truly do not know how to make it any clearer.

2005-09-30, 18:01
am answering the questions

Really? I asked "What happens when you do that?" (ie. enter the URL). I still don't see the answer.

Try this as well:

Start->Run and enter "cmd" and open that program. From the commmand window, type:

telnet localhost 9000

and hit enter. Then type in a ? and hit enter and tell me what you get back.

2005-09-30, 18:03
wow.... you are kidding correct????

I have stated a number of times now...NOTHING HAPPENS! Nada! No go Joe! .....

The browser never opens with SlimServer...



telnet localhost 9000 / ?

HTTP/1.1 400 Bad Request
Date: Sat, 01 Oct 2005 01:22:12 GMT
Server: libwww-perl-daemon/1.02
Content-Type: text/html
Content-Length: 57

<title>400 Bad Request</title>
<h1>400 Bad Request</h1>

Connection to host lost.


2005-09-30, 18:27
This will be my last attempt to help.

Something *does* happen. My question to you was what do you see happening. Your answer NOTHING is completely bogus. You either see your browser spinning, never connecting and timing out, or you get back something on the page. I'm asking you what your browswer is telling you. NOTHING is not very helpful, since it doesn't really describe the various errors.

I've understood that a browser isn't opened automatically. Its not necessary to keep repeating this, as i got it, and this isn't at all my concern at the moment. Same with Event Viewer, same with Error Messages. I get it - you don't see any.

Have you tried telnet'ing as I suggested?

2005-09-30, 18:31
Actually... I am glad it is your last attempt... you are most unhelpful and do not follow the thread....

You can stuff it as far as bogus.
- nothing happens
- the browser does not open
- no error message
- no spinning
- no nothing
- only desktop
- no time out
- no messages

shall I use a bigger hammer?

2005-09-30, 18:32
I see we're missing each other's posts now.

The telnet experiment indicates that your slim server is running and responding. That's good!

So now, we're down to why the browser isn't able to connect / retrieve data.

I presume you are running IE. I also now presume that you are getting back an entirely blank page. If this is true, then I suspect your slim files do not have the correct permissions.

Please confirm the blank page in IE when you connect to http://localhost:9000 .

2005-09-30, 18:34
Why would Slim Server permissions all of a sudden change with 6.2 but not with previous versions?

Most current version of IE

No Blank Page!!!!

Only Desktop

Nothing Happens.................

2005-10-01, 02:05
are you expecting the browser to open a window itself ?? What if YOU open a broswer session and go the the local slim webpage ?

2005-10-01, 08:38
For clarification:
- When attempting to launch SlimServer 6.2 from either the system tray or the desktop icon, nothing happnes. No browser opens, no error message etc. Task Manager says Slim.exe is running.

- When attempting to open SlimServer 6.2 from the browser: Steps: 1. Open browser... default webpage comes up. 2. Enter http://localhost:9000... blank page appears, no spinning. It's as if SlimServer launched but it only is a blank page.


I flattened the box last night. Re-installed the OS (XP Pro SP2) with all Security and Critical updates. Downloaded SlimServer 6.2 from the site. Installed SlimServer 6.2

- When attempting to launch SlimServer 6.2 from either the desktop icon or the system tray again nothing happens, no messages. Task Manager says slim.exe is running

- I now can launch SlimServer 6.2 from within the browser (http://localhost:9000). SlimServer opens with the DEFAULT interface. The DEFAULT interface shows both Server and Player settings options. SlimServer goes through a scan of the music folder. I changed the DEFAULT interface to FISHBONE. It took an extremely long period of time for the interface to change to FISHBONE.

HOWEVER.............. now there is no PLAYER or SERVER settgins options. There is no way to configure SlimServer. Where did the PLAYER and SERVER settings options go in 6.2??

After rebooting the machine, SlimServer 6.2 will now open with the desktop icon and the system tray icon. However, there is still no SERVER or PLAYER settings options.

2005-10-01, 11:17
On 1-Oct-05, at 8:38 AM, tonymuffin wrote:
> for the interface to change to FISHBONE.
> HOWEVER.............. now there is no PLAYER or SERVER settgins
> options. There is no way to configure SlimServer. Where did the
> PLAYER and SERVER settings options go in 6.2??
did you try the pulldown menu in the top left of the fishbone skin?


2005-10-01, 13:11
You mean this one?


What doss that have to do with the SERVER or PLAYER settings?

2005-10-01, 13:22
On 1-Oct-05, at 1:11 PM, tonymuffin wrote:

> You mean this one?
> [image: http://timothydehan.com/temp/slimserverdropdown.jpg]
> What is that have to do with SERVER or PLAYER settings?
my apologies. i'll leave you alone now, and get back to my other tasks

2005-10-01, 13:29
Ok.... so where are the PLAYER and SERVER settings in the FISHBONE skin? They use to be at the top of the page. But they are not there any longer.

Jacob Potter
2005-10-01, 13:30
Can you post a full screenshot?

2005-10-01, 13:45

2005-10-01, 13:54
On 1-Oct-05, at 1:45 PM, tonymuffin wrote:

> http://timothydehan.com/temp/fullscreenshot.jpg
yes, the pulldown, top left that currently shows Browse Artists.
If you look at the bottom of the pulldown when you click it, you should
find both the server settings and the player settings for the current
selected player.


2005-10-01, 14:00
Nope.... Look at the previous image I posted for that drop down.


Thus my question as to what that drop down has to do with SERVER and PLAYER settings.

2005-10-01, 14:35
On 1-Oct-05, at 2:00 PM, tonymuffin wrote:

> Nope.... Look at the previous image I posted for that drop down. Thus
> my question as to what that drop down has to do with SERVER and PLAYER
> settings.
I've got a fix in for the next nightly build.

2005-10-01, 14:37
On 1-Oct-05, at 2:00 PM, tonymuffin wrote:

> Nope.... Look at the previous image I posted for that drop down. Thus
> my question as to what that drop down has to do with SERVER and PLAYER
> settings.
oh yeah, in the meantime you can simply use:
http://serverIP:9000/Default/ to get back to the default.

just change the serverIP to match your server IP address, or use
localhost if you are on the same machine.


2005-10-02, 07:48
The nightly build took care of PLAYER and SERVER settings. They now show up in the drop down.

However, what happened to the following?:
1. There is no longer the word CLEAR on the Player side that would clear anything in the current play list
2. When hovering over the covers in ARTWORK view, the title of the albums no longer appears (alt text)