PDA

View Full Version : Slimserver 6.2b1 , albums and songs missing - Unicode



NÚstor
2005-09-26, 22:40
Hi ,
since last week I've been trying Slimserver 6.2 (after a month without checking it).

About 60 (of about 700) albums do not show on the collection, also many song names are missing while looking at the list of songs of many albums.

All of the albums and songs missing, DO contain "special characters" , in the album name, or artist name or song name.

I use flac files with cuesheets, my cuesheets are saved as Unicode.

I went back and reinstalled 6.1.2 and all the missing items appear OK on that version. Tried again deleting everything and reinstalling 6.2b1, and again those albums and songs are missing.

Any idea? does someone else experience the same problem?

Thanks!
NÚstor

gharris999
2005-09-26, 22:59
You aren't alone. I don't think that 6.2 likes unicode cuesheets yet. Have you tried encoding them as UTF8?

NÚstor
2005-09-28, 07:41
Thanks to Dan fix in bug 2196 now I got all my albums back (thanks Dan! :-) )


I did not get ALL my tracks, genres , and years back (many of them are missing) but I will recheck theres no something else going on with my tags before opengin a bug.

NÚstor

gharris999
2005-09-28, 12:13
Nestor: I've opened up bug 2215 which might describe your situation. http://bugs.slimdevices.com/show_bug.cgi?id=2215

NÚstor
2005-09-28, 13:08
Hi Gordon,
I will check that, thanks!

I have found the reason for my ever growing list of genres and years missing! It was strange because everytime I fixed a batch of files with some embedded cuesheet I found that my genres or years classification was shrinking.

So my problem is:

My embedded cuesheets _do not contain_ the genre or the year for the albums (because my EAC configuration just put that info in the specific VORBIS comments for genre, year (plus artist and album). So I think, because im using an embedded cuesheet, SlimServer is completely ignoring my Vorbis GENRE and YEAR tag ( and I suspect its ignoring the REPLAY_GAINs too, but because Im not using them at all yet I didnt notice).

Does this make any sense? If so , is it that the expected behaviour? Would hate to go through every file, modifying the embedded cuesheet to add this.

Let me know your opinion, and I will open a bug, if this seems like something that can be fixed.

Thanks
NÚstor

gharris999
2005-09-28, 21:42
I've written a win32 console utility program in C that fixes up cuesheets so that each track gets a GENRE tag and a ARTIST tag, etc. The utility also grabs information out of the CDPLAYER.INI file to help flesh out the information in the cuesheet file. (Album and track comments, etc). It saves a lot of labor. I almost never have to "hand edit" a cuesheet file any more. If you are interested, I'd be happy to send the utility and source code to you to play with.

I'm also having lots of problems with Slimserver 6.2 recognizing the genre of my whole-album flacs with embedded cuesheets. I've opened up bug #2219 http://bugs.slimdevices.com/show_bug.cgi?id=2219

I think something is killing records in the genre_track table. I'm ending up with only a handful of records there.

NÚstor
2005-09-29, 06:43
Hi Gordon, it would be great if you can send me that!

gharris999
2005-09-29, 06:58
I'll post a link to it later today.

gharris999
2005-09-29, 15:22
Sorry for the delay. Satelite internet doesn't work when it's raining. My fixcue (and other) tools are here: http://home.earthlink.net/~gharris999/fixcue/fixcue.zip