PDA

View Full Version : Slimserver using 100% cpu every minute



gorstk
2005-09-23, 15:52
Using latest nightly 23/9, mandrake linux, pentium 3 1ghz, musicmagic, SB1

Around every one minute slimserver takes up 100% of my processor useage
making the server unuseable for interactive tasks for a few seconds.
Music or scrolling on my SB1 is not affected. This occurs again about a
minute after CPU useage returns to normal.

Any idea what even can be occurring around about every minute?

This occurs with or without the web interface open and with or without
the SB1 playing or not (or even switched off).

I cant think of anything special other than music magic.

This problem seemed to start occurring in a nighlty around abotu 2 weeks
ago.

Any ideas?

Cheers

mherger
2005-09-23, 22:22
> I cant think of anything special other than music magic.

Turn it off for a test. And any other plugin you're using. If this helps,
turn them on, one after another, until you see the problem again.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

gorstk
2005-09-26, 13:42
John Gorst wrote:
>
> Using latest nightly 23/9, mandrake linux, pentium 3 1ghz, musicmagic, SB1
>
> Around every one minute slimserver takes up 100% of my processor useage
> making the server unuseable for interactive tasks for a few seconds.
> Music or scrolling on my SB1 is not affected. This occurs again about a
> minute after CPU useage returns to normal.
>
> Any idea what even can be occurring around about every minute?
>
> This occurs with or without the web interface open and with or without
> the SB1 playing or not (or even switched off).
>
> I cant think of anything special other than music magic.
>
> This problem seemed to start occurring in a nighlty around abotu 2 weeks
> ago.

Just disabled MusicMagic plugin and this behaviour is resolved.

The output of --d_musicmagic is included below.
Note the read of the ?musicmagic cache every one minute, presumeably to
see if the musicmagic database has been updated. Also the missing file.

Whilst sometimes it only takes a second to read this file, at other
times it takes upto 3 seconds. It actually makes the desktop unuseable
for 4 seconds, with a 4 second pause on the 'top' output.

I have the "musicmagic reload interval" set to 6000, so I dont
understand why this is being updated so often. Any ideas?

2005-09-26 21:33:40.3487 MusicMagic: Testing for API on localhost:10002
2005-09-26 21:33:40.8243 MusicMagic: Predixis MusicMagic Mixer. Version
1.1.6 (note same problemw ith old version of msuicmagic)

2005-09-26 21:33:40.8265 MusicMagic: get filters list
2005-09-26 21:33:42.1182 MusicMagic: get filters list
file error - plugins/MusicMagic/mixerlink.html: not found
file error - plugins/MusicMagic/mixerlink.html: not found
(snip)
file error - plugins/MusicMagic/mixerlink.html: not found
file error - plugins/MusicMagic/mixerlink.html: not found
file error - plugins/MusicMagic/mixerlink.html: not found
2005-09-26 21:34:41.5838 MusicMagic: read cacheid of 1126148026
2005-09-26 21:34:41.7699 MusicMagic: got status - idle
2005-09-26 21:35:44.6747 MusicMagic: read cacheid of 1126148026
2005-09-26 21:35:44.8549 MusicMagic: got status - idle
2005-09-26 21:36:45.1854 MusicMagic: read cacheid of 1126148026
2005-09-26 21:36:48.9182 MusicMagic: got status - idle
2005-09-26 21:37:51.8544 MusicMagic: read cacheid of 1126148026
2005-09-26 21:37:52.0355 MusicMagic: got status - idle