View Full Version : SB2 freaked out now can't connect

2005-09-20, 21:41
I was playing a large playlist and the SB2 freaked out: wierd sounds and the display was totaly lit up (no characters just every portion lit). When I unpluged the sb to reset/reboot it came up as usual but all previous settings were wiped out. I selected my network, reneterd WEP (in hex) and it would not connect. Tried this several times and unplugged for a day. Still countdown but no connect. I tried holding power button for a reset, same thing reenter all info countdown no connect. I reinstalled slimserver, it is running on port 9000. I am running Windows XP pro

my current network settings:
Wireless encription: 64 bit
Wireless signal strength: 85-96
SSID: (Selected properly)
SlimServer 0.000(0000)
DNS server
Bridge wireless network to ethernet: no
Firmware version: 14
Connect via: Wireless
Obtain IP automatically (DHCP)

Help please I miss my squeezebox

2005-09-20, 21:49
Try a hard reset. Unplug the power, keep Add held down and plug it back in. You should see "Factory Reset".

2005-09-20, 22:19
I just tried hard reset and even tried a ethernet connection and squeezenetwork but to no avail. I tried to ping my PC start run cmd ping, but I can't remember the proper usage of ping command.

2005-09-21, 07:15
ping <ip address>

2005-09-21, 07:25
On Sep 20, 2005, at 9:41 PM, huang wrote:
> IP
This indicates that your Squeezebox was unable to obtain a DHCP address.

One thing you didn't list was the MAC address. The version of the
firmware that you are using has a bug in it that can trigger the
corruption of the MAC address. Please confirm that the MAC address
listed in the View Current Settings menu is identical to the one
printed on the bottom of the player. If it's not, then press RIGHT
on that screen and re-enter the MAC address.

Let us know if that solves your issue.

2005-09-21, 18:47
When I an scrolling through the check network settings the MAC address comes up ff.ff.ff.ff but I do not seem to be able to change anything.

2005-09-21, 21:39
YeeeeeHA the mac address did it!!! I also updated the firmware. Thanks to all who enabled me to close my eyes and enjoy the sublime sqeeze pleasure. Miles Davis Kind of Blue through Squeezebox2 BAT and Dunlavy mmmmmmmmmm.

Why did it freak in the first place?

2005-09-22, 10:29
Congrats, and nice selection of music.

There was a firmware MAC address corruption bug in earlier firmware. Your firmware update and reset resolved the problem.

2006-01-19, 20:25
I just had this happen to me twice this week. The first time, I just went back in and re-entered the WEP key and everything went back to normal. Today, I got the freakout as described above but then was not able to connect to the wireless access point. It turns out that the MAC address was corrupted as detailed above.

The reason that I am writing this is that my firmware version is 16 - two versions after the one that had the bug? Does anyone have any insight into this? Should I upgrade my firmware? If so, do I also have to update Slimserver?


2006-01-21, 05:46
The firmware is updated in sync with the server. If you upgrade to a reasonably recent server, it will upgrade the SB as well.

You wrote: my firmware version is 16

I'm not sure what you mean. Current firmware versions are, according to http://wiki.slimdevices.com/index.cgi?HardwareComparison , 28 for SB2/3 and 40 for SB1.

Can you tell us where you saw the 16?

2006-01-21, 18:35
If you go to Settings -> Information -> Firmware, you get '16'. And yes, this is a SB2 that I am dealing with. I think that server version is prior to the SB3 being released.

Reliability and sound quality are key to me. I am willing to upgrade the server provided that there is no loss to either one of these. Two freakouts in a single week, after nearly a year of perfect service, is not considered a huge problem.