PDA

View Full Version : "no album"



maxman
2005-09-19, 11:19
Hi,

I've got a lot single songs. They are not associated with an album, hence have album tag empty.

Slimserver picks these up as 'no album' when browsing for music. I noticed that when browsing from artist to 'no album' to song the squeezebox then lists all songs that have the album tag empty. Is this the expected behavior? How can I fix this?

eg browse artist - then browse album - then get list of all mp3's that do not have an album tag from various artists

DJMUK
2005-09-19, 13:34
How about giving these tracks an 'Album Name' such as 'Singles - Artist Name'. Then when you browse by artist you would get a list of the artists actual albums plus the 'singles' album.

I would suggest, as I have shown above, that you add the artist name to the 'singles' album as this should ensure SlimServer lists them correctly.

For example:
Singles - ABC
Singles - DEF

I have very few singles but use a dummy ?????? name of 'Misc' so they get shown with the artists full albums.

David

EDIT: Last sentance should be: I have very few singles but use a dummy ALBUM name of 'Misc' so they get shown with the artists full albums.

maxman
2005-09-20, 08:28
Thnx for this idea.. i wonder though why the design cannot just ignore albumtag altogether when it is empty and only show album when relevant?

DJMUK
2005-09-20, 09:17
Thnx for this idea.. i wonder though why the design cannot just ignore albumtag altogether when it is empty and only show album when relevant?

You should file an enhancement request giving details of how you think it should work at:

http://bugs.slimdevices.com/

That's the way the program gets improved!

maxman
2005-09-21, 07:08
ok thnx I did just that.