PDA

View Full Version : Various Artist / Multiple items in tags



Dan Sully
2005-09-13, 15:16
For those of you not watching the checkin messages, I've just checked in a
large update to handle these bugs: 1209, 1659, 1913, 1951, 2055, 2056, 2057, 2066 & 2075

* All Behavior settings are now dynamic.

* 'Various Artists' (localized) appears at the top of the Artist level listings.

* TRACKARTIST is no more.

* An Explict ALBUMARTIST tag will override any VA Auto-identification setting.

* Introduced a contributor_album table - which acts just like the
contributor_track table, but only one step/join is required to get to a list
of contributors for an album.

* Various Artist album Auto-identifcation happens only when an album has
multiple artists, and all of the tracks in that album are not the same
combination of artists.

* Multiple artists are shown in listings: IE: Ella Fitzgerald, Louis Armstrong

* Don't include Composer, Conductor, Band are now individual checkboxes.

* Moved ContributorTrack & GenreTrack->add into Contributor & Genre respectively.

* Default auto-identifcation & useBandAsAlbumArtist to Off.

* Cleanup Setup a bit, and move VA config to be 2nd from the top in Behavior.

* Get rid of Slim::Music::Info::infoHash() & info() - which were only being called by one function.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?

dip
2005-09-14, 08:58
Thanks Dan for the great update. VA handling seems to me now much more transparent since TRACKARTIST is no longer used.

I tested all problematic cases for which I filed different bug reports (which are now closed as solved) and it seems that most of the problems do no longer exist, but (unfortunately) not all.

1. Bug 2057 is not solved. As described in Bug 2057 VA albums containing OGG VORBIS files having accented characters in the ALBUM tag are not detected as VA albums. All artists are listed in Browse Artists and in browse albums the album name is listed not only once but so often as different artist are on the album. When I tag the album manually with ALBUMARTIST=Various then everything is ok.

2. Bug 2066 is not solved in SOME cases. I have an album on which all but TWO songs are of Artist1 and these TWO songs are duetts of "Artist1 and Artist2" and "Artist1 and Artist3", respectively. All songs are OGG VORBIS files and for these two songs the ARTIST tag is set to "Artist1 & Artist2" and "Artist1 & Artist3", respectively ("&" is set as separator). For this album the new Compilation flag is set to "Yes" ALTHOUGH ALBUMARTIST IS SET TO "Artist1" (so it should be an "Artist1" album and not a VA album).

I played a little bit around and found that this happens only with OGG VORBIS files but not with mp3 files. In addition I found that even with OGG VORBIS files this happens only if there are AT LEAST TWO files with two DIFFERENT second artists. That means if there is only one song with "Artist1 & Artist2" the album is correctly not classified as VA album. And if there are several duets on the album BUT ALWAYS WITH THE SAME SECOND ARTIST (e.g. "Artist1 & Artist2) then the album is also correctly not classified as VA album.

3. When searching on my Squeezebox for an artist, always "Various" is in addition found and shown as first entry. Even when I search for xxxx (which does not exist) "Various" is shown as "matching" result. I tested this only with Softsqueeze at the moment).

4. When I am on the song info page and click on the artist (in the web interface) all albums of this artist are shown. When I then click on one of the shown albums which is a VA album, only the songs of the selected artist are shown. This is the correct behavior. But on the Squeezbox (Softsqueeze) when showing the song info of a song, scrolling to artist and pressing right, always only the starting album is shown (1 of 1). All other albums of this artist are not shown starting from song info.

5. When using the standard title format with the default skin the song lists in the web interface (available through browse artists or browse albumgs) contain an artist link (e.g. SONG TITLE from ALBUM by ARTIST). If I click on the ARTIST link then ALL albums are shown not only the albums of this specific artist.

This sounds worse than it is. I think with the new changes VA album handling is much improved and there is only a little step to perfect handling left...

dean
2005-09-14, 11:14
Thanks, dip.

I updated bugs 2057, 2066. Also opened bugs 2122, 2123, and 2124.

Feel free to add additional information or add your email address for
status and/or questions.

-dean
>

Philip Meyer
2005-09-14, 12:50
Cue sheets don't seem to be working with Various Artists.

I have a cue sheet with an album artist (PERFORMER "tag"), with each track having a PERFORMER tag. Only the tracks that have a different artist to the album artist are listed for the album under Various Artists. I can't find the other tracks.

Phil

dean
2005-09-14, 13:05
Please file a bug on http://bugs.slimdevices.com/ and attach the
sample cue sheet. That would help us a lot.

Thanks,

dean

On Sep 14, 2005, at 12:50 PM, Philip Meyer wrote:

> Cue sheets don't seem to be working with Various Artists.
>
> I have a cue sheet with an album artist (PERFORMER "tag"), with
> each track having a PERFORMER tag. Only the tracks that have a
> different artist to the album artist are listed for the album under
> Various Artists. I can't find the other tracks.
>
> Phil
>

Philip Meyer
2005-09-14, 15:01
>Please file a bug on http://bugs.slimdevices.com/ and attach the
>sample cue sheet. That would help us a lot.
>
Okay - bug 2126 created.

I noticed that I have another cue sheet for a various artist album where the album artist has been set to "Various Artists". This works okay - I added a partial example to the bug report.

BTW, is it possible to add a disk number (DISCNUMBER n/n or PARTINSET n/n?) "tag" to the tracks in a cue sheet? I have a three-cd set each cue sheet defining a disk with the same album name with tracks 1-15, so Slimserver catalogs this as one album with three track 1's, followed by three track 2's, etc. I'd like all disk 1 tracks first, then disk 2, etc. This works okay for individual mp3 tracks when I use PARTINSET or DISCNUMBER.

Phil

MrC
2005-09-15, 10:41
* All Behavior settings are now dynamic.

In 6.2b1 - svn 4294, it does not appear that the "Multiple Items In Tags" is dynamic. I had to rescan to have the setting take affect. Should rescan be necessary, and is this a bug?

Dan Sully
2005-09-15, 10:46
* MrC shaped the electrons to say...

>> * All Behavior settings are now dynamic.
>
>In 6.2b1 - svn 4294, it does not appear that the "Multiple Items In
>Tags" is dynamic. I had to rescan to have the setting take affect.
>Should rescan be necessary, and is this a bug?

Sorry - I should have been more specific. The Various Artists based settings
are dynamic. The tag splitting still needs to happen at scan time.

-D
--
"A good messenger expects to get shot." --Larry Wall

MrC
2005-09-15, 11:02
That does make more sense. Thanks for the clarification.

By the way, bug 1995 that I reported about some tracks showing as the artist "1" appears to be fixed with this, and perhaps other recent various artists/compilation fixes.

http://bugs.slimdevices.com/show_bug.cgi?id=1995

mikerob
2005-09-16, 14:55
I would like to understand the expected behaviour of the new Various Artist implementation.

With "List Compilation albums under each artist" set under Server Settings / Behavior / Compilations, I still see "Various Artists" when browsing by artists on the web browser.

Also when searching by artist on the remote control, the search always returns "Various Artist" as the first entry after entering the search (the artists actually matching the search phrase can be found when scrolling down from "Various Artist")

Is there any way of totally disabling "Various Artist" so you only see the artists that have actually been tagged?

dip
2005-09-19, 02:45
VA handling works now perfectly for me. All described bugs are now really solved. Thanks again for your great work!

dip
2005-09-25, 12:14
4. When I am on the song info page and click on the artist (in the web interface) all albums of this artist are shown. When I then click on one of the shown albums which is a VA album, only the songs of the selected artist are shown. This is the correct behavior. But on the Squeezbox (Softsqueeze) when showing the song info of a song, scrolling to artist and pressing right, always only the starting album is shown (1 of 1). All other albums of this artist are not shown starting from song info.

I have found one issue similar to item 4. above. When "browsing for an artist" which has both complete albums as well as single songs on VA albums using the web interface on slimserver ALL albums (the complete AND the VA albums) are shown for this artist. On the squeezebox using the remote, however, only the complete albums are shown. There should also the VA albums be shown as in the web interface.

When I use "search for artists" instead also on the squeezebox ALL albums containing songs of this artist are correctly shown (even the VA albums).

dean
2005-09-25, 21:04
Great, can you submit the details in a bug at http://
bugs.slimdevices.com/

Thanks!

On Sep 25, 2005, at 12:14 PM, dip wrote:

>
> dip Wrote:
>
>>
>> 4. When I am on the song info page and click on the artist (in the
>> web
>> interface) all albums of this artist are shown. When I then click on
>> one of the shown albums which is a VA album, only the songs of the
>> selected artist are shown. This is the correct behavior. But on the
>> Squeezbox (Softsqueeze) when showing the song info of a song,
>> scrolling
>> to artist and pressing right, always only the starting album is
>> shown (1
>> of 1). All other albums of this artist are not shown starting from
>> song
>> info.
>>
>>
> I have found one issue similar to item 4. above. When "browsing for an
> artist" which has both complete albums as well as single songs on VA
> albums using the web interface on slimserver ALL albums (the complete
> AND the VA albums) are shown for this artist. On the squeezebox using
> the remote, however, only the complete albums are shown. There should
> also the VA albums be shown as in the web interface.
>
> When I use "search for artists" instead also on the squeezebox ALL
> albums containing songs of this artist are correctly shown (even
> the VA
> albums).
>
>
> --
> dip
>

dip
2005-09-25, 22:44
Already done. Bug 2192
Dieter