PDA

View Full Version : iTunes 5.0 and the iTunesUpdate Plug-In



jhurley
2005-09-11, 09:39
Anyone else been experiencing serious problems since a v5 upgrade?

I've had to disable the update plug-in in order to continue using my squeezebox.

I'm using the Windows version, not as a service, with direct iTunes update enabled, and was experiencing a crash each time the first track of my album/playlist ended as it attempted an iTunes update.

This was evidenced by a small dialog box with the message "Error loading Postback", and a number, usually in the 12,000's.

This caused the slim.exe application running in background to terminate and obviously my squeezebox lost connection due to the fact that the server application had terminated.

Disabling the plug-in fixes the problem. iTunes v5.0 is the only variable between a working and non-working setup.

Craig, James (IT)
2005-09-12, 06:35
Thanks for the warning - I've been away so I haven't had the time to
install iTunes 5.0 yet.
I think I will try it on my laptop first now...

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

James
2005-09-12, 11:24
Well I just installed SlimServer and iTunesUpdate on my laptop, which has been upgraded to iTunes 5.0 from 4.9 and it works fine for me. Phew.

Interestingly the only hit on google for "error loading postback" is slimdevices itself - and it appears to be a bug in the default2 skin fixed in 6.1 - what version of SlimServer & which skin are you using?

James

jhurley
2005-09-20, 10:10
SlimServer Version: 6.1.2 - 3660 - Windows XP - EN - cp1252

Skin: Default2

Strange it only happens when a track finishes, and I have no browsers open, only an idle PC!

Craig, James (IT)
2005-09-20, 10:18
I can only suggest trying 6.2 instead.

I'm having no problems with iTunesUpdate & iTunes 5.0 on SS 6.2.

(I found the iTunes scan in 6.1 to be very unreliable and stopped using
it some time ago.)

James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

jhurley
2005-09-20, 10:45
I'm going to try 6.2. However my vulcan logic says there has to be a plug-in issue... surely.

This worked: iTunes 4.9x | Slim 6.12 | iTunesUpdate 1.4
This didn't: iTunes 5.00 | Slim 6.12 | iTunesUpdate 1.4
This does : iTines 5.00 | Slim 6.12

jhurley
2005-09-20, 11:10
6.2 didn't sort it. Hrrrmphh.

jhurley
2005-09-20, 14:43
Broken: Slim 6.2 | iTunes 5.0 | iTunesUpdate 1.4
Working: Slim 6.2 | iTunes 5.0

James
2005-09-21, 00:59
how annoying!
can you enable the iTunes Update plugin to write messages to the log, and the --d_plugins debug output for good measure, and send me the output?

James

jhurley
2005-09-21, 02:04
I have just completed a full de-install and re-install of iTunes 4.9 and SlimServer 6.2b.

Everything is working fine, with the plug-in enabled. So I'm back to my working pre-v5 setup.

I am contemplating re-attempting a v5 iTunes upgrade now, but

(a) I'm not sure why
(b) I don't know that I can be bothered

I can't help thinking there's must have been something funky in my setup causing it....

I do have installed and use MusicMatch Jukebox as well as iTunes, but I can't imagine that's having any impact.

jhurley
2005-09-21, 05:39
I did a 5.0 update on top of my clean re-install of 6.2b and 4.9 and.... it works!

iTunesUpdate 1.4 working cleanly with iTunes 5.0.

Thanks
Jon

Craig, James (IT)
2005-09-21, 05:47
Phew.

BTW Apple released iTunes 5.0.1 today ;-)


James
--------------------------------------------------------

NOTICE: If received in error, please destroy and notify sender. Sender does not waive confidentiality or privilege, and use is prohibited.

jhurley
2005-09-21, 06:00
Spookily enough it's 5.01 that I've installed.

So I guess I'll never really know if it was a 5.0 problem! Common sense tells me it was an issue at my end.