PDA

View Full Version : Ogg Vorbis problems



eq72521
2005-09-05, 16:17
I hope that this is the right forum.

I've been running SlimServer 5.4 on FreeBSD 5.3 for 7+ months with few problems. This weekend I decided to attempt the latest stable version (6.1.1). First I ran into a problem with a couple .CUE files that seemed to be causing a server crash during indexing (as best I could tell from what showed in the log), but I renamed them to CUE.txt (because I didn't use them anyway with SlimServer) and that was fine.

Next, I found that Ogg Vorbis wouldn't play. I went into "Server Settings | File Types" and attempted to check the "Ogg Vorbis - AIFF" checkbox. No good, sox wasn't installed. I installed sox by doing "make, make install" in /usr/ports/audio/sox/, which seemed to work. Now, I could check the box in "Server Settings | File Types". However, when I attempted to play an Ogg Vorbis file, it doesn't and I get the following in the log:

/usr/local/bin/sox: Unknown input file format for '/music/all/Amos, Tori/From The Choirgirl Hotel/01 - Spark.ogg': File type 'ogg' is not known

Noting that the new version of SlimServer was using sox instead of oggdec, I decided to uncomment the lines in convert.conf for converting ogg to wav, since this is what works fine in SlimServer 5.4:

ogg wav * *
[oggdec] -Q -o - -R $FILE$

I then restarted the server, went back to "Server Settings | File Types", unchecked the "Ogg Vorbis - AIFF" and checked "Ogg Vorbis - WAV" (again, the same setting I use in SlimServer 5.4). Upon trying to play an Ogg Vorbis file this time, I see in the log:

/usr/libexec/ld-elf.so.1: Shared object "libm.so.2" not found, required by "oggdec"

If I go back to 5.4, everything works fine again.

Any ideas? I'm in the process of re-ripping my collection (hopefully for the final time) and saving as FLAC, but I still have hundreds of CDs saved as OGG, and it will probably take me some months to get through everything. Although nothing was wrong with 5.4, I'm sure there are new features and benefits to using 6.1 and I'd like to be able to do so, but not at the expense of not being able to play ~43% of my collection.

eq72521
2006-04-27, 12:15
No one responded (see quoted message below) last September so I went back to 5.4. Recently I purchased an SB3 which I believe requires 6.x, so solving this issue became more important for me. I just managed to do so and am posting a followup in the unlikely event that someone else runs into the same problem.

As noted below, sox didn't seem to know anything about Ogg Vorbis files, despite the fact that I had libogg and libvorbis installed prior to installing it. The issue is that the sox port in FreeBSD 5.3-STABLE has a typo in its makefile. It was looking for "libvorbis.so.2" on line 34. libvorbis on my system is libvorbis.so.3. Further down in the Makefile (line 45), it correctly references "vorbis.3". Fixing line 34 so that it was looking for "libvorbis.so.3" and then uninstalling, remaking, and reinstalling fixed the problem. sox can now deal with Ogg Vorbis files and everything plays perfectly on my SB1 using SlimServer 6.2.2. Next step: moving the SB1 downstairs and installing the shiny new SB3. :)


I hope that this is the right forum.

I've been running SlimServer 5.4 on FreeBSD 5.3 for 7+ months with few problems. This weekend I decided to attempt the latest stable version (6.1.1). First I ran into a problem with a couple .CUE files that seemed to be causing a server crash during indexing (as best I could tell from what showed in the log), but I renamed them to CUE.txt (because I didn't use them anyway with SlimServer) and that was fine.

Next, I found that Ogg Vorbis wouldn't play. I went into "Server Settings | File Types" and attempted to check the "Ogg Vorbis - AIFF" checkbox. No good, sox wasn't installed. I installed sox by doing "make, make install" in /usr/ports/audio/sox/, which seemed to work. Now, I could check the box in "Server Settings | File Types". However, when I attempted to play an Ogg Vorbis file, it doesn't and I get the following in the log:

/usr/local/bin/sox: Unknown input file format for '/music/all/Amos, Tori/From The Choirgirl Hotel/01 - Spark.ogg': File type 'ogg' is not known

Noting that the new version of SlimServer was using sox instead of oggdec, I decided to uncomment the lines in convert.conf for converting ogg to wav, since this is what works fine in SlimServer 5.4:

ogg wav * *
[oggdec] -Q -o - -R $FILE$

I then restarted the server, went back to "Server Settings | File Types", unchecked the "Ogg Vorbis - AIFF" and checked "Ogg Vorbis - WAV" (again, the same setting I use in SlimServer 5.4). Upon trying to play an Ogg Vorbis file this time, I see in the log:

/usr/libexec/ld-elf.so.1: Shared object "libm.so.2" not found, required by "oggdec"

If I go back to 5.4, everything works fine again.

Any ideas? I'm in the process of re-ripping my collection (hopefully for the final time) and saving as FLAC, but I still have hundreds of CDs saved as OGG, and it will probably take me some months to get through everything. Although nothing was wrong with 5.4, I'm sure there are new features and benefits to using 6.1 and I'd like to be able to do so, but not at the expense of not being able to play ~43% of my collection.