PDA

View Full Version : Songs show in search, but not in Browse artist



egauthier
2005-09-02, 17:37
I have a problem that I don't know how to debug.

If I Browse Artist to a specific artist, I only see one Album from the artist when I know there are 6 albums there.

If I search for a song (that I know is there on an album that is not displayed under Browse Artist) it is found. Then I click on the artist name in the search results, I get the correct full list of all the Albums from that artist.

I don't know where to start with this one. The database clearly has all the artist/album information as it is displayed correctly when clicked through on the artist via the search results.

I did set d_file and when rescanning the library and see that the song files are found.

using iTunes, on "SlimServer Version: 6.1.1 - 3774 - Linux - EN - utf8"

Thanks for any help.

Regards,
-Eric

mikerob
2005-09-03, 01:48
Have the missing albums been filed under "Various Artists"?

Recent functionality in the 6.2 release means that Slimserver will do this if the compilation tag is set - I don't know if this is also in 6.1.1.

egauthier
2005-09-03, 08:12
Mikerob,

Thanks, but no it doesn't show under Various Artists.

It is the strangest thing. An Advanced Search for the Artist doesn't find the Albums. When I search for a song that I know is there, the search results show the artist correctly.

However, the one album that does show up normally under "Browse by Artist" shows the artist "id" as 1491 when I hover over the link.

When I hover over the artist link in the search results of the "missing song" the artist "id" shows as 848. All of the "missing" tracks have this artist id.

So, it appears that there are 2 different artists being created for the same artist string. I have verified with a tag editor and in the iTunes Library.xml file that the Artist strings are identical.

I am running a rescan right now with d_info to see if that can tell me anything.

Regards,
-Eric

Ben Sandee
2005-09-03, 09:46
On 9/3/05, egauthier <egauthier.1usgqz (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
> So, it appears that there are 2 different artists being created for the
> same artist string. I have verified with a tag editor and in the iTunes
> Library.xml file that the Artist strings are identical.
>
>
Dan's put in a few fixes over the last few weeks for issues similar to this..
If you're game, you could try the nightly builds to see if the fixes for
your problems have already been implemented. In general, I've found the
nightly builds very stable once I adjusted to the new behaviors
(particularly those related to Various Artist albums).

Ben

markc
2005-09-04, 07:41
I am having exactly the same problem, running the 6.2b1 - 4156 nightly. Many artists and albums are missing from the library while browsing even though I can search the library and find them. I have tried rescanning, rescanning with clear library set, and exiting slimserver then deleting the database then restarting slimserver, all to no avail. The d_scan looks clean, and the tags are fine. This started happening about 3-4 weeks ago. Anyone else seeing this, or have any ideas for what could be happening? Thanks in advance for your help.

markc
2005-09-04, 12:55
A quick update: Unistalling the recent slimserver nightly that I had installed, and re-installing the 6.1.2 maintenance branch fixes the problem for me, so it must have something to do with the most recent changes to the nightlies.

Neil Cameron
2005-09-05, 03:11
It didn't work for me. I still have a small number of CDs or individual
tracks that consistently refuse to show up on a rescan, for no apparent
reason at all although I can browse to them OK. This is now the only issue
I have with SlimServer and is very frustrating...

But it did solve my Alien BBC problem; which now works perfectly!

--
Neil


"markc"
<markc.1uuolz (AT) no-mx (DOT) forums.slimdevices.com>
wrote in message news:markc.1uuolz (AT) no-mx (DOT) forums.slimdevices.com...
>
> A quick update: Unistalling the recent slimserver nightly that I had
> installed, and re-installing the 6.1.2 maintenance branch fixes the
> problem for me, so it must have something to do with the most recent
> changes to the nightlies.
>
>
> --
> markc

egauthier
2005-09-06, 17:21
I have tried with the nightly 6.1.2, then went back to 6.1.1, then went to nightly 6.2.

Somewhere along the way, my problem with that specific artist was fixed.

However, I am still having the problem with other artist/songs, I just don't know who they are.

I currently have a discrepancy between iTunes and Slimserver of 90 songs and 208 artists!!

This is driving me nuts.

Regards,
-Eric

Dan Sully
2005-09-06, 17:31
* egauthier shaped the electrons to say...

>I currently have a discrepancy between iTunes and Slimserver of 90
>songs and 208 artists!!
>
>This is driving me nuts.

SlimServer does some auto-identification of "Various Artists" albums, and
doesn't include those artists (often with single tracks) in the Artist Count.
Please don't go crazy - just because we don't do something exactly like
iTunes doesn't mean it's broken. :)

-D
--
<fuz> deregulation will lead to greater competition, consumer choice, and lower prices.
my name is elmer fudd. I own a mansion and a yacht.

egauthier
2005-09-07, 11:20
Dan,

Believe me, iTunes drives me nuts too. I don't want Slimserver to do everything like iTunes (but Smart Playlists would be cool!).

I won't go crazy, I promise.

Regards,
-Eric