PDA

View Full Version : Slimserver connection probs.



SHAKIRALOVER
2005-08-31, 15:08
Ok i downloaded Slimserver, and when i click my ip addy, all it says is cannot find server.

My friend did it on his and works, i turned firewall off and still no workie.

any ideas?

JJZolx
2005-08-31, 15:11
Ok i downloaded Slimserver, and when i click my ip addy, all it says is cannot find server.
You also installed it, right?

What operating system are you running?

SHAKIRALOVER
2005-08-31, 15:13
Yeah installed, its in quick launch bar.

xp, SP2.

JJZolx
2005-08-31, 16:00
Yeah installed, its in quick launch bar.

xp, SP2.
Are you using port 9000? Double-click on the icon in the tray, which should bring up a web browser connected to the server.

http://localhost:9000

or from another machine on the network:

http://<machinename>:9000

or

http://<ip_address>:9000

SHAKIRALOVER
2005-08-31, 16:12
Im using my ip and then :9000.
when i click icon it says slimserver starting.
page doesnt pop up.

SHAKIRALOVER
2005-09-01, 02:54
Also im not using a router, i tried adding port 9000, to exception list, it was already there.

MrC
2005-09-01, 08:45
Check TaskManager to be sure slim.exe is running. Check Event Log for any slim service failure or error.

SHAKIRALOVER
2005-09-01, 11:07
Its workin in task manager.
Icon in quick launch says, slimserver starting (constantly).

How i check event log?

MrC
2005-09-01, 11:19
Start->Run and enter eventvwr.exe.

If you don't have Start->Run available on your system, use Control Panels->Administrative Tools->Event Viewer.

Try also disabling Windows Firewall temporarily to see if that helps, or any of your AV/Firewall software.

SHAKIRALOVER
2005-09-01, 11:41
Ok i cant seem to find it in event viewer.

but again tryed with av and firewall turned off.

MrC
2005-09-01, 11:54
Start a Command Shell (search your menus to find it). In the command shell, type

telnet localhost 9000

type a

?

and then hit Enter. If you are connecting to the webserver, you should get something like:


HTTP/1.1 400 Bad Request
Date: Thu, 01 Sep 2005 18:51:20 GMT
Server: libwww-perl-daemon/1.02
Content-Type: text/html
Content-Length: 57


If you don't get this, you are not connecting to the server, and something is blocking your connection attempt most likely.

In the same command shell, type:

netstat /an

and look for lines that start like this:


TCP 127.0.0.1:9000
...
UDP 0.0.0.0:3384


If you don't see those, then slim server is not "listening" for incoming network connections.

Report back what you find.

SHAKIRALOVER
2005-09-01, 12:30
http://www.neons.us/uploads/85a438c654.jpg

ok so we got that bit.

MrC
2005-09-01, 12:37
Ok, good. This shows that slim server is not listening on port 9000. Perhaps you've configured a different port to use rather than 9000. That setting is available in Server Settings->Network. But since you cannot get to the server, you need to use another mechanism.

Now try:

netstat /bn

and look for

[slim.exe]

Above those lines will be the ports being used by slimserver. There should be two or more of those lines. If you see a 9999 for example, try connecting to http://localhost:9999.

SHAKIRALOVER
2005-09-01, 12:51
not there, even though its running.

http://www.neons.us/uploads/e5f611cada.jpg

shall i try reinstall?

MrC
2005-09-01, 12:58
At this point, I would reinstall. Why not use the 6.2 beta version available at:

http://www.slimdevices.com/downloads/nightly/SlimServer_v2005-09-01/SlimServer_v2005-09-01.exe

Its works fine.

Be sure to kill slim.exe in task manager, and uninstall slimserver, then install the new one.

SHAKIRALOVER
2005-09-01, 13:11
Yayyyyyyyyyyyyyyyyyyyyy it works.

Thanks MrC, have an e-cookie. :)

MrC
2005-09-01, 13:15
You're welcome!

Chocolate chip please. :-)