PDA

View Full Version : Artwork does not show up



tonymuffin
2005-08-30, 21:27
When viewning by Artwork a number of albums with Artwork only display the title etc but not the Artwork. I have done repeated scans and the same thing happens. Why would the majority of albums be displayed under Artwork and a number of them not?

tonymuffin
2005-09-02, 16:04
Anybody else experiencing this? Any suggestions?

JJZolx
2005-09-02, 20:10
Anybody else experiencing this? Any suggestions?
Are you getting red X's or a "blank CD" sorta graphic?

How do you name your cover art?

tonymuffin
2005-09-02, 20:16
Nope... no red X's, no blank CD sorta graphics. Only the title and Artist. Cover art is name cover.jpg

JJZolx
2005-09-02, 20:39
Nope... no red X's, no blank CD sorta graphics. Only the title and Artist. Cover art is name cover.jpg
Could be a couple of things.

I notice that SlimServer scans artwork now in a second pass through your library. After the first pass SlimServer will no longer display 'Currently scanning...' (or whatever it says), but will gradually pick up cover art during the second pass. This is particularly noticeable if it takes your server a long time to scan the library.

I'm pretty sure you need to do a 'clear library' when you rescan in order to pick up any new artwork. That is, if you add artwork to album directories where SlimServer had scanned the album previously. A rescan without a 'clear' doesn't seem to find cover art, except for new albums.

tonymuffin
2005-09-03, 08:56
I guess I am not making myself clear.

1. The folders all have Artwork.
2. The artwork is named cover.jpg in each folder
3. I have repeatedly rescanned the Libary with the CLEAR LIBRARY BEFORE RESCAN function checked.
4. I have Place Holders enabled for the Artwork. The Artwork that does not display only shows the Place Holder.

Is this making any more sense? I would really appreciate some assistance with this. I have pinged Support via email a number of times with no help.

This is not the only issue either. There are a number of albums that display twice in Artwork. One will display the Artwork however, the second display is Place Holder only with no Artwork. This is really strange as there is only one folder each for the individual items. There are no shortcuts in the music folder as well. So, where is Slim Server picking up the second folder with no Artwork?

tonymuffin
2005-09-03, 11:52
Not using iTunes or Music Magic. My version is 6.1.1. The newer versions as I have mentioned in other thread hork my machine. Don't use any importers.

What does this mean?
d_artwork debugging switch will help while scanning

kdf
2005-09-03, 11:55
On 3-Sep-05, at 8:56 AM, tonymuffin wrote:

>
> I guess I am not making myself clear.
>
> 1. The folders all have Artwork.
> 2. The artwork is named cover.jpg in each folder
> 3. I have repeatedly rescanned the Libary with the CLEAR LIBRARY
> BEFORE RESCAN function checked.
> 4. I have Place Holders enabled for the Artwork. The Artwork that
> does not display only shows the Place Holder.
>
> Is this making any more sense? I would really appreciate some
> assistance with this. I have pinged Support via email a number of
> times with no help.
>
d_artwork debugging switch will help while scanning.
are you using musicmagic or itunes? These types of dupe album listings
are known when using MMM and/or itunes with 6.1.1 or 6.1.2 (haven't
been following this thread for your version) Latest 6.2 build should
be ok.

if not, try disabling any importers if you use any.
-kdf

kdf
2005-09-03, 12:10
On 3-Sep-05, at 11:52 AM, tonymuffin wrote:

>
> Not using iTunes or Music Magic. My version is 6.1.1. The newer
> versions as I have mentioned in other thread hork my machine. Don't
> use any importers.
>
> What does this mean?
> d_artwork debugging switch will help while scanning
>
server settings->debugging

check d_artwork
click change

start rescan

open http://slimserverIP:9000/log.txt


OR

run command line:
start->run
cmd.exe
cd "\program files\slimserver\server\"
slim.exe --logfile c:\myartwork.txt --d_artwork

after the server starts, initiate a rescan and you will have all the
artwork log messages stored in c:\myartwork.txt"

this will report each album found, and what the server can or cannot
find in the way of artwork for each file.

as to the problems that 'hork' your machine ...
If you have a startup problem (can't recall your other posts
specifically, since I read about 300 posts a day) try erasing the
slimserversql.db file before you start.

-kdf

tonymuffin
2005-09-04, 11:19
Ok, I checked d_artwork and rescanned. The log.txt file does not show the particular folders with the artwork that is not showing up. However, the folder is there, the artwork is there.