PDA

View Full Version : Disable scanning on startup ?



florent
2005-08-28, 00:41
Hello,

I'm using Slimserver 6.1.1 with MySQL on a Gentoo box. It works fine, but I'm trying to figure out how to prevent it to rescan the whole library each time it starts, since it takes a pretty long time (over 20.000 tracks).

Here's my startup script :


#!/sbin/runscript

# Init script for SlimServer 5/6 for Gentoo Linux
# Save this as /etc/init.d/slimserver

depend() {
need net
after localmount
}

# Configure these appropriately for the local installation
pidfile=/var/run/slimserver/slimserver.pid
logfile=/var/log/slimserver/messages
ssdir=/home/slimserver/SlimServer
cachedir=/var/cache/slimserver
niceness=-10
language=fr_FR

start() {
ebegin "Starting Slimserver"
export LANG=$language
HOME=${ssdir} /bin/nice --adjustment=${niceness} start-stop-daemon \
--start --quiet \
--exec ${ssdir}/slimserver.pl -- --daemon \
--prefsfile=/etc/slimserver.pref --cachedir=${cachedir} \
--pidfile=${pidfile} --user=slimserver \
--logfile=${logfile} ${SLIMSERVER_OPTS}
eend $? "Failed to start Slimserver"
}

stop() {
ebegin "Stopping Slimserver"
start-stop-daemon --stop --quiet --pidfile ${pidfile}
eend $? "Failed to stop Slimserver"
}
I've already tried to add the --noscan option, but all I obtain is a database with 0 songs :-(

Is there a way to tell him to load only the existing database, and don't generate a new one ?

Thanks in advance,

Florent

gharris999
2005-08-28, 08:25
I had the same problem with Slimserver 6.1.x using mysql both with Windows XP and with Fedora. The 6.2.x beta doesn't seem to have this problem (though it has others.) I never really figured out what was going on with 6.1.x since I'm using 6.2.x these days.