PDA

View Full Version : Squeezebox cannot connect to SlimServer - details inc



Triggaaar
2005-08-27, 04:15
I'm tring to use a Squeezebox for the first time.

Details:
Win XP
Netgear router
Firmware 11 on Squeezebox2
Wired Squeezebox

I tried the auto IP address using DHCP.

Squeezebox IP 192.168.0.5 - which seems right
My PC IP 192.168.0.4
Netgear router IP 192.168.0.1

Looking at the details on the squeezebox screen, it first said slimserver is 192.168.1.5 - I didn't think this was correct. When it didn't work, I tried specifying My PC's IP add here. This didn't work either.

I have tried connecting the squeezebox directly to my PC without the Router. I've tried switching anti virus software off, and putting the squeezebox's IP add in the router's info to stop the firewall blocking it.

I have installed slimserver, and the icon on the taskbar says it's starting.

Before it tries to connect, it says
'Looking for SlimServers'
it then says 'Select your SlimServer' and gives the IP address of my machine (as I'd hope).
I select this, and it says 'Connecting to |SlimServer...'
This message never goes.

What can I do?

Thanks

Triggaaar
2005-08-27, 05:12
IGNORE THAT!!!!

Uninstalled SlimServer, and re-installed from same downloaded file - the squeezebox updated it's firmware to 15, then it connected.

And now Jimi Hendrix is blasting through my speakers :)

Triggaaar
2006-12-22, 06:14
A year and a bit later, I'm back with the same problem. My motherboard died, which I've now replaced, and the squeezeboxes can't see the server again. I looked up this old message, and tried unistalling/reinstalling, which didn't work.

I'm not using Microsoft Internet Explorer any more, as my machine didn't like it, and I'm on Mozilla Firefox (this is what I was using without problem before the motherboard died.

Otherwise, details are much like above. I have a netgear router, but I've tried connecting to the PC via my hub, without the router (the hub does work, as my PC can talk to the spare PC). I've installed the latest slimserver on the PC, and done a reset on the squeezeboxes by holding 'add' when switching on. I haven't done a firmware upgrade, as holding the brightness button doesn't seem to do anything.

I assume it is a firewall problem, but I can't find the answer. The PC has AVG anti virus software running, but I can't find anything related to firewall in it's help index. Likewise with firefox. When I go to Control Panel -> Windows Firewall, I get the error message "due to an unidentified problem, Windows cannot display Windows Firewall settings". I don't know if this is because I'm not using internet explorer, or what.

I've looked at the troubleshooting section of frequently asked questions, but no joy. If anyone has a suggestion, I'd be very grateful, as I've lost music in every room of the house.

Many thanks

Triggaaar
2006-12-24, 07:18
Ok, so I've had to find the answer myself. Quite a lonely forum this. Not sure if anyone else is interested in the solution, but I'll post it here anyway.

The manual's guidelines for adding exceptions to the firewall rules, did not work for my PC, Windows XP, SP2. Manual says to go to control panel, security centre, and click 'Windows Firewall' - this was not an option on my PC.

Instead:
go to Control Panel
select Network Connections
select Local Area Connection
on the General tab, select Properties
on the Advanced tab, select Settings
and then add exceptions as per the manual's instructions - I added 3, where the external and internal port numbers matched each other, for each individual exception - 3483 (TCP), 3483 (UDP), 9000 (TCP).

Happy christmas

Patrick Dixon
2006-12-24, 08:47
Ok, so I've had to find the answer myself. Quite a lonely forum this.
It's Christmas don't you know, so there's only you and me here .... and I'll be gone soon.

Glad you're sorted - Happy Christmas.

Diana
2006-12-24, 09:44
Ok, so I've had to find the answer myself. Quite a lonely forum this...
Happy christmas

Still a few of us reading this interesting stuff. Couldn't say anything useful myself - but your discovery will, I'm sure, be a welcome Xmas gift to lots of folk in the same boat as you!

On behalf of all those who'll benefit from your persistence, thanks for the Xmas present!

Very best wishes (off to put some fuel in the car!)

Triggaaar
2006-12-24, 11:30
On behalf of all those who'll benefit from your persistence, thanks for the Xmas present!A year and 4 months after starting this thread, I'm finally not talking to myself. I feel all warm inside, thanks.

adl6009
2006-12-25, 09:26
Just wanted to say thanks for restarting the thread. After looking at what you did I spotted why my player wasn't working, my thread is
http://forums.slimdevices.com/showthread.php?t=30921

Us beginners can help ourselves sometimes ;-)

Triggaaar
2006-12-26, 12:12
Nice one, glad it helped. When your squeezeboxes stop working, the world just doesn't seem right. Actually playing a CD seems like a crazy idea.