PDA

View Full Version : No connection Slimserver<->Squeezebox



mustard
2005-08-20, 15:46
OK, i have given up bridging for now.(other thread)
But now I am having problem connecting to my slimserver.

Symptoms: Connecting to Slimserver.. (hangs/nothing happens)

Other facts:
Running Gentoo Linux/slimserver 6.1.1
I can ping my squeezebox from my server (which runs slimserver)
I am on the webinterface of slimserver while trying to connect (must be running then,eh?)
I have installed slimserver with the user "slimserver". Used a mix of a Gentoo.ebuild that didn't work and the tar.gz-files. Could be a source of problems. Which priveliges does "slimserver" need? what files to own/groups to belong to?

From the FAQ-troubleshooting
Here are some things to try:
Make sure your network settings are entered correctly. Double-check.
-Well I can ping them, Squeezebox has the correct ip to the server.
Make sure that SlimServer is still running and has not been stopped.
-Well i am on the web-interface
If you have any firewall software installed, configure it to allow communications between your server computer and your player.
-Don't think I have no firewall..Could be some murky conf-file somewhere that blocks it? Do I have to open some ports or something?
Make sure that your ethernet hub or switch supports 10Mbps connections (most do, but some do not).
-going wireless,baby
Also try a different cable.
-as above
Try to use your systems "ping" utility to try to connect to your player. If you get a message claiming 100 percent packet loss, there could be a network problem or misconfiguration.
-100% success
Ensure that your player has an IP address on the same subnet as the server. This usually means that the first 3 numbers of their IP addresses have the same values.
-they are.

mustard
2005-08-20, 16:52
It also seems to be listening where it should..


netstat -tunlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:9090 0.0.0.0:* LISTEN 2024/slimserver
tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN 2024/slimserver
tcp 0 0 127.0.0.1:6010 0.0.0.0:* LISTEN 27421/0
tcp 0 0 127.0.0.1:6011 0.0.0.0:* LISTEN 6390/1
tcp 0 0 0.0.0.0:3483 0.0.0.0:* LISTEN 2024/slimserver
tcp 0 0 ::1:6010 :::* LISTEN 27421/0
tcp 0 0 ::1:6011 :::* LISTEN 6390/1
udp 0 0 0.0.0.0:3483 0.0.0.0:* 2024/slimserver
udp 0 0 0.0.0.0:68 0.0.0.0:* 6560/dhcpcd

mustard
2005-08-21, 02:55
Well I'll be damned. Now it works. don't know how it happened really..
Now I try bridging again (I must be a masochist..:))