PDA

View Full Version : No artist tag gets artist set to "1"



MrC
2005-08-18, 13:54
Tracks with no artist tag get their artist set to "1" (the number one). This is a very strange artist indeed.

Perhaps the artist should be assigned to "Unknown" or something like that.

8/18 nightly.

kdf
2005-08-18, 14:28
Quoting MrC <MrC.1tz9to (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Tracks with no artist tag get their artist set to "1" (the number one).
> This is a very strange artist indeed.

where is this showing up? player, web, any/all modes/skins?

are the other tags in place, just to be sure 1 isn't being picked up by
guessTags somewhere along the way?

-kdf

MrC
2005-08-18, 15:12
Sorry, I should have been more clear.

In the web interface, I get an artist of "1". Tags appear to be valid, and the log indicates tags are correct. Only the artist appears incorrect. Since there is no long entry for artist using d_info, I don't see any debug that indicates where the 1 is coming from.

The skin i'm using is the left justified fishbone skin. I've attached pics that shows the problem, drilling down deeper into the tags for one of the many problematic titles (sorry, due to upload limits of the forum, i had to enclose in two parts).

kdf
2005-08-18, 15:26
Quoting MrC <MrC.1tzdiz (AT) no-mx (DOT) forums.slimdevices.com>:


> The skin i'm using is the left justified fishbone skin.

Have you tried any of the supplied skins? Some templates have changed since
that was last posted, so it could be a skin problem. I have updated the
original fishbone skin to make it a lot easier to customise for left-justify
(just move [% browselinks %]).

I don't have any files with just the artist missing on hand here, so a guess is
all I can offer right now :)

-kdf --
NOT a Slim Devices employee

MrC
2005-08-18, 16:15
I just tried Default2. This problem is more than skin deep. :-)

If anyone knows the debug flag to debug the artist extraction, please post and I'll run some debug on this.