View Full Version : D-Link DI-624 wireless router connection problem

2005-08-14, 02:31
I have a problem connecting my Squeezebox 2 to my wireless network.

I originally connected my SB to my PC using a crossover cable and that worked fine. I then purchased a D-Link DI-624 wireless router and with no encryption or using WEP encryption the SB connects OK but when using WPA encryption (which I would like to use) I receive an error from the SB.

Iíve set my router to use WPA/PSK and assigned a passphrase. Iíve also opened the 3 ports on the router firewall and on the laptop OS (Win XP SP2) firewall I want to connect to (which has SlimServer running). Iím pretty sure this is correct as like I said with no or WEP encryption all is fine.

On my SB I create a wireless network using WPA Personal. It finds my network, I enter the WPA Password (passphrase recorded on router), obtain an IP using DHCP, then last I specify the IP of the SlimServer, my laptop. This is where it fails. It says ďProblem canít connect to SlimServerĒ. Iíve also tried to manually entering an IP, Subnet, Gateway, & DNS and receive the same problem.

My laptop running SlimServer has a static IP & DNS.

Any ideas?

Thanks for any help you can provide,


2005-08-14, 08:10
I managed to get WPA-PSK working with my DI-624, SB2 and slimserver box, though only with some trouble. I also got it working with a DI-784. In my setup, I didn't open any ports in the router's firewall, which I think you would do only if you wanted to make your slimserver available to the "outside world" on the interent.

My shaky experience with WPA-PSK and D-Link gear prompted me to try a Netgear FWAG114, which is what I'm using now.

Are you using the latest firmware (2.53) for the DI-624? Assuming that you have a revision C version of the hardware, you can get the firmware here: http://support.dlink.com/products/view.asp?productid=DI%2D624%5FrevC

2005-08-15, 09:29
I am successfully connecting using WPA-PSK two SB2s to a DI-624
(hardware rev.C) running firmware 2.50.


gharris999 wrote:
> I managed to get WPA-PSK working with my DI-624, SB2 and slimserver box.

2005-08-15, 15:11
Thanks for your feedback.

I checked and I'm running Rev C 2.53; came like that out the box.

Wonder what settings I have on the router that's different and causing it not to work? As I said, it works fine using no encryption and WEP but not WPA/PSK!

2005-08-16, 03:08
is your laptop running a firewall that is blocking connections from the SB? If you get an IP address for your SB, then the problem is unlikely to be with the router.

I run ZoneAlarm on my PCs and had to change one of the settings to medium to allow sharing of drives between PCs. Maybe similar problem on your laptop?

Hope this helps

jan van mourik
2005-08-27, 11:19
Bought a notebook for my off-to-college kid yesterday and got a D-Link
DI-524 for free (after rebate). I was quite excited cause now i have a
Belkin 11B wireless router. I set it up this morning and had the same
problem as James! The SqueezeBox goes fine through all menus, finds the
network, gets an ip address, finds the SlimServer. But then it goes on to
actually connect to SlimServer and it sits there for a while, then gives up!

On a side note, I have voip (Lingo) and that worked on the D-Link, but than
after 30 minutes talking to a friend, I all of a sudden lost contact! So my
voip modem has a problem with the D-Link too..
I plugged my Belkin back in (that one was $15 after rebates a year ago i
think) and all works fine again...



2005-08-27, 19:54
I eventually got everything working. After a little research I found out that the firmware on the DI-624 was no good. Version 2.53 or above seems to have broken the WPA in some circumstances. As soon as i down-graded back to verion 2.50 everything worked fine.

Maybe something similar is happening to you?

Here's some info you (or somebody else) may find useful:



jan van mourik
2005-09-02, 20:57
Aaargh, no! Just my own stupid mistake! I was sitting in the tub and all of
a sudden I realized....

Home -> Server Settings -> Security
..... Block incoming connections / Allowed IP Addresses

The ip addresses on the new Dlink router are different from the Belkin...

Tried it again and it's working fine now!