PDA

View Full Version : Slimserver does not recognize Windows shortcut links to other folders with music



boybees
2005-08-13, 03:05
I have music in more than one folder on my C: drive. When I create a shortcut to the second folder, and then cut-and-paste that shortcut into my primary music folder (the one that Slimserver is pointed to), Slimserver doesn't see any of the music in that second folder.

I'm following the instructions in the FAQ:

"How do I use multiple folders or disks with my Music Library?

You can create links or shortcuts to other folders and place them in your specified Music Library Folder. The contents of the linked folders will then be part of your Music Library."

What am I doing wrong? thanks.

boybees
2005-08-13, 07:51
Tried having the shortcut point to a folder that only contains music, and still no luck. Slimserver doesn't see the shortcut or the second folder.

sleepysurf
2005-08-13, 07:58
You can't use a mapped network drive letter, but instead must point Slimserver directly to the proper directory, per...
http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume

For example, I have my FLAC files stored on a peripheral Buffalo Linkstation... with Slimserver directed to...
\\LS1\Audio

dean
2005-08-13, 08:00
On Aug 13, 2005, at 3:05 AM, boybees wrote:

>
> I have music in more than one folder on my C: drive. When I create a
> shortcut to the second folder, and then cut-and-paste that shortcut
> into my primary music folder (the one that Slimserver is pointed to),
> Slimserver doesn't see any of the music in that second folder.
>
> I'm following the instructions in the FAQ:
>
> "How do I use multiple folders or disks with my Music Library?
>
> You can create links or shortcuts to other folders and place them in
> your specified Music Library Folder. The contents of the linked
> folders
> will then be part of your Music Library."
>
> What am I doing wrong? thanks.
Where are the target folders located? If they are identified by a
drive letter, this FAQ entry may be the fault:

<http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume>

I'm having trouble using a network shared volume as my music library
on Windows. It says tha the path isn't valid. What's up?

If you are running on Windows NT, 2000 or XP, SlimServer is running
as Windows service. Windows services do not have permission to use
networked drives by default. You will need to run the SlimServer
service as a user who has permission to use the shared volume. To do
this, visit Control Panels -> Administrative Tools -> Services. Find
SlimServer and double-click to view the properties. Click on the Log
On tab, then click This Account and enter the account information for
the user account that has access to the network volume. (Note: The
user account for the service must be protected by a password for this
to work.)

If you are still having problems, or are using Windows 98, try
using a UNC-style path to specify your music library in the Server
Settings page. Instead of X:\path for a mounted volume, use \\SERVER
\path\ style addressing. This may work for some servers where direct
volume letter mapping does not.

boybees
2005-08-13, 09:45
Success! the key was giving Slimserver admin priveleges, ala the FAQ. Thanks for the help.

marlowe
2007-07-24, 11:36
I am having the same problem as boybees:
I have pointed Slimserver to my folder C:\...\musik\flac. When I put a shortcut in this folder to for example C:\...\musik\flac - jazz, it sees the shortcut (when browsing by folder), but doesn't recognise it as such. It treats it like a song instead.

I don't use a password on my computer, so I can't see, how I can use the solution boybees used. Does anyone have any suggestions? Thanks.

Beau
2007-10-27, 09:19
Slimserver treating a shortcut as a song when I browse music folder.

I've just purchased a Western Digital MyBookWorld NAS. I want to transfer my music over on to this but will still be running slimserver (V6.31) on a Windows XP Pro box.

Slimserver won't let me input the share name directly in the Music folder box so I've put C:\Music in there and in C:\ Music I've put a UNC style shortuct to the folder on the NAS that contains the music.

Going through Windows and clicking on the shortcut brings up the correct folder but Slimserver sees the shortcut as a song.

The music folder on the NAS is set to allow any user read access. I've also tried changing slimserver to run as a user who has permission but can't get Slimserver to accept the details (user set up on the NAS with full read/write access to the music folder) I input so I must be doing something wrong here.

Any ideas? I've had shortcut's running and working fine where both drives were directly attached (via USB) to the XP box but this is stumping me.

Thanks
Beau