PDA

View Full Version : Two Laptops on Squeezebox2



essbee1964
2005-08-12, 14:45
Hi All,
Took delivery today and got it up and running brilliantly on my laptop.
In order to keep the girlfriend quiet she wants to install Slimserver on her laptop too so she can use the Squeezebox when I'm not using it on my laptop.
I have installed Slimserver on both laptops but can only open and play music on mine. When I attempt to open Slimserver on hers it says it cannot connect to the localhost:900 site (after making sure my Slimserver is closed).
Am I being thick, is there a way to do this or is it not an option (will she have to transfer her music to my laptop)?

One further point, the Squeezebox 'sees' that there is both mine and her laptop on the wireless network but only connects to mine.

Can anybody help?

complete newbie
Shaun

dean
2005-08-12, 18:45
I'd bet it's an issue with some firewall software on her laptop.

On Aug 12, 2005, at 2:45 PM, essbee1964 wrote:

>
> Hi All,
> Took delivery today and got it up and running brilliantly on my
> laptop.
> In order to keep the girlfriend quiet she wants to install Slimserver
> on her laptop too so she can use the Squeezebox when I'm not using it
> on my laptop.
> I have installed Slimserver on both laptops but can only open and play
> music on mine. When I attempt to open Slimserver on hers it says it
> cannot connect to the localhost:900 site (after making sure my
> Slimserver is closed).
> Am I being thick, is there a way to do this or is it not an option
> (will she have to transfer her music to my laptop)?
>
> One further point, the Squeezebox 'sees' that there is both mine and
> her laptop on the wireless network but only connects to mine.
>
> Can anybody help?
>
> complete newbie
> Shaun
>
>
> --
> essbee1964
>

mherger
2005-08-13, 12:36
> I have installed Slimserver on both laptops but can only open and play
> music on mine. When I attempt to open Slimserver on hers it says it
> cannot connect to the localhost:900 site (after making sure my
> Slimserver is closed).

localhost is always the machine your sitting at. If you try to access your
girlfriend's computer from your machine, you'd have to use her machine's
name or ip address instead.

> One further point, the Squeezebox 'sees' that there is both mine and
> her laptop on the wireless network but only connects to mine.

Even if you tell it to connect to the other computer? Re-run your player's
setup by rebooting it. You then can select which server to connect to.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

essbee1964
2005-08-13, 13:12
Thanks guys, an update...

both my laptop and her laptop are recognised and appear on the Squeezebox and we can choose which one to connect to, great.

What's happening now is that she can see all her music on the Squeezebox but still cannot access the Slimserver software from her laptop (I can from mine). She can actually play music from her laptop using the remote but would obviously like to access the software too! I have tried installing the software on her laptop without the firewall with no success. I find this a bit odd as we have identical laptops.

shaun

MrC
2005-08-13, 15:04
There are 3 things that I can think of that need to be configured to allow connection via a browser.

1) Window's firewall, and Norton or similar, must not be blocking access

2) Slimserver must not be blocking access (Server Settings->Security) to localhost (unless this was changed, shouldn't be a problem)

3) The browser must have javascript enabled.

To save one iteration of posting here, please indicate as much as you can exactly what is happening when your girlfriend cannot connect. Blank browser page? Error page? Kitchen catches fire?

And I presume she's doing http://localhost:9000 (not 900 as typo'd in your original post).

JJZolx
2005-08-13, 15:07
Thanks guys, an update...

both my laptop and her laptop are recognised and appear on the Squeezebox and we can choose which one to connect to, great.

What's happening now is that she can see all her music on the Squeezebox but still cannot access the Slimserver software from her laptop (I can from mine). She can actually play music from her laptop using the remote but would obviously like to access the software too! I have tried installing the software on her laptop without the firewall with no success. I find this a bit odd as we have identical laptops.
It might be worth trying

http://127.0.0.1:9000

I've seen some machines that for some reason can't resolve 'localhost'.

essbee1964
2005-08-13, 15:19
Thanks for all your suggestions, Jim's was successful, replacing localhost did the trick. Can I set this address up as a default when I right click on the task bar and 'Start Slimserver'?

thanks again
Shaun

Marc Sherman
2005-08-13, 17:18
essbee1964 wrote:
> Thanks for all your suggestions, Jim's was successful, replacing
> localhost did the trick. Can I set this address up as a default when I
> right click on the task bar and 'Start Slimserver'?

This is a windows machine, right? Try editing:
C:\WINNT\system32\drivers\etc\hosts

It should contain the line:
127.0.0.1 localhost

- Marc

MrC
2005-08-13, 18:16
It might be worth trying

http://127.0.0.1:9000

I've seen some machines that for some reason can't resolve 'localhost'.

This should only happen if the hosts file has been hijacked, deleted, or your system is configured not to use it. Make sure the file C:\WINDOWS\SYSTEM32\drivers\etc\hosts exists, and contains an entry:

127.0.0.1 localhost

essbee1964
2005-08-14, 04:25
Checked as advised, entry exists in hosts but still does not connect to the localhost. What I am doing is starting Slimserver, waiting a few seconds and manually opening the http://127.0.0.1:9000 site to bring up the web interface and closing the localhost site that pops up, not ideal but it works!
shaun

MrC
2005-08-14, 08:14
Try opening a command window (Start->Run, and type "cmd" (no quotes) and hit OK button. A command window will open. Type the command:

ping localhost

If the command works, you will get 0 packet loss. If it fails, you will see something about not being able to find host localhost.

Is your girlfriends IE configured to use a proxy?

essbee1964
2005-08-14, 11:20
I have pinged to localhost and there were no packets lost. No, hers does not go through a proxy, her laptop is configured the same as mine.
shaun

JJZolx
2005-08-14, 12:55
Thanks for all your suggestions, Jim's was successful, replacing localhost did the trick. Can I set this address up as a default when I right click on the task bar and 'Start Slimserver'?

When are you getting the error message on that machine? Is it only after you use SlimTray (the task bar icon) to do a 'Start SlimServer'?

When SlimServer isn't running and you start it from SlimTray then SlimTray always opens a browser window immediately after starting the server. I've noticed that on my system most of the time this results in a 'page not found' error. It appears that SlimTray doesn't wait long enough, or else SlimServer isn't yet ready to serve web pages.

See bug: http://bugs.slimdevices.com/show_bug.cgi?id=1733

My workaround is to wait a little bit (a few seconds) and then click on a browser shortcut to http://localhost:9000 that I keep in the browser toolbar. The page usually displays on the second try. You can also double-click the SlimTray icon and it will launch a new browser window connected to SlimServer.

Ted Rathkopf
2005-08-22, 14:59
Meanwhile, back at the model home, essbee1964 <essbee1964.1to8db (AT) no-mx (DOT) forums.slimdevices.com> said:

> I have installed Slimserver on both laptops but can only open and play
> music on mine. When I attempt to open Slimserver on hers it says it
> cannot connect to the localhost:900 site (after making sure my
> Slimserver is closed).

I saw responses below indicating that using 127.0.0.1 worked instead
of using localhost, but I didn't see anyone say the obvious: The port
should be 9000, not 900.

--
Ted Rathkopf

MrC
2005-08-22, 17:29
I saw responses below indicating that using 127.0.0.1 worked instead
of using localhost, but I didn't see anyone say the obvious: The port
should be 9000, not 900.
Ted Rathkopf

Oh contraire astute one:


And I presume she's doing http://localhost:9000 (not 900 as typo'd in your original post).