PDA

View Full Version : YALNQ Ė Slimsever service start question



gharris999
2005-08-07, 16:51
Yet Another Linux Newbie Question:

Iím having trouble customizing my slimsever service start parameters.

Iím editing /etc/sysconfig/slimserver and changing the line:


SLIMSERVER_CFG="/etc/slimserver.conf"
To


SLIMSERVER_CFG="/etc/slim-data/slimserver.conf"
Iíve set the appropriate permissions on /etc/slim-data

When I attempt a ./etc/init.d/slimserver start

Öthe daemon doesnít start and it gives no error message. When I change the line in /etc/sysconfig/slimserver back, the daemon starts just fine.

Iím running Fedora core 4. Any ideas as to what Iím doing wrong here? I really donít have a clue as to how to go about modifying linux server startup parameters. I'm just guessing that this is where I should start.

Robin Bowes
2005-08-08, 02:25
gharris999 wrote:
> Yet Another Linux Newbie Question:
>
> Iím having trouble customizing my slimsever service start parameters.
>
> Iím editing /etc/sysconfig/slimserver and changing the line:
>
>
> Code:
> --------------------
> SLIMSERVER_CFG="/etc/slimserver.conf"
> --------------------
>
> To
>
>
> Code:
> --------------------
> SLIMSERVER_CFG="/etc/slim-data/slimserver.conf"
> --------------------
>
> Iíve set the appropriate permissions on /etc/slim-data
>
> When I attempt a ./etc/init.d/slimserver start
>
> Öthe daemon doesnít start and it gives no error message. When I change
> the line in /etc/sysconfig/slimserver back, the daemon starts just
> fine.
>
> Iím running Fedora core 4. Any ideas as to what Iím doing wrong here?
> I really donít have a clue as to how to go about modifying linux server
> startup parameters. I'm just guessing that this is where I should
> start.

I just did the following:

mkdir /etc/slimdata
cp /etc/slimserver.conf /etc/slimdata/slimserver.conf
vi /etc/sysconfig/slimserver
=> SLIMSERVER_CFG="/etc/slimdata/slimserver.conf"
chown -R slimserver:slimserver /etc/slimdata
/etc/init.d/slimserver restart

Worked fine for me.

One possibility - do you have SELinux enabled? I don't, so that might be
something to do with it.

R.

gharris999
2005-08-08, 22:56
Well, I'm not sure what I was doing wrong, but when I followed Robin's method, suddenly everything was fine. Thanks, Robin.