PDA

View Full Version : Problems with new Various Artists Feature



dip
2005-08-07, 16:39
The new Various Artist Feature is great but still has some problems (I am using the Windows XP version):

1. After installing the August 7 nightly instead of 755 artists only 233 artists were shown in my library. All artists which exist only on various artists albums were no longer shown separately in browse artists as expected. But after the next rescan (with clearing the database) all 755 artists are back in browse artists. It doesn't matter whether I choose "Automatically identify "Various Artist" albums" in the server settings or not, I never get the behaviour I had after the first installation of the August 7 nightly. So it seems that the rescan does not correctly consider this option.

I verified this behaviour by deleting the slimserver program directory and by copying back my previous (backuped) directory.

2. I tried to use a "Customized "Various Artist" identifier" but that did not work at all. The albums are always listed unter "Various Artists".

3. I have one artist which has one song on a Various Artists album and four songs with No Album. This artist is shown in browse artists, so it seems that No Album is treated like an album (is that by design or a bug?). In the web interface after clicking on the artist two entries (the Various Artists album name and No Album) are shown. On my Squeezbox 2, however, only the Various Artist album name is shown. The No Albums songs cannot be accessed through browse artists.

4. It seems that the Various Albums feature must be improved to correctly recognize the "Multiple Items in Tags" feature. I have multiple artists separated by "&" and accordingly defined "&" as separator for multiple artists. When a Various Artists album exists including a track from a multiple artist (like "Artist 1 & Artists 2") then the "Artist 1" is correctly not shown in browse artists but "Artist 2" is incorrectly shown. At the same time in the song info Album Artist is set to "Various Artists", Artist is set to "Artist 1" and Track Artist is set to "Artist 2". It seems to me that Artist should be replaced by Track Artist and should be set to "Artist 1 Artist 2".

Dan Sully
2005-08-08, 10:01
Could you file a bug for these, so they will be tracked?

Thanks.

* dip shaped the electrons to say...

>The new Various Artist Feature is great but still has some problems (I
>am using the Windows XP version):

-D
--
"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety." - Benjamin Franklin

dip
2005-08-08, 15:06
Four bug reports filed.
Dieter

chopdog
2005-08-08, 15:07
I am not sure what the magic word is to make the Various Artists feature work - but I haven't worked it out !

I have thousands of "multi-artist" albums using the regular ARTIST tag, with multiple artisted albums stored in single album folders. Slim Server isn't detecting it - at all.

Do I need any additional software installed if I am testing beta code ? Is this needing MySQL ?

chopdog
2005-08-08, 15:12
It seems to be a problem if there is no album artist included. If I put an album artist in, it works fine. Sort of defeats the object.... but a start, I guess.

chopdog
2005-08-08, 15:15
I don't know if this helps, but if you play something that has been "Various Artisted", then SB and the Slim Server interface doesn't pick up the artist name in the display. Does this help ? FYI I am using WMA files.