PDA

View Full Version : No playlists anymore - 2005_08_05 nightly



thomashb
2005-08-06, 07:53
I just upgraded to the nightly build yesterday from a nightly build some weeks ago. Afterwards I stopped my linux server while the slim server was automatically rescaning the music folders (blame on me). Today I started the server and made it scan the music again. Everything looks fine but I have no playlists anymore.

The playlist directory setting in the server is correct but there are no files anymore. Fortunately I have a backup of the m3u files and copied them back. But a playlist rescan did not add the playlists to the slim server. Permissions on the directory and files are ok.

What can I do to get my playlists back into the server?

dean
2005-08-06, 08:12
Eeek, I have had the same problem with my auto-installed RPM last night.

I've disabled downloads of the nightly from the web site until we
understand this issue better.

-dean


On Aug 6, 2005, at 7:53 AM, thomashb wrote:

>
> I just upgraded to the nightly build yesterday from a nightly build
> some
> weeks ago. Afterwards I stopped my linux server while the slim server
> was automatically rescaning the music folders (blame on me). Today I
> started the server and made it scan the music again. Everything looks
> fine but I have no playlists anymore.
>
> The playlist directory setting in the server is correct but there are
> no files anymore. Fortunately I have a backup of the m3u files and
> copied them back. But a playlist rescan did not add the playlists to
> the slim server. Permissions on the directory and files are ok.
>
> What can I do to get my playlists back into the server?
>
>
> --
> thomashb
>

Patrick Dixon
2005-08-06, 08:35
I have the same problem with (I think) the 2-8 nightly tarball - see http://forums.slimdevices.com/showthread.php?t=15563

But if I now create a playlist, that works OK.

I still have a playlist that I created before the wipe cache rescan (using exactly the same slimserver), that's in the folder, but doesn't get included in the db.

kdf
2005-08-06, 09:51
On 6-Aug-05, at 8:12 AM, dean blackketter wrote:

> Eeek, I have had the same problem with my auto-installed RPM last
> night.
>
> I've disabled downloads of the nightly from the web site until we
> understand this issue better.
>
since the playlist scan is handled via the scheduler, I'd be willing to
bet that it is related to what I have filed as bug 1936. In my case, I
found it due to musicmagic and moodlogic scheduled tasks being killed
when itunes scan ended (remove
_task). I have a patch there that cleans up things for mmm and ml, but
I don't know yet what I'm looking for in the logs to check on playlist
scan. I also haven't got anything to handle the multiple cases of
addToList, so it could be that music folder and playlist scanning are
still being confused. Thus, when the scheduler ends the folder scan, it
kills the playlist scan task as well. of course, this is mostly theory
right now.

-kdf

dean
2005-08-06, 10:01
I'm also not seeing new playlist files being saved.

Let's see if Dan has any idea of what's going on.

-dean

On Aug 6, 2005, at 9:51 AM, kdf wrote:

>
> On 6-Aug-05, at 8:12 AM, dean blackketter wrote:
>
>
>> Eeek, I have had the same problem with my auto-installed RPM last
>> night.
>>
>> I've disabled downloads of the nightly from the web site until we
>> understand this issue better.
>>
>>
> since the playlist scan is handled via the scheduler, I'd be
> willing to bet that it is related to what I have filed as bug
> 1936. In my case, I found it due to musicmagic and moodlogic
> scheduled tasks being killed when itunes scan ended (remove
> _task). I have a patch there that cleans up things for mmm and ml,
> but I don't know yet what I'm looking for in the logs to check on
> playlist scan. I also haven't got anything to handle the multiple
> cases of addToList, so it could be that music folder and playlist
> scanning are still being confused. Thus, when the scheduler ends
> the folder scan, it kills the playlist scan task as well. of
> course, this is mostly theory right now.
>
> -kdf
>
>

Philip Meyer
2005-08-06, 10:09
On the issue of playlists, I saved a new playlist titled "Afterglow" last night. Looking in "Browse Playlists" today, I thought it was missing, but in fact it appears towards the end of the list, between "Total Ambient Bliss" and "WXPN - (Stars Die Sun Morning)".

I was expecting Playlists to be sorted by name. Is this not the case? If so, what is the sor order?

Phil

Patrick Dixon
2005-08-06, 11:08
Don't know if it's any use, but I don't have the MusicMagic, Moodlogic or iTunes plugins enabled.

Dan Sully
2005-08-06, 11:52
* Patrick Dixon shaped the electrons to say...

>Don't know if it's any use, but I don't have the MusicMagic, Moodlogic
>or iTunes plugins enabled.

I just checked in a fix for this - sync up with SVN, then wipe & rescan.

-D
--
It's the wrong trousers Gromit, and they've gone wrong!

kdf
2005-08-06, 12:16
On 6-Aug-05, at 11:52 AM, Dan Sully wrote:

> * Patrick Dixon shaped the electrons to say...
>
>> Don't know if it's any use, but I don't have the MusicMagic, Moodlogic
>> or iTunes plugins enabled.
>
> I just checked in a fix for this - sync up with SVN, then wipe &
> rescan.
>
Doing a scan myself right now with those changes. After a scan, some
playlists seem to be missing. They are all m3u, but some are radio
station links, and some may not have all tracks still available. I'll
have to do more poking around.

-kdf

MikeGilpin
2005-08-07, 11:09
I'm on this same nightly - it fixed a bug for me - but my playlists are fine. Probably because they come from iTunes, on a Mac with OS X.

Patrick Dixon
2005-08-07, 11:39
I just checked in a fix for this - sync up with SVN, then wipe & rescan.Thanks, but it hasn't fixed it for me - and it's lost the one playlist I had! (r3890)

Dan Sully
2005-08-08, 12:12
* kdf shaped the electrons to say...

>Doing a scan myself right now with those changes. After a scan, some
>playlists seem to be missing. They are all m3u, but some are radio
>station links, and some may not have all tracks still available. I'll
>have to do more poking around.

Ok - this is really fixed in subversion now. Sorry for the typo.

-D
--
<ZangTT> berkeley db - it's mostly about the hash()

Patrick Dixon
2005-08-08, 15:14
Hoorah! I got Playlists! Thanks Dan.

Patrick Dixon
2005-08-09, 00:39
One small problem though, they all have #CURTRACK 0 as the first entry.

thomashb
2005-08-09, 12:46
Hoorah! I got Playlists! Thanks Dan.

I upgraded from my last working version to the 2005_08_09 nightly now and I have playlists as well :-)

Unfortunately I have too many playlists :-(

Most playlists show up three times now. Since I can easily delete some this is no big problem. But it looks like the playlists integration still has some problems...