PDA

View Full Version : Wake-on-LAN in tonight's nightly build



dean
2005-08-03, 17:26
Tonight's nightly 6.2 build will include firmware 16, which adds Wake-
on-LAN to the Squeezebox2.

If your SlimServer computer is asleep and has it's network card set
to wake on administrative access, you can wake it up with the remote
by pressing RIGHT from the main settings menu on the player setup
screens or by pressing RIGHT or POWER when on the "Connecting to
SlimServer..." screen.

If you try it out, please post your experiences here.

Thanks to Felix Mueller for a big hand in making this happen.

-dean

kdf
2005-08-03, 19:26
On 3-Aug-05, at 5:26 PM, dean blackketter wrote:

> Tonight's nightly 6.2 build will include firmware 16, which adds
> Wake-on-LAN to the Squeezebox2.
>
> If your SlimServer computer is asleep and has it's network card set to
> wake on administrative access, you can wake it up with the remote by
> pressing RIGHT from the main settings menu on the player setup screens
> or by pressing RIGHT or POWER when on the "Connecting to
> SlimServer..." screen.
>
> If you try it out, please post your experiences here.
>
experience is very bad. I'd suggest not trying it. I'm hard down with
no way to connect to slimserver to even try to downgrade :(
sorry for the bad news
-kdf

kdf
2005-08-03, 19:50
On 3-Aug-05, at 7:26 PM, kdf wrote:

>
> On 3-Aug-05, at 5:26 PM, dean blackketter wrote:
>
>> Tonight's nightly 6.2 build will include firmware 16, which adds
>> Wake-on-LAN to the Squeezebox2.
>>
>> If your SlimServer computer is asleep and has it's network card set
>> to wake on administrative access, you can wake it up with the remote
>> by pressing RIGHT from the main settings menu on the player setup
>> screens or by pressing RIGHT or POWER when on the "Connecting to
>> SlimServer..." screen.
>>
>> If you try it out, please post your experiences here.
>>
> experience is very bad. I'd suggest not trying it. I'm hard down
> with no way to connect to slimserver to even try to downgrade :(
> sorry for the bad news
>
svn 3855 looks ok. If you do get stuck after trying svn 3854, it
should be still able to connect with a wired connection. You can use
that to get back in and update. nightly build shouldn't have a
problem.

note to self: 6.2 is experimental. use with caution :)

-kdf

JJZolx
2005-08-03, 19:56
experience is very bad. I'd suggest not trying it. I'm hard down with
no way to connect to slimserver to even try to downgrade :(
sorry for the bad news
What's this mean for those of us religously staying current with either nightly builds or Subversion on the trunk? Will rev#[whatever] insist on upgrading the firmware, or is the fw upgrade optional?

What's the course of action when something like the above catastrophe occurs and the SB loses it's mind?

JJZolx
2005-08-03, 20:01
svn 3855 looks ok. If you do get stuck after trying svn 3854, it
should be still able to connect with a wired connection. You can use
that to get back in and update. nightly build shouldn't have a
problem.

note to self: 6.2 is experimental. use with caution :)
Didn't see your response while I was posting my question. "Try wired connection if wireless doesn't work" sounds like a sound troubleshooting move. But still leaves me wondering: Can an SB/SB2 be turned into a paperweight by a dodgy firmware upgrade, or is there always some last-ditch means of recovering some old known-good firmware?

dean
2005-08-03, 20:17
On Aug 3, 2005, at 8:01 PM, JJZolx wrote:
> But still leaves me wondering: Can an SB/SB2 be
> turned into a paperweight by a dodgy firmware upgrade, or is there
> always some last-ditch means of recovering some old known-good
> firmware?
Yes, it's possible for a firmware upgrade to cause the player to
become a streamlined brick, so we do test up/downgrading to make sure
that we haven't created a killer firmware image.

The problem with the firmware that was checked in for a couple of
hours was causing some player settings to get corrupted, but as far
as I know, wouldn't have bricked the player. It seems to be fine now.

Bricked players due to faulty firmware would need to come back to our
World Headquarters to be reprogrammed (free of charge, of course), or
have the CPU cards swapped, but it hasn't happened yet...

-dean

oreillymj
2005-08-03, 22:29
I see firmware 15 in the latest 6.2 nighlty directory.

http://www.slimdevices.com/downloads/nightly/latest/6.2/SlimServer_v2005-08-03/Firmware/

Do I need to wait until tommorrow for this directory to have the 16.bin file or do the zips have it.

kdf
2005-08-03, 22:38
On 3-Aug-05, at 10:29 PM, oreillymj wrote:

>
> I see firmware 15 in the latest 6.2 nighlty directory.
>
> http://www.slimdevices.com/downloads/nightly/latest/6.2/
> SlimServer_v2005-08-03/Firmware/
>
> Do I need to wait until tommorrow for this directory to have the 16.bin
> file or do the zips have it.
>
Dean is referring to the nightly build for Aug 4, which will be built
in 2-3 hours from now (around 1am Pacific time)

-kdf

oreillymj
2005-08-04, 03:19
ok, I'll give it a try.

If it works, I reckon a Wiki will be required to educate users on how to configure/test their PC will respond to WOL packets.

I found DSL reports FAQ very helpful, but it still took me a couple of hours of trial and error to get this working.

And that was with a modern PC/NIC that supported WOL without any extra cables.

Troublseshooting/support of this will be difficult for users without 2 pc's or a friend with a laptop.

max.spicer
2005-08-04, 05:22
Fantastic. I'd be particularly interested to hear if anyone gets this going with wireless. I'll give it a go on my setup tonight.

Max


Tonight's nightly 6.2 build will include firmware 16, which adds Wake-
on-LAN to the Squeezebox2.

If your SlimServer computer is asleep and has it's network card set
to wake on administrative access, you can wake it up with the remote
by pressing RIGHT from the main settings menu on the player setup
screens or by pressing RIGHT or POWER when on the "Connecting to
SlimServer..." screen.

If you try it out, please post your experiences here.

Thanks to Felix Mueller for a big hand in making this happen.

-dean

oreillymj
2005-08-04, 05:38
Really Cool,
This works for me.

I tested my Dell Dimension 8300 first to make sure it could be woken by my laptop.

Update the firmware, put the PC to sleep, and the SB2 had no problem waking the PC.


The firmware worked fine. I'm not sure if a small sleep period is required after the magic packet has been sent to allow the PC to wake up like to 20 second count-down when attempting to connect to a WLAN.

BTW the way here are my settings for anyone else to try.
The NIC has to be in the 2nd PCI slot of a PCI 2.2 compatible motherboard.
Older Motherboards need a small cable from the NIC to the M/board.
Dell had my PC configed this way.

In XP, open device manager an locate the Network adapter connected to you router.
Click on the Power Management tab.
Enable the following options.
Allow the computer to turn off this device to save power
Allow this device to bring the computer out of standby

My PC has an Intel PRO/100VE card, so options will vary according to maker. The Advanced tab allows me to alter the sertings of this NIC.
In Advanced go to Wake On LAN, click properties
I have
Enable PME - Enabled
Wake On Link - OS Controlled
Wake on Settings - Wake On Magic Packet

In Power Saver Options, click properties
Reduce power during standby - Enabled.

There are a number of small utilities to can use to test WOL, all you'll need is another PC on the W/LAN and the MAC address of your NIC to try them out. Also don't try anything embedded in a web page, as your router firewall is likely to block the packets before they get anywhere near your internal network.

max.spicer
2005-08-04, 10:36
Doesn't work for me, but that's not really a surprise and almost certainly not your fault. I have an ancient Dell Precision 210 as my server, with an added Belkin wireless card. The BIOS is set to wake on lan for the add-in NIC, but I haven't got any cables between my card and the motherboard. My SB2 is connected via cable to my 3com router.

Max


Tonight's nightly 6.2 build will include firmware 16, which adds Wake-
on-LAN to the Squeezebox2.

If your SlimServer computer is asleep and has it's network card set
to wake on administrative access, you can wake it up with the remote
by pressing RIGHT from the main settings menu on the player setup
screens or by pressing RIGHT or POWER when on the "Connecting to
SlimServer..." screen.

If you try it out, please post your experiences here.

Thanks to Felix Mueller for a big hand in making this happen.

-dean

dean
2005-08-04, 11:01
Yep, that's not going to work. :)

Also, WOL doesn't work on Macs if they are running from battery power
or if they are connected via wireless.



On Aug 4, 2005, at 10:36 AM, max.spicer wrote:
> Doesn't work for me, but that's not really a surprise and almost
> certainly not your fault. I have an ancient Dell Precision 210 as my
> server, with an added Belkin wireless card. The BIOS is set to
> wake on
> lan for the add-in NIC, but I haven't got any cables between my
> card and
> the motherboard. My SB2 is connected via cable to my 3com router.
>
> Max
>
> dean Wrote:
>
>> Tonight's nightly 6.2 build will include firmware 16, which adds
>> Wake-
>> on-LAN to the Squeezebox2.
>>
>> If your SlimServer computer is asleep and has it's network card set
>> to wake on administrative access, you can wake it up with the remote
>> by pressing RIGHT from the main settings menu on the player setup
>> screens or by pressing RIGHT or POWER when on the "Connecting to
>> SlimServer..." screen.
>>
>> If you try it out, please post your experiences here.
>>
>> Thanks to Felix Mueller for a big hand in making this happen.
>>
>> -dean
>>
>
>
> --
> max.spicer
>
> The wild things roared their terrible roars and gnashed their terrible
> teeth
> and rolled their terrible eyes and showed their terrible claws
> but Max stepped into his private boat and waved good-bye
>

oreillymj
2005-08-04, 11:29
Max,

When your PC is powered off, there is no power sent to the wireless NIC.

The PC must keep some power going to the NIC in standby mode for it to receive the WOL magic packet and send a signal to the motherboard telling the PC to wake up.

WOL will work wirelessly if the device sending the packet is Wireless and the device to be woken is using a regular Wired NIC connected to a Wireless router via ethernet cable.

There's also some other bit of setup required which I documented in my previous post.

This FAQ is very useful http://www.dslreports.com/faq/wol

max.spicer
2005-08-04, 14:31
To be honest, I doubt I'll ever get wol lan running, unless I ever get around to running a cable into my loft from the lounge (where my router lives). My current alternative plan is to have my server wake itself up at a particular time each weekday, and a different time each weekend. It already turns itself off at 11pm if no devices are playing, so this seems a reasonable solution.

Max


Max,

When your PC is powered off, there is no power sent to the wireless NIC.

The PC must keep some power going to the NIC in standby mode for it to receive the WOL magic packet and send a signal to the motherboard telling the PC to wake up.

WOL will work wirelessly if the device sending the packet is Wireless and the device to be woken is using a regular Wired NIC connected to a Wireless router via ethernet cable.

There's also some other bit of setup required which I documented in my previous post.

This FAQ is very useful http://www.dslreports.com/faq/wol

gharris999
2005-08-04, 23:20
WOL works like a charm. Both my wired and wireless SB2s wake my P4C800E-DX based media server, no problemo.

Philip Meyer
2005-08-05, 15:13
Hi dean blackketter <dean (AT) slimdevices (DOT) com>,

>Tonight's nightly 6.2 build will include firmware 16, which adds Wake-
>on-LAN to the Squeezebox2.
>
Would it be possible to tie this in to the alarm settings? ie. send the WOL packet 30 seconds before the alarm time? I assume at the moment the SB doesn't have any time code in the firmware, especially if it is sitting at the setup menu, so maybe this is unrealistic.

I guess I could configure the servers BIOS to have a timed wakeup, which is probably just as good ;)

I currently leave the server on all night, as I play music before I nod off in bed. Is there such a thing as a Sleep On Lan packet?!!! eg. press-and-hold remote control sleep button to suspend the server, and press-and-hold remote to wake it up again. That would be cool.

Phil

kdf
2005-08-05, 16:18
Quoting Philip Meyer <slim (AT) hergest (DOT) demon.co.uk>:

> I currently leave the server on all night, as I play music before I nod off
> in bed. Is there such a thing as a Sleep On Lan packet?!!! eg.
> press-and-hold remote control sleep button to suspend the server, and
> press-and-hold remote to wake it up again. That would be cool.

let the execute plugin run a shutdown script on 'stop' or 'power off', so that
when the sleep timer stops playback, and shuts off, the plugin will trigger teh
pc to shut down. Your BIOS will then have to do the timed wake up.

-kdf

gharris999
2005-08-07, 22:08
Is it possible for this feature to make it into the SB1 firmware? Or is there some hardware limitation with SB1s that prevents this?

Tim Collins
2005-08-10, 19:05
I am also interested in seeing Wake-on-Lan added to squeezebox firmware. There is an open bug in the tracker as #331, but it has been out there for quite a while.

oreillymj
2005-08-12, 02:41
I'm seeing an issue here, I've escalated to MS support.

When my PC resumes from standby using the new WOL functionality, it will only stay on for a minute or 2 unless I touch the KB or mouse. I believe this is XP related, but it would be good to get some feedback from the Linux/Mac users on the list.

This MS KB article describes the behaviour I see - http://support.microsoft.com/default.aspx?scid=kb;en-us;810719

The only work-around I can see is a patch from MS to allow Wake-On-Lan to work the same as any other resume or a change to the NIC driver to fake a keyboard press.

Otherwise Wake On Lan becomes a bit pointless since I have to walk up stairs to press a key.

dean
2005-08-12, 07:44
Arg. I'm not sure what we can do about this. Squeezebox2 _could_
send WOL packets every 30 seconds or so, but that would prevent the
machine from going back to sleep.

I wonder if there's a registry setting to adjust that 2-minute
timeout...


On Aug 12, 2005, at 2:41 AM, oreillymj wrote:

>
> I'm seeing an issue here, I've escalated to MS support.
>
> When my PC resumes from standby using the new WOL functionality, it
> will only stay on for a minute or 2 unless I touch the KB or mouse. I
> believe this is XP related, but it would be good to get some feedback
> from the Linux/Mac users on the list.
>
> This MS KB article describes the behaviour I see -
> http://support.microsoft.com/default.aspx?scid=kb;en-us;810719
>
> The only work-around I can see is a patch from MS to allow Wake-On-Lan
> to work the same as any other resume or a change to the NIC driver to
> fake a keyboard press.
>
> Otherwise Wake On Lan becomes a bit pointless since I have to walk up
> stairs to press a key.
>
>
> --
> oreillymj
>

MrC
2005-08-13, 10:18
I'm seeing an issue here, I've escalated to MS support.

When my PC resumes from standby using the new WOL functionality, it will only stay on for a minute or 2 unless I touch the KB or mouse. I believe this is XP related, but it would be good to get some feedback from the Linux/Mac users on the list.

This MS KB article describes the behaviour I see - http://support.microsoft.com/default.aspx?scid=kb;en-us;810719

The only work-around I can see is a patch from MS to allow Wake-On-Lan to work the same as any other resume or a change to the NIC driver to fake a keyboard press.

Otherwise Wake On Lan becomes a bit pointless since I have to walk up stairs to press a key.

Yes, you've discovered Window's go back to sleep in 2 minutes behavior. It can be maddening. Are you finding that it goes back to sleep even though there is network or slimserver activity? It should remain away under such circumstances, but it may be that the KB is referring to activity while logged in and performed by the user.

dean
2005-08-13, 10:40
Vidur and I discussed this problem last night.

I'm considering sending WOL packets every 30 seconds to the connected
server while playing.

I'm also considering sending WOL packets for every Slim Devices
remote IR signal received when on the "Connecting to server..." screen.

Would this work for folks? Are there pitfalls here?


On Aug 13, 2005, at 10:18 AM, MrC wrote:

>
> oreillymj Wrote:
>
>> I'm seeing an issue here, I've escalated to MS support.
>>
>> When my PC resumes from standby using the new WOL functionality, it
>> will only stay on for a minute or 2 unless I touch the KB or mouse. I
>> believe this is XP related, but it would be good to get some feedback
>> from the Linux/Mac users on the list.
>>
>> This MS KB article describes the behaviour I see -
>> http://support.microsoft.com/default.aspx?scid=kb;en-us;810719
>>
>> The only work-around I can see is a patch from MS to allow Wake-On-
>> Lan
>> to work the same as any other resume or a change to the NIC driver to
>> fake a keyboard press.
>>
>> Otherwise Wake On Lan becomes a bit pointless since I have to walk up
>> stairs to press a key.
>>
>
> Yes, you've discovered Window's go back to sleep in 2 minutes
> behavior.
> It can be maddening. Are you finding that it goes back to sleep even
> though there is network or slimserver activity? It should remain away
> under such circumstances, but it may be that the KB is referring to
> activity while logged in and performed by the user.
>
>
> --
> MrC
>

MrC
2005-08-13, 10:58
I'm wondering if Windows actualy pays attention to WoL after its been woken, and during that 2 minute timeout period. Its very possible there's a callback re-sleep timeout waiting for keyboard and mouse activity.

Since Windows is most likely getting lots of network activity, I don't suppose sending more will matter, even WoL (which is received by the NIC anyway).

If you do your test, please post results. I'd be curious to learn how Windows behaves.

max.spicer
2005-08-14, 04:09
Sounds horrific to me. Could you not just remove windows as a supported platform and force everyone to run the server on decent operating systems instead? :-)

That said, the original point of WOL was to enable waking up the server to apply patches etc. I don't think it was intended to necessarily stay awake afterwards. Either way, it really should be an option.

Max


Vidur and I discussed this problem last night.

I'm considering sending WOL packets every 30 seconds to the connected
server while playing.

I'm also considering sending WOL packets for every Slim Devices
remote IR signal received when on the "Connecting to server..." screen.

Would this work for folks? Are there pitfalls here?

oreillymj
2005-08-14, 05:42
Yep, sending more WOL packets would not do anything once the PC is woken.

When the PC goes back to standby, the next WOL packet would wake it again.
But I don't think I'd fancy having the SB constantly re-awakening the PC. The strain on the HD especially is something I'd like to avoid.

It's also ironic that Microsoft thinks that 2 minutes is sufficient to install any of their patches. SP2 takes about an hour to install.

There should definitely be an option in Windows or the NIC driver to keep the PC awake when it's woken by WOL.

I'm going to get back in contact with Microsoft on Monday to follow up on this issue.

I'm curious to know if Linux or OS-x behave the same.

max.spicer
2005-08-14, 08:41
If they did, I can guarantee that you'd be able to change it!

Max


I'm curious to know if Linux or OS-x behave the same.

oreillymj
2005-08-15, 02:31
Hi,

I found this http://msdn.microsoft.com/library/en-us/power/base/setthreadexecutionstate.asp?frame=true API function in XP to tell the system to stay awake. I've compiled an exe which makes the API call, and I'm going to test it tonight using the execute plugin.

Could be a work-around for windows users. Since the execute plugin can perform power events, it should be ideal.

gharris999
2005-08-16, 18:43
I was working on a similar approach, though not as elegant as O’rillymj's. This is what I’ve come up with so far: (please forgive the overly wordy and didactic post.)

If your system running SlimServer is more or less dedicated to that task (i.e. you don’t use it for “real work”) then try the following:

Essentially, you’ll disable system standby and system hibernation in the windows power options and instead put the slimserver in charge of putting your windows box to sleep.

Start by disabling system standby and system hibernation on the windows machine.

Then, download the free pstools suite from www.sysinternals.com. Copy psshutdown.exe to your C:\Program Files\Slimserver\server\Plugins directory.

Download Jason Holtzapple’s PowerSave.pm plug-in from http://ultratrendy.com:31888/slim/ and copy it into the Plugins directory.

With slimserver not running (kill the service or kill perl.exe,) open PowerSave.pm with Wordpad and look for the line towards the bottom that reads:


Slim::Control::Command::execute ($client, ['power', 0]);

Now, immediately below that line, add the following:



#start to shutdown the slimserver box
system("\"C:\\Program Files\\SlimServer\\server\\Plugins\\psshutdown.exe \" -c -d -m \"Slimserver Suspending this computer!\" -t 120\"");
Now, start up Slimserver and enable the PowerSave plugin.

At the SqueezeBox, using the remote, scroll down to plugins, select the PowerSave plugin, set it to ON, and select the time out value.

Now, 15 minutes, 2 hours, (or whatever you set the plugin timeout to) after the SqueezeBox quits playing, the PowerSave plugin will turn off the SqueezeBox and run psshutdown.exe on the Slimserver box. With the parameters set above, the Slimserver box will go into suspend mode after a two minute warning. You can cancel the suspension by clicking on the psshutdown dialog cancel button.

If you do use your slimserver box for “real work,” then having that dialog box pop up in your face might be kind of annoying. Here’s another, more subtle approach:

Again, edit PowerSave.pm with WordPad, and substitute this line for the line you added before:


system("cmd.exe /c \"C:\\Program Files\\SlimServer\\server\\Plugins\\suspendnow.cmd \"");

Now, create two batch files, again in the Plugins directory:

suspendnow.cmd:


@echo off
schtasks /DELETE /s \\slimserver /u usernamd /p password /TN SlimSleep /F
schtasks /create /s \\slimserver /u username /P password /sc ONIDLE /I 10 /tn SlimSleep /tr "%Comspec% /c \"%~dp0suspend_wake.cmd\""

This 1st batch file uses the schtasks.exe command which is part of Windows XP. You’ll need to substitute the computer network name of your slimserver box for the "\\slimserver" entry, and substitute a valid username and password for a user with administrative privileges on the system.

This batch file simply tries to delete the "SlimSleep" scheduled task, if one exists. It then creates the SlimSleep task and schedules it to fire off after the next 10 minute idle period (no mouse or keyboard activity.) You can increase that idle timeout to whatever you want…just change the "/I 10" entry to "/I 45" or whatever.

Next, create the 2nd batch file:

suspend_wake.cmd:


@echo off
start "Suspending" "%~dp0psshutdown.exe" -c -d -m "Slimserver Suspending this computer!" -t 120
echo Sleeping for 5 seconds..
sleep 5
schtasks /DELETE /s \\slimserver /u username /p password /TN SlimSleep /F
This batch file gets invoked by the scheduled task, fires off psshutdown.exe to start the suspend countdown, and finally deletes the task that invoked it.

There. That’s two ways to put Slimserver and your SqueezeBox in charge of power savings on your computer.

reinoud
2005-08-29, 13:06
Hi all,

I am following this discussion for a while because I recently bought a SB myself and I also have problems with standby / wakeup of my server.

To be honest, I don't really like the solution chosen here.

Reason: I am using my slimserver computer also as a home server and when one of the computers goes online I want the server to wake up without having to send a magic-packet. Network activity directed to the server's address should be enough.

All of this worked fine until I installed the SB because it keeps communicating with the server even when on standby. (as you all know). So now my server won't go into standby mode.


Isn't it possible to switch of the SB functionality to keep communicating with the server and have to SB really go into standby mode? I think that would be a much better solution for the problem.


In order to find out if it could work I tried the following:
-> I have setup my Microsoft Server 2003 to allow wake on network activity. I disabled the administrators wake on lan functionality. The server is setup to go in standby mode after 1 minute of idle time.
-> The server goes into standby mode if: a) I switch of the power supply of the SB and b) if I go into network connect mode on the SB (network installation at setup or connect to slimnetwork mode via the menu)
-> Turning the SB power back on or selecting my slimserver on the SB wakes the server instantly. And it stays on. The 2 minute shutdown only appears to be happening if the administrator's wake-on-lan is activated.

So it could work. I hope it is technically possible. What are your thoughts?


Cheers,
Reinoud

PS: I have read this discussion, another about the standby problem and the error log. Sorry if I missed the one I really needed to read.

dean
2005-08-29, 13:26
On Aug 29, 2005, at 1:06 PM, reinoud wrote:
> Isn't it possible to switch of the SB functionality to keep
> communicating with the server and have to SB really go into standby
> mode? I think that would be a much better solution for the problem.
With Squeezebox2 you can press and hold the RIGHT arrow button and go
back to setup. That should disconnect and allow your server to go to
sleep.

reinoud
2005-08-30, 13:33
Thanks for the reply.

I knew that but that isn't a really user-friendly solution is it? Go into setup so that my server can go to sleep.

Why isn't it possible to have the SB2 to disconnect from the network when the power button is pressed. I don't need the clock...

Thanks,
Reinoud

dean
2005-08-30, 14:00
On Aug 30, 2005, at 1:33 PM, reinoud wrote:
> I knew that but that isn't a really user-friendly solution is it? Go
> into setup so that my server can go to sleep.
No, press and hold LEFT to disconnect your player from the network.
Then press RIGHT to connect again. The fact that you can also set
up your network (or choose another server, connect to SqueezeNetwork)
is just a side effect.

>
> Why isn't it possible to have the SB2 to disconnect from the network
> when the power button is pressed. I don't need the clock...
Many folks use the web interface to wake up their "powered off"
Squeezeboxes from the web interface or with the alarm clock feature.

While theoretically it would be possible to disconnect the player
when it's off and the clock is hidden, then send a message to the
player to wake back up later if you wanted to one of the things
listed above, it's cumbersome and wouldn't work in many circumstances.

reinoud
2005-08-30, 14:34
I understand. But I am user who doesn't want the functionality you mentioned.

Is it possible to add a setting to the slimserver that gives the user an option to control this behaviour?

For example: 'SB2 disconnect in standby mode Yes/No'. If the standby button is pressed, the SB2 could check the slimserver setting and acts accordingly.

That would be a perfect solution for me, and maybe also for others.

Thanks,
Reinoud

dean
2005-08-30, 14:57
It would help if you could enter your details in an enhancement
request on http://bugs.slimdevices.com/

That way other folks can add their comments and vote for it.

Thanks,

dean

On Aug 30, 2005, at 2:34 PM, reinoud wrote:

>
> I understand. But I am user who doesn't want the functionality you
> mentioned.
>
> Is it possible to add a setting to the slimserver that gives the user
> an option to control this behaviour?
>
> For example: 'SB2 disconnect in standby mode Yes/No'. If the standby
> button is pressed, the SB2 could check the slimserver setting and acts
> accordingly.
>
> That would be a perfect solution for me, and maybe also for others.
>
> Thanks,
> Reinoud
>
>
> --
> reinoud
>

oreillymj
2005-08-31, 00:29
BTW
I'm still following up on the issue of my PC going back to sleep with Microsoft. I'll try to give another update later in the week. The support engineer I've been dealing with provided me an existing hotfix, but it didn't work.

oreillymj
2005-08-31, 00:38
Regarding Reinoud's comments.
Why doesn't he just disable the Wake On Lan settings on his PC.
Then the SB wil behave as per firmware 15, the WOL packets will get send out on the Network, but the PC will stay in standby.

Maybe I'm mis-understanding his post and therefore his problem.

"I have setup my Microsoft Server 2003 to allow wake on network activity. I disabled the administrators wake on lan functionality. The server is setup to go in standby mode after 1 minute of idle time."

Your running a server that you want to go into standby after 1 minute? By definition a server is a machine that you want to keep up 100% of the time if possible.

Also can you tell me more about disabling Wake-On-Lan functionality in W2k03. If this fixes the sleep issue, it could provide Microsoft with the info required to create a patch for the problem I'm seeing. I currently have a call open with them and would like to provide more feedback.

reinoud
2005-09-01, 01:14
Thanks all for your replies. I will try to descibe my situation a bit better.

- I have this server at home to share data, pictures and music.
- I want the server to go down on order to save on the electricity bill and because of the noise the machine makes.
- To wake the server up takes only seconds and as long as there is network activity directed to the server, it wont go down. That's why I am using the 1 minute time.
- I am not always using the SB2.
- I have two laptops and besides the server no other computer. If I switch one of them on, the server wakes and I can logon to the domain defined on the server. That way we can easily share all files and printers. If switched off the server goes to sleep automatically.

So this all worked perfectly for months. Until I bought the SB2. Perfect machine but it keeps communicating with the server even if in standby mode. So the server won't go to sleep anymore.

Why I don't like the administrator wake-on-lan option:
- If I switch on one of the laptops and try to logon to the domain, no WOL (=magic packet) is send, so the server wouldn't wake and I cannot logon.
- Apparently the administrator option on Server 2003 should not be used for this purpose because it automatically shuts itself down after 2 minutes. It's designed for administrator activities on the server.

Why I don't like the slimserver and/or the remote control of the SB@ to take control of the wake/sleep state of my server by using scripts etc.:
- because I am not always using the SB2.

Hopefully it's more clear now what the problem is and why I want the SB2 to stop communicating with the server if in standby mode.


As for your question:
"Also can you tell me more about disabling Wake-On-Lan functionality in W2k03. If this fixes the sleep issue, it could provide Microsoft with the info required to create a patch for the problem I'm seeing. I currently have a call open with them and would like to provide more feedback."

I am not an expert on Server 2003 but I did a lot of testing and can only tell you my findings and opinion.
I have found out that while on normal wake-on-lan everything works fine. Waking and staying awake is no problem as long as there is network traffic directed to the server. So with the SB2 switched on it wakes and stays awake.
If the administrator wake-on-lan option is ticked a magic package is needed to wake the server but then the server goes back to standby after two minutes if not used by an administrator. If I wake the server with the magic package and remotely log on using the standard remote administrator access of Server 2003, the server stays awake. This is also the case if you work directly on the computer.
So my quess is that this option is designed for administrators to wake the server if shut down in case of problems and allow them to fix the problem. So not for end-users or end-user hardware like the SB2. Normal wake-on-lan should be used instead.

You wrote previously:
"I have Enable PME - Enabled"
"Wake On Link - OS Controlled"
"Wake on Settings - Wake On Magic Packet"

Why don't try another "wake on setting"? Is there a setting like 'any traffic'? You will see that than you don't need a WOL (magic package) to wake the server.


Or am I missing something? Is there another reason why we want the SB2 to send WOL packages (=magic package)? If normal network traffic directed to the slimserver computer also wakes it. And normal traffic is a 'ping' to the computer's ip address.


Cheers,
Reinoud

oreillymj
2005-09-01, 05:35
reinoud,

Thanks for providing further details.
It sounds like you are using "Wake On Link" which means any activity sent towards your machine while in standby will wake the it. When you switch on a laptop and try to log on to the domain, you send network traffic to your W2k03 server. I thought that Wake on Link was designed to wake a machine when the network cable is plugged/unplugged from a port.

I had to disable this setting as my machine would not go into standy properly. It would only stay in standby for about 1 second before waking up again. At the time I reckoned that the router was somehow polling the ports causing the link state to change and the PC to wake.

I'll do more testing tonight with my SB turned off to see if I can sucessfully send the PC to sleep with Wake on Link enabled.

If it turns out that the SB is sending packets to the server even when (the SB2 is supposed to be) off, then there is a bigger issue the WOL packets.

That would suggest that anyone using wake on link will have problems with an SB2 on their network.

reinoud
2005-09-01, 07:15
Hi,

Looks like you have the same problem as I have. My server goes to sleep and immidiately wakes up again.

Has to do with the SB2 looking for the slimserver constantly even in standby mode.

I am pretty sure that if you change to 'wake on link' mode with the SB2 powered off, the standby mode will work again. Power on the SB2 and the server wakes.
You will see that in SB2 setup mode the server will go to sleep as well.


Have fun testing,
Reinoud

bgriffis
2005-09-01, 20:07
Hi,

I just received my SB2 *today* and am really loving it so far. Well, I'm about to go to bed and normally at night I put my computer in sleep mode to save power. It won't stay asleep any more! As soon as I put it to sleep it wakes right back up. Before getting my SB2 I had been doing this for a couple months.

I've had a laptop on the network which is able to share printers and files with my desktop which is where Slim Server is installed. On the desktop I went into the device manager and I enabled the "Allow this device to bring the computer out of standby" option in the Power Management tab for the ethernet chip. This has worked really well in the past. For example if my desktop is asleep and I try to open a shared file from the laptop then the desktop will wake up and the laptop can access the file.

I would love to see some kind of option for the SB2 to stop sending network traffic when it is in standby. I saw a post about pressing the left arrow but that's a real pain. I know I'll forget to do this and have to go back down to the basement later on...

For now I'm going to just turn off Slim Server, put my desktop to sleep, and then go to sleep myself! If someone can come up with a better fix though it would be much appreciated!

Brad

bgriffis
2005-09-01, 20:09
Arg! Killing Slim Server is not enough -- I'll have to treck down to the basement after all and try the "left arrow" method.

Brad

reinoud
2005-09-01, 21:56
Looks like I am really not the only one....

Brad:
Try turning off your SB2 instead of the slimserver. So don't use the standby button on the remote but unplug the power cable.

I suggested a solution to Dean before but I am waiting for Oreilly's testing results before I log it as an improvement.

bgriffis
2005-09-02, 04:51
Reinoud,

Thanks for the reply. I ended up unplugging it so that I could get my computer to sleep!

I can't imagine we're the only ones that are having (or will have) this problem. I think in general people are becoming more power conscious about their PCs and having an idle PC go to sleep seems a pretty logical solution.

Brad

dean
2005-09-02, 08:10
Well, this behavior has been in all of our products since 2001 and
hasn't really been an issue before, but I understand what you are
saying.

There are actually three ways to disconnect from your server:

1. Unplug your player.
2. Press and hold LEFT for a few seconds.
3. Connect to SqueezeNetwork.

I guess what you are asking for is a fourth way to disconnect, using
the POWER button, right?

On Sep 2, 2005, at 4:51 AM, bgriffis wrote:

>
> Reinoud,
>
> Thanks for the reply. I ended up unplugging it so that I could get my
> computer to sleep!
>
> I can't imagine we're the only ones that are having (or will have)
> this
> problem. I think in general people are becoming more power conscious
> about their PCs and having an idle PC go to sleep seems a pretty
> logical solution.
>
> Brad
>
>
> --
> bgriffis
>

reinoud
2005-09-02, 10:02
That would be perfect Dean. Just switching on and off using the power button.

But please don't misunderstand me (or us). We are in love with the SB2 and are just trying to improve it.

bgriffis
2005-09-03, 06:23
Dean,

Thanks for the reply. Right now I'm using the "unplug your player" method. This works but feels silly to do something so low-tech on such a high-tech player! I tried holding LEFT for a few seconds and it definitely disconnected. I watched the player for a few minutes afterward and it didn't appear that the screen ever went dim. Does the "screensaver" not kick in when you go into setup mode? I was afraid it might wear out the screen if I have it in that bright mode all the time. Plus it would be distracting when I'm watching tv or something.

You are correct in what we are asking. We are requesting that you add a setting for this though such as "Disconnect from network on Power Off (Yes/No)?" Right now there is no choice. It is "hard coded" to always stay connected. With that menu choice you could make the default behavior to stay connected so for most people it would look the same, but there would be an option for people like us using sleep modes to have it disconnect on power down.

By the way, I think you will see this become more and more of an issue as time goes on. As you can see from all of Intel's current marketing they are really pushing the low-power aspect of their new dual core architecture. Plus in the new Windows Vista to come out late next year they will be simplifying power-down schemes there. Supposedly there will be just one power-down mode (as opposed to stand-by and hibernate now) and it will have "instant on" wake-up. I would guess that more and more people will start using these methods going forward so it would be nice to have capabilities for that in place. The few "early adopters" of this kind of thing like me will be mighty happy too.

Please let me know about the screen brightness thing when I hold LEFT. If it will eventually dim then that could be a solution. The power button option would be more elegant though if it's not a ridiculous amount of work to implement.

Cheers,
Brad


Well, this behavior has been in all of our products since 2001 and
hasn't really been an issue before, but I understand what you are
saying.

There are actually three ways to disconnect from your server:

1. Unplug your player.
2. Press and hold LEFT for a few seconds.
3. Connect to SqueezeNetwork.

I guess what you are asking for is a fourth way to disconnect, using
the POWER button, right?

> [/color]

dean
2005-09-03, 07:38
On Sep 3, 2005, at 6:23 AM, bgriffis wrote:
> Thanks for the reply. Right now I'm using the "unplug your player"
> method. This works but feels silly to do something so low-tech on
> such
> a high-tech player! I tried holding LEFT for a few seconds and it
> definitely disconnected. I watched the player for a few minutes
> afterward and it didn't appear that the screen ever went dim. Does
> the
> "screensaver" not kick in when you go into setup mode? I was
> afraid it
> might wear out the screen if I have it in that bright mode all the
> time. Plus it would be distracting when I'm watching tv or something.
Good point. Can you file an enhancement request at: http://
bugs.slimdevices.com


> By the way, I think you will see this become more and more of an issue
> as time goes on. As you can see from all of Intel's current marketing
> they are really pushing the low-power aspect of their new dual core
> architecture. Plus in the new Windows Vista to come out late next
> year
> they will be simplifying power-down schemes there. Supposedly there
> will be just one power-down mode (as opposed to stand-by and hibernate
> now) and it will have "instant on" wake-up. I would guess that more
> and more people will start using these methods going forward so it
> would be nice to have capabilities for that in place. The few "early
> adopters" of this kind of thing like me will be mighty happy too.
Well, the real problem is a limitation in windows.

Wake-On-Lan is designed for just this purpose, but unfortunately
Windows shuts itself down after one minute of being awake. "Wake on
network activity" is probably a little bit overkill, given all the
network enabled applications out there.

reinoud
2005-09-05, 01:45
Dean,

You wrote:
"Well, the real problem is a limitation in windows"
I don't agree. The WOL is designed for administrator purposes. The "Wake on network activity" is designed for normal network traffic, like the SB2.

And:
"Wake on network activity is probably a little bit overkill, given all the network enabled applications out there."

The wake only happens if there is network traffic directed to the computer's ip-address, in other cases it stays asleep. So it works perfectly.


I like Brad's solution with the 'Disconnect from network on Power Off (Yes/No)?' option much more. Is it too difficult/expensive to implement for the SB2?


Reinoud

oreillymj
2005-09-05, 15:25
Apologies,

I haven't been able to post recently.

Dean is correct. Windows is sending the PC back to standby when it should stay awake due to network activity, so this is a Windows bug/limitation.

Your issue is different. You seem to be either using wake on link or some other W2k03 feature which bring your pc out of standy when it detects any network traffic directed at it.

My own limited testing since my last post have been frustrating. My PC will now sucessfully stay in standby with Wake on Link enabled. I think the previous behaviour I saw (standby/wake/standby/wake) may have been caused by a bug in the NIC driver I was using. I upgraded as part of my recent troubleshooting.

Microsoft have closed my call, claiming that the behaviour is down to a bios setting. I'm going to try re-open the call as Windows is not even behaving according to MS's own Kb article. Pings or Network traffic directed at my pc should keep it awake.
There are no bios setting's I can see which would cause the behaviour I'm experiencing.

reinoud
2005-09-06, 01:12
No worries but it seems that communication is very difficult. Probably has to due with the fact that english isn't my mother tongue.

I selected Wake-on-link in the Bios. Server 2003 gives two power options for the network adapter. 1-allow this device to wake the computer. 2-only allow administrators to do this.

I selected option 1 only. If I select option 2, the computer needs a magic package to wake. Also if I select option 2, the computer is showing the same problems as you describe, it only stays awake for 2 minutes.


I still think we are having the same problem.

You wrote:
"may have been caused by a bug in the NIC driver I was using. I upgraded as part of my recent troubleshooting"
I think it has only to do with your bios change and not with the upgrade you did. Switch back to "wake-on-lan" instead of "wake-on-link" and you will see "standby/wake/standby/wake" behaviour returns.

you also wrote:
"My PC will now sucessfully stay in standby with Wake on Link enabled"
Yes, it stays awake because the SB2 keeps communication with it. Wake-on-link means 'network activity directed to the computer's ip address' and not 'network cable connected'.

I quess that you now, with the 'wake-on-link' option selected, have trouble getting the computer to sleep. And that is because the SB2 is constantly communicating with your server.

Switch the SB2 off and you will see the server goes to sleep automatically. Switch on the SB2 and your server wakes and stays awake.

But I could be wrong and we could have a different problem.

Reinoud

MrC
2005-09-06, 08:58
Wake-on-link means 'network activity directed to the computer's ip address' and not 'network cable connected'.

I do not believe this is correct. Wake on Link is trigger by the low-level ethernet hardware heartbeat pulse. This is well below the IP level - in fact, its controlled by the lower level of ethernet at the physical layer. Mac Address and IP address have nothing to do with this. Absence of the pulse triggers an ACPI sleep state - restoration of the pulse triggers the ACPI resume (wake) state.

reinoud
2005-09-06, 13:34
It's too technical for me but you seem to know very well what you're talking about. So I quess I am wrong about the wake-on-link. (I only learned that name in this discussion...)

In my Bios I have only the following setting:
- Wake on PME enabled/disabled. I have it enabled. Google learned me that PME (power management event) is the same as WOL.

In my Microsoft Server 2003 I have the following power options for my network adapter:
1) allow this device to bring the computer out of standby
2) allow only management stations to bring the computer out of standby

I have found out that if you only select option 1, you don't need a magic package to wake the computer. Network traffic directed to the computer's ip address is enough.

However when I select option 2. I need a magic package to wake the computer and the computer only stays awake for 2 minutes.

The help text for option 2 is: "Specifies the computer to come out of low power state only when the device receives certain types of network traffic, which are typically sent by a network administrator. When you select this box, the only network traffic that causes the device to bring the operating system out of low power state is traffic sent by a network administrator. Clear the check box to allow all network traffic to cause the device to bring the computer out of a low power state. As a rule, if the computer provides services to other computers, you should clear the check box so that other computers can bring it out of a low power state."

Maybe it's more clear now what I am talking about.

And again, with my settings the system works beautifully and I trully believe that it is setup like it is designed to be. It wakes and stays awake. By switching on my laptop or SB2. It only won't go to sleep while the SB2 is powered on.

I do think it is very typically that my system with option 2 selected behaves exactly the same as the systems of the other users, like shutting itself down after two minutes.

I also agree with another user that this is a hot toppic, given the number of hits on this discussion. And I trully hope that somewhere in the future I will have the option to stop the SB2 communciating with the server in standby mode.

Meanwhile I am unpluging the power cable of the SB2 when I go to sleep at night instead of using the power button on the remote.

But the SB2 plays beautifully

rbetts
2005-10-02, 06:59
Just reading some stuff on this post. Wake On Lan WILL work over wireless and it is very simple. The MAC address of the target device to Wake on the network is broadcast 16 times either on a broadcast address or an IP directed broadcast.

There are two things required for WOL. The MAC address of the target machine and the IP address if an IP directed broadcast is required. For networks where routers are present an IP directed broadcast is required but this should not be an issue in any home network (You would hope!) so a standard broadcast is ok!

I currently have a squeezebox 1 and think WOL would be a great addition and I would be happy to upgrade to version 2 should WOL be a supported feature. The only issue I can see with WOL is to enable it on the PC hosting the server. Most modern LAN cards support WOL, some require a small connecting lead to the mainboard. Most LAN cards are now built in so this is not a problem. Just change the BIOS settings to listen for WOL packets!

The main issue I have with the SqueezeBox is that I have to go upstairs and switch on my PC first. With WOL, my problem is solved! How about a shutdown feature when you poweroff the squeezebox?? Should be easy to implement!!!

BombaPunch
2005-11-03, 09:38
I entered a bug to request a power button option in the SB2 & SB3 to actually turn the device off (and allow the server to sleep). IMO, WOL functionality for customers that host Slimserver on a windows platform is useless without this option. Please vote for this bug!

http://bugs.slimdevices.com/show_bug.cgi?id=2476

bomba

don_quay
2006-01-26, 04:24
I have posted a bug that achieves the same ends, but in a different way.

I am proposing for the SB to cause the PC to do some busy-work while playing, which would keep the PC awake. Once the SB stops playing, the PC would have nothing to do and go to sleep after the set period.

This would work where WOL is activated, with the "Administrator Only" checkbox marked.