PDA

View Full Version : sub enabled



Neil Sleightholm
2005-08-02, 14:17
I just noticed that many of the builtin plugins have had the following added:
sub enabled {
return ($::VERSION ge '6.1') && initPlugin();
}

Is this something that all plugins will require? Does it define the minimum version required to enable the plugin?

Neil

dean
2005-08-02, 14:32
I added this because some folks were doing downgrades which caused
the newer plugins (which weren't removed) to crash on older versions
of slimserver.


On Aug 2, 2005, at 2:17 PM, Neil Sleightholm wrote:

>
> I just noticed that many of the builtin plugins have had the following
> added:
> sub enabled {
> return ($::VERSION ge '6.1') && initPlugin();
> }
>
> Is this something that all plugins will require? Does it define the
> minimum version required to enable the plugin?
>
> Neil
>
>
> --
> Neil Sleightholm
>

Neil Sleightholm
2005-08-03, 10:43
Thanks Dean.