View Full Version : Softsqueeze Headless Mode Fedora FC3

2005-07-28, 16:06
Hi, I've searched the forums and softsqueeze page but I haven't been able to find a solution to this problem.

Using Fedora Core 3,Java 1.5, softsqueeze_linux_2_0b8.rpm and running /opt/softsqueeze/softsqueezeHeadless

Yields the error below. Seems like something simple, but I can't seem to figure it out. Any help would be greatly appreciated. (I'm running in command-line (init 3) on linux. I do have gnome and enough X libraries installed to run that on occasion, but right now this is a machine with no monitor attached so I just run it without X.

0 [main] INFO config - Reseting user preferences
Error starting Softsqueeze:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
java.awt.GraphicsEnvironment.checkHeadless(Unknown Source)
java.awt.Window.<init>(Unknown Source)
java.awt.Frame.<init>(Unknown Source)
java.awt.Frame.<init>(Unknown Source)
javax.swing.SwingUtilities$SharedOwnerFrame.<init>(Unknown Source)
javax.swing.SwingUtilities.getSharedOwnerFrame(Unk nown Source)
javax.swing.JOptionPane.getRootFrame(Unknown Source)
javax.swing.JOptionPane.showOptionDialog(Unknown Source)
javax.swing.JOptionPane.showMessageDialog(Unknown Source)
javax.swing.JOptionPane.showMessageDialog(Unknown Source)
com.slim.softsqueeze.Config._reset(Config.java:297 )
com.slim.softsqueeze.SoftSqueeze.main(SoftSqueeze. java:463)
com.slim.softsqueeze.Application.main(Application. java:53)

2005-07-28, 17:22
Actually, after some more hunting for the error in general (rather than as related to Softsqueeze) I found this...

"/usr/X11R6/bin/Xvfb :15 & (probably ar root on startup, only needed once)
(:15 is just an example, :0 is the default, you just have to remember it for the following step:)

before starting the java server process:

DISPLAY=:15; export DISPLAY;"

After install Xvfb and running the headless again, I now get:

"[main] INFO config - Reseting user preferences"

each time and then the player doesn't show up via the web broswer. Do I need to tell it where my slimserver is?

2005-07-30, 11:31
shameless bump.

Patrick Dixon
2005-07-30, 12:12
I'd like to help (although I'm not sure I can), but I don't really understand what you are trying to do: you're running FC3 headless and softsqueeze - on the same machine? How are you going to see/hear the softsqueeze output? Where/how is the headless FC3 controlled?

2005-07-30, 13:54
The point of headless is that he doesn't care about seeing the GUI - rather, just the music stream, which will be controlled via the web interface.

I'm not sure about headless being supported for you situation. here are two references that supports some doubt:




Vimes, if you just want to get things running quickly, you couuld use VNC (just run vncserver on FC3 and then run the VNC viewer (www.realvnc.com, or ultravnc and connect).

2005-07-30, 14:30
Java 1.4 and up should support headless without too much difficulty, and without needing Xvfb. What's the contents of "/opt/softsqueeze/softsqueezeHeadless"?

2005-07-30, 16:17
Thanks for the responses. MrC. is right. I'm trying to run softsqueeze in headless mode b/c the box happens to be connected to a stereo system. It also happens to be the machine running slimserver. I don't want to run X on it as I don't really need it and don't want to burn the resources. I'd just like to launch softqueeze in headless mode and then control from the web browser. Currently I'm using some other jinky free jukebox software, but it would be nice to leverage the Slimdevices UI and playlists and keep everything centralized.

*edit: /opt/softsqueeze/softsqueezeHeadless is a shell script included with the rpm distro of softqueeze. Seems to be mostly setting up classpaths.

2005-07-30, 16:30
Vimes wrote:

>each time and then the player doesn't show up via the web broswer. Do I
>need to tell it where my slimserver is?
Yes you do. Try softsqueezeHeadless -Dslimserver= (or your
server IP address)


2005-07-31, 08:51
Richard, Thanks for the help. Still no luck though. I just get the info message about preferences and then it seems to be running (via ps ax on another terminal) but doens't seem to be recognized by slimserver. There's no error.log in /opt/softsqueeze either. Is there anywhere else I can look for errors?

As a side note, if I run softsqueeze on my windows PC it works fine, is picked up immediatly etc. Thanks again...seems like I'm missing something obvious.