PDA

View Full Version : Search kills server in 6.1.1 OS X



morps
2005-07-26, 20:04
If I do a search through the default UI (not sure if that really matters), the server dies. In the console, the following is reported:

Modification of a read-only value attempted at /Users/mikemorper/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/HTTP.pm line 1194.
2005-07-26 20:00:06.0555 Got to the END.
2005-07-26 20:00:06.0560 Got sigint.
2005-07-26 20:00:06.0562 SlimServer cleaning up.

Going back into the Preference pane and restarting the server gets me back up, but this failure happens 100% of the time.

...any ideas???

kdf
2005-07-26, 20:33
On 26-Jul-05, at 8:04 PM, morps wrote:

>
> If I do a search through the default UI (not sure if that really
> matters), the server dies. In the console, the following is reported:
>
> Modification of a read-only value attempted at
> /Users/mikemorper/Library/PreferencePanes/SlimServer.prefPane/
> Contents/server/Slim/Web/HTTP.pm
> line 1194.
>
Are you searching for something that doesn't exist?
Which search mode are you using, live or advanced?
Which skin are you using, and which browser?

-kdf

morps
2005-07-27, 07:07
On 26-Jul-05, at 8:04 PM, morps wrote:

Are you searching for something that doesn't exist?
Which search mode are you using, live or advanced?
Which skin are you using, and which browser?

-kdf

1. Nope, searching for known artists.
2. Under the Search Music section, I am using the "search music" link which brings up a single text field where I enter what I'm looking for (as opposed to using the "Advanced Search" in the same section).
3. Web interface = default. Browser: Crashes both with Mac OS X Safari 1.3 as well as Windows FireFox 1.06.

kdf
2005-07-28, 10:33
Quoting morps <morps.1su0en (AT) no-mx (DOT) forums.slimdevices.com>:

>
> kdf Wrote:
> > On 26-Jul-05, at 8:04 PM, morps wrote:
> >
> > Are you searching for something that doesn't exist?
> > Which search mode are you using, live or advanced?
> > Which skin are you using, and which browser?
> >
> > -kdf
>
> 1. Nope, searching for known artists.
> 2. Under the Search Music section, I am using the "search music" link
> which brings up a single text field where I enter what I'm looking for
> (as opposed to using the "Advanced Search" in the same section).
> 3. Web interface = default. Browser: Crashes both with Mac OS X Safari
> 1.3 as well as Windows FireFox 1.06.

I'm not sure what's happening here, and I'm unable to reproduce it. In the
interest of making sure this isn't just left forgotten, please file a bug
report at http://bugs.slimdevices.com and provide as much detail as you can.

-kdf

Ben
2005-08-10, 04:41
Was a bug ever posted on this? I'm getting the exact same behavior with 6.1.2, but mines was installed in /library

Modification of a read-only value attempted at /Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/HTTP.pm line 1194.
2005-08-10 06:34:55.6809 Got to the END.
2005-08-10 06:34:55.6811 Got sigint.
2005-08-10 06:34:55.6812 SlimServer cleaning up.

Search in default2 worked correctly. I haven't tried a 6.2 nightly yet.

Ben

leonyu13
2005-08-27, 23:03
I get the same behavior running slimserver on Redhat 9.0 and accessing from XP machine using both Firefox 1.0.6 and IE 6.0. I filed bug 2030 http://bugs.slimdevices.com/show_bug.cgi?id=2030.

Running latest nightly 8/27 RPM.