PDA

View Full Version : songs being duplicated in playlist scan



mikeb
2005-07-26, 11:02
I have a 509 item playlist;

# wc -l /var/db/slimserver/playlists/playlist.m3u
509 /var/db/slimserver/playlists/playlist.m3u

Every file in it is a mp3, no directories or playlists;
# grep -v .mp3$ /var/db/slimserver/playlists/playlist.m3u
#

Upon loading it, slimserver shows me that I have 782 songs loaded. That's
pretty impossible since I cleared the playlist prior to playing this.

It is duplicating 272 of the songs. After downloading the list I see;

root@pinky:/root# sort status.m3u | uniq -c | grep ^\ *2 | wc -l
272

(for those that noticed the math is off by one there is a single
non-existant song that it had found, still tracking that down as well)

Obviously playback is pretty bad if those duplicates end up near each
other after the playlist is shuffled. So what's the deal? Anyone else
have this issue?

I stopped the server, cleared the cache, restarted, reloaded the playlist
and the same problem can be repeated every single time.

Next, I enabled debugging d_scan and d_playlist, had Slimserver (v6.1.1)
reload the playlist, and sure enough I see it finding the same song twice.
There is definitely something broken here.

I see bugs referencing accented characters and case sensitivity issues
causing this, neither are an issue here.

Any help is appreciated. I can submit a bug if no one has experience with
this or any ideas.

--
"Never believe anything until it's been officially denied"
- Claud Cockburn

Dan Sully
2005-07-26, 11:13
* Mike Benjamin shaped the electrons to say...

>I have a 509 item playlist;
>
># wc -l /var/db/slimserver/playlists/playlist.m3u
> 509 /var/db/slimserver/playlists/playlist.m3u
>
>Every file in it is a mp3, no directories or playlists;
># grep -v .mp3$ /var/db/slimserver/playlists/playlist.m3u
>#

Mike - can you send me your slimserversql.db file and the playlist.m3u ?

Thanks.

-D
--
<jwb> "I am POWERBOOK thy god. Thou shalt have no other laptop before me"
<gage> and the mountains shall drop sweet wine, and the hills shall melt

oreillymj
2005-07-26, 11:39
Mike,

I posted in the Beta forum that since 6.1b1, the track count in the UI is incorrect as it is counting tracks in playlists in addition to tracks in your music directory.

So for example, if your music directory had 50 tracks, and you 1 playlist with 20 tracks in it, the UI would report that there were 70 tracks in your collection.

I don't see duplicated tracks in the UI

mikeb
2005-07-26, 11:55
> Mike,
>
> I posted in the Beta forum that since 6.1b1, the track count in the UI
> is incorrect as it is counting tracks in playlists in addition to
> tracks in your music directory.
>
> So for example, if your music directory had 50 tracks, and you 1
> playlist with 20 tracks in it, the UI would report that there were 70
> tracks in your collection.

That doesn't seem to be what's occurring here, my music folder is set to a
hierarchy of folders/files that contain no playlists and the playlist that
I'm loading (which sits in the playlist root) contains every single song
from that hierarchy. There aren't even 700 songs in the music folder root
at this instant, yet the web UI says there are 770 songs in it, from a
playlist that contained 509 songs.


> I don't see duplicated tracks in the UI

>From the UI I hit "Download" on the playlist, and there are definitely
duplicates in it. I have heard the same song come up twice in an hour
period on multiple occassions in the last few weeks. I'm not sure if this
is a historic problem or something new as I did not investigate fully
until today.

--mikeb

>
>
> --
> oreillymj
>

Colin Reilly
2005-07-26, 12:01
I have the same issue since upgrading to 6.1.1. When I open an album of songs in Slim Server it shows each song twice. Like the above poster I cleared the cache and rescanned, but it happens every time.

Colin

Colin Reilly
2005-07-26, 12:07
To clarify, in my case every song on every album is duplicated. It shows that I have 1155 songs when in fact I only have half that number.

Colin

Dan Sully
2005-07-26, 12:14
* Colin Reilly shaped the electrons to say...

>To clarify, in my case every song on every album is duplicated. It
>shows that I have 1155 songs when in fact I only have half that number.

Colin - please send me your slimserversql.db file.

dan | at | slimdevices.com

Thanks.

-D
--
<nil> It sucks to discover that you are the foremost authority on some set of things when you've got a problem.

Colin Reilly
2005-07-26, 13:31
Dan,

I fixed the problem. When I was rescanning it seems it was looking in two different places. I originally had iTunes on my C:\ drive, but I added another drive and put a copy of iTunes there. In Slimserver/server settings I pointed it at the new drive, but it found the copy of the music folder on the original drive also, even although I set it not to look for iTunes automatically, and gave it the path to the new drive. When I deleted the iTunes on my C:\ drive and rescanned all was OK.

Regards
Colin

Dan Sully
2005-07-26, 13:39
* oreillymj shaped the electrons to say...

>I posted in the Beta forum that since 6.1b1, the track count in the UI
>is incorrect as it is counting tracks in playlists in addition to
>tracks in your music directory.
>
>So for example, if your music directory had 50 tracks, and you 1
>playlist with 20 tracks in it, the UI would report that there were 70
>tracks in your collection.
>
>I don't see duplicated tracks in the UI

oreillymj - could you send me your slimserversql.db file?

'Tracks within a playlist' are the same thing in the database as 'Tracks
outside a playlist' as it were.

Thanks.

-D
--
<dmercer> Because that is what our industry does.
Churns out useless shit. Followed by inferior re-implementations of useless shit.

oreillymj
2005-08-02, 07:40
Dan,

Sorry, just seen your message, I'll zip up and send you my Db file.

I'm wondering if you now have this fixed in 6.2 since you closed http://bugs.slimdevices.com/show_bug.cgi?id=1896

This bug also seem to explain some other weird behaviour i've seen since upgrading to 6.1.x.

I had deliberately moved some soundtrack/xmas tunes from my main music folder to stop the tracks from being scanned and included in my music library. I don't need Jingle Bells playing in July.

I had then created playlists for these albums, so the song wereaccessible, but only using the playlist, but that seems to have broken, probably due to the fact that bug 1896 was allowing scanning outside of the music dir specified in preferences.

My music folder is set to
C:\Documents and Settings\<userid>\My Documents\My Music\MP3

My Playlist foldr is set to
C:\Documents and Settings\<userid>\My Documents\My Music\My Playlists

My folder hierarchy

My Music

__Mp3

__Coldplay etc...

__My Playlists

__Cinema Paradiso.m3u etc...

__Soundtracks

__CAL

__Cinema Paradiso

__Xmas

_Bing Crosby