PDA

View Full Version : Slimserver 6.1.1 cannot set music folder to network drive on XP



Pantau
2005-07-23, 10:22
After installing Slimserver 6.1.1 I get following message
" Oops - "t:" doesn't seem to be a valid directory. Try again."
when the path is a network drive. With local drives it works.
I also tried \\server\musicfolder for path information, but got the same error. I tried it on to different machines.

I'm running Slimserver 6.1.1 3774 on Windows XP SP2.
Does anybody have the same problem ?

Cheers
Beat Graf

mherger
2005-07-23, 10:42
> After installing Slimserver 6.1.1 I get following message
> " Oops - "t:" doesn't seem to be a valid directory. Try again."
> when the path is a network drive. With local drives it works.
> I also tried \\server\musicfolder for path information, but got the
> same error. I tried it on to different machines.

Slimserver can't see your mounted network shares when run as a service.
And the standard user used to run a service does not have right to access
any share. Please search to forum on how to change that user. It's a
common problem.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

sbjaerum
2005-07-23, 10:55
> After installing Slimserver 6.1.1 I get following message
> " Oops - "t:" doesn't seem to be a valid directory. Try again."
> when the path is a network drive. With local drives it works.
> I also tried \\server\musicfolder for path information, but got the
> same error. I tried it on to different machines.

Slimserver can't see your mounted network shares when run as a service.
And the standard user used to run a service does not have right to access
any share. Please search to forum on how to change that user. It's a
common problem.

--

Michael


Or take a look at
http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume

Steinar

dSw
2005-07-25, 09:33
I started having the same problem after upgrading to 6.1.

To fix it, I first of all switched to starting the SlimServer app manually after boot up (! couldn't be bothered setting up a new password-locked account!).

This still didn't allow SlimServer to see my music folder so I had to change my music folder specification from "M:" to "\\LS1" and now the folder can be seen ok by SlimServer.

I also changed my symbolic links from the drive letter to their equivalent machine name, however I'm not entirely clear if this was necessary or not.

Was the drive letter change mentioned anywhere in the 6.1 docs? If not it should have been. The only mention I see of it is for starting SlimServer as a Service.

Roy Owen
2005-07-25, 11:56
This is a Windows issue. Mapped network drives with letters are not
available to services, they are part of the user's profile. In order to use
the share you *MUST* use UNC notation, if you are using a disparet network
(ie not Windows) you are out of luck. Also try having the service run as a
named user and not as system (the default), you still have to use UNC
notation but connection is easier/more reliable.

On 7/25/05, dSw <dSw.1sqhsb (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> I started having the same problem after upgrading to 6.1.
>
> To fix it, I first of all switched to starting the SlimServer app
> manually after boot up (! couldn't be bothered setting up a new
> password-locked account!).
>
> This still didn't allow SlimServer to see my music folder so I had to
> change my music folder specification from "M:" to "\\LS1" and now the
> folder can be seen ok by SlimServer.
>
> I also changed my symbolic links from the drive letter to their
> equivalent machine name, however I'm not entirely clear if this was
> necessary or not.
>
> Was the drive letter change mentioned anywhere in the 6.1 docs? If not
> it should have been. The only mention I see of it is for starting
> SlimServer as a Service.
>
>
> --
> dSw
>

dSw
2005-07-25, 13:09
This is a Windows issue. Mapped network drives with letters are not
available to services, they are part of the user's profile. In order to use
the share you *MUST* use UNC notation, if you are using a disparet network
(ie not Windows) you are out of luck. Also try having the service run as a
named user and not as system (the default), you still have to use UNC
notation but connection is easier/more reliable.


I guess what you are saying is that 6.1 now only installs as a service (albeit with a choice of manual or automatic), as opposed to 6.0.2 and below, which gave you the option of installing as a service or not.

Roy Owen
2005-07-25, 13:58
You should still be able to start slimserver from the command line once you
are logged into windows.

On 7/25/05, dSw <dSw.1sqrqn (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> Roy Owen Wrote:
> > This is a Windows issue. Mapped network drives with letters are not
> > available to services, they are part of the user's profile. In order to
> > use
> > the share you *MUST* use UNC notation, if you are using a disparet
> > network
> > (ie not Windows) you are out of luck. Also try having the service run
> > as a
> > named user and not as system (the default), you still have to use UNC
> > notation but connection is easier/more reliable.
> >
>
> I guess what you are saying is that 6.1 now only installs as a service
> (albeit with a choice of manual or automatic), as opposed to 6.0.2 and
> below, which gave you the option of installing as a service or not.
>
>
> --
> dSw
>