PDA

View Full Version : excessive load at startup



stinkingpig
2005-07-16, 20:57
I've been on vacation and just deleted the 500 messages in my Slim
folder unread, so I might have missed a thread on this. Anyway, I'm
seeing load as high as 35 during startup with Slimserver 6.1 nightlies
since a bit before beta 2, using AlienBBC 0.97 and a month-old
SlimScrobbler CVS as my only external plugins. The load is caused by a
huge number of mDNSResponderPosix processes. I just restarted the 6.1b2
daemon about 5 minutes ago and I still have 39 of these open.

slimserver.log isn't saying anything interesting -- is this known or
should I dig further?
--
Jack at Monkeynoodle dot Org: It's a Scientific Venture...
Riding the Emergency Third Rail Power Trip since 1996!

Dan Sully
2005-07-16, 23:32
* Jack Coates shaped the electrons to say...

>I've been on vacation and just deleted the 500 messages in my Slim
>folder unread, so I might have missed a thread on this. Anyway, I'm
>seeing load as high as 35 during startup with Slimserver 6.1 nightlies
>since a bit before beta 2, using AlienBBC 0.97 and a month-old
>SlimScrobbler CVS as my only external plugins. The load is caused by a
>huge number of mDNSResponderPosix processes. I just restarted the 6.1b2
>daemon about 5 minutes ago and I still have 39 of these open.
>
>slimserver.log isn't saying anything interesting -- is this known or
>should I dig further?

Kill them all. I reworked the mDNSResponder handling, I think in time for b2
(honestly can't remember at this hour), so that shouldn't happen anymore.
There's probably a buildup of previous processes from stopping and starting.

-D
--
There was supposed to be a big kaboom.

stinkingpig
2005-07-16, 23:45
Dan Sully wrote:
> * Jack Coates shaped the electrons to say...
>
>> I've been on vacation and just deleted the 500 messages in my Slim
>> folder unread, so I might have missed a thread on this. Anyway, I'm
>> seeing load as high as 35 during startup with Slimserver 6.1 nightlies
>> since a bit before beta 2, using AlienBBC 0.97 and a month-old
>> SlimScrobbler CVS as my only external plugins. The load is caused by a
>> huge number of mDNSResponderPosix processes. I just restarted the
>> 6.1b2 daemon about 5 minutes ago and I still have 39 of these open.
>>
>> slimserver.log isn't saying anything interesting -- is this known or
>> should I dig further?
>
>
> Kill them all. I reworked the mDNSResponder handling, I think in time
> for b2
> (honestly can't remember at this hour), so that shouldn't happen anymore.
> There's probably a buildup of previous processes from stopping and
> starting.
>
> -D


good call, some of them dated back to early April. I'm rescanning the
database now, so I can't say if it's going to improve performance until
that's done.

--
Jack at Monkeynoodle dot Org: It's a Scientific Venture...
Riding the Emergency Third Rail Power Trip since 1996!