PDA

View Full Version : Problems rescanning library



GlennBooth
2005-07-15, 03:02
Hi,

I've had my new Squeezebox 2 for a few days, and I'm really impressed, but there is one niggle I can't fix. the 'rescan' feature doesn't seem to work correctly for me.

I rip a CD, then copy the compressed audio files to the music library directory (a Samba share on a Linux box) and hit the rescan button in Slimserver. I get the message "The server is now rescanning your music library" but it never seems to complete the job, and the newly added music does not appear in the library, though the files are visible on the Samba share.

I can force the issue by wiping the cache, which does add the new music correctly, but even then the server web interface doesn't let me know when the rebuild is complete - the interface always says it's rescanning, even after being left overnight.

FWIW, I'm using the Windows version of Slimserver 6.0.2 (I have a whole bunch of WMA files I can't replace, or I'd use the Linux version). The music files are in OGG format, and work fine if I wipe the cache.

What am I doing wrong? Are there any logs I can use that might give me some clues?

Thanks,

Glenn.

mherger
2005-07-15, 03:26
> I can force the issue by wiping the cache, which does add the new music
> correctly, but even then the server web interface doesn't let me know
> when the rebuild is complete - the interface always says it's
> rescanning, even after being left overnight.

You'll have to update the left panel yourself, either by navigating around
or by your browser's refresh button. It won't update itself.

> What am I doing wrong? Are there any logs I can use that might give me
> some clues?

-d_scan -d_files -d_info

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

dean
2005-07-15, 07:35
Glenn,

Can you try the 6.1 beta release and see if that resolves your problem?

Thanks,

dean

GlennBooth
2005-07-18, 11:56
Hi,

Thanks for the suggestions. I have installed the 6.1 beta release, and things have definitely changed for the better. Rescanning now seems to work properly, but I needed to get my tagging in shape as well, as that may have contributed to the problem.

Ripped about 100 CDs at the weekend, and I'm loving it - the best thing about the Squeezebox is finding all that old music I haven't heard in ages. Music is a hobby again.

Thanks again,

Glenn.