View Full Version : Unable to change remote mapping

Dave D
2005-07-14, 19:45
I thought I would play with the remote mappings a bit on my SB2 remote, but my changes seem to have no effect, even though I have restarted slimserver. In case my new mapping was invalid, I also tried *disabling* the "hold-pause-to-stop" function by commenting out this line: pause.hold = stop. That did not work, either; this function continued to operate as if I had done nothing.

Here's what I was originally trying to do: I saw in Slim::Buttons::Common that the "muted" mapping is set up to call Slim::Control::Command::execute. (So a "mute" function exists, right? At least on the JVC remote?) So I added the following line to Default.map in the [Common] mode section:

sleep.hold = muting

and I commented out the line:

muting = muting

(since this button does not exist on the SB2 remote)

Restarted Slimserver (and also the SB2) but it didn't work. I also tried other buttons--actually started with 0.hold--without success. That's when I started trying to disable a function, also without success.

What am I doing wrong?


Slimserver 6.0.2
Win XP Pro with all the updates

Dave D
2005-07-14, 20:01
Sorry for that post. Boy do I feel stupid.

As I was getting ready to hit the hay, it occurred to me that I have two copies of the slimserver code: one in the install directory and one in another sandbox. I was modifying the wrong one.

Sorry about that. The mappings work just as I would expect.

- Dave