PDA

View Full Version : YALNQ: Yet Another Linux Newbie Question



gharris999
2005-07-09, 09:48
Anyone willing to help me save 3 hours of googling and head scratching? Iíve got Fedora Core 4 installed on my Thinkpad and Iím trying to copy my MP3 library over the network from a windows share. Iím mounting the share with:

mount -t smbfs -o username=foo,password=bar //10.0.1.103/mp3recordings /mnt/mp3recordings

The mount succeeds. So, I try copying the mp3 files to an external 200gig drive that Iíve got formatted to ext3:

rsync -a -v /mnt/mp3recordings/music/* /media/usbdisk/recordings/music

So far, so good. The files copy. However, many of the filenames get mangled into something like:

01 - Sibil la latine (Barcelona X-XI si?cles).mp3 (invalid encoding)

I assume that Iíve somehow got to tell Linux about the codepage of the windows box Iím copying from. Do I do that with an extra command line option to the mount command, or what?

Thanks in advance for having patience with a complete Linux nube.

Patrick Dixon
2005-07-09, 10:24
I'm pretty green with Linux, but on FC3 I use cifs to mount my Windows network drives (I had load of problems with smbfs)

create a mountpoint:

mkdir /mnt/DellMusic

and add a line to /etc/fstab:

//Dell-01/Music /mnt/DellMusic cifs guest,rw 0 0

and the drive will get mounted at boot.

I haven't had any problems with character sets, so I don't know if this approach will solve your problem or not.

Robin Bowes
2005-07-09, 11:55
gharris999 wrote:
> Anyone willing to help me save 3 hours of googling and head scratching?
> Iíve got Fedora Core 4 installed on my Thinkpad and Iím trying to copy
> my MP3 library over the network from a windows share. Iím mounting the
> share with:
>
> mount -t smbfs -o username=foo,password=bar //10.0.1.103/mp3recordings
> /mnt/mp3recordings
>
> The mount succeeds. So, I try copying the mp3 files to an external
> 200gig drive that Iíve got formatted to ext3:
>
> rsync -a -v /mnt/mp3recordings/music/* /media/usbdisk/recordings/music
>
> So far, so good. The files copy. However, many of the filenames get
> mangled into something like:
>
> 01 - Sibil la latine (Barcelona X-XI si?cles).mp3 (invalid encoding)
>
> I assume that Iíve somehow got to tell Linux about the codepage of the
> windows box Iím copying from. Do I do that with an extra command line
> option to the mount command, or what?
>
> Thanks in advance for having patience with a complete Linux nube.

Right, this is not a complete solution, but some thoughts about how I
would go about this.

1. Why not rsync directly from the Windows box to the Linux server?
2. Use scp (or pscp - from the PuTTY ssh bundle) to copy the files.
3. Use ftp
4. Use samba and mount the linux share on the windows box.

Option 4 is probably your best choice as Samba will deal with the
codepage issues.

R.

gharris999
2005-07-09, 11:59
Well, that was easy. I just replaced ďsmbfsĒ with ďcifsĒ in my mount command. Thanks for the tip. Now, as I watch filenames scroll past on the terminal screen as rsync does itís work, most of the folder and filename diacritic characters are translated into "?"s. But, when I view the folder in nautilus, the characters appear ok. I guess I'll see what slimserver's routines make of them sometime later this week when I cobble together a linux mediaserver machine from spares. I guess I'll try Robin's samba technique next if slimserver barfs on what I pulled this way.