PDA

View Full Version : Server stops when softsqueeze exits



MrC
2005-06-30, 21:38
Hi,

When one of my slimserver's softsqueeze client exits, it seems to cause the slimserver to stop. I don't know if slimserver is exiting normally, or if it crashes. It seems to happen all the time with this particular client.

Has anyone else experienced this? And suggestions for how to diagnose/resolve?

Thanks,
MrC

Dan Sully
2005-06-30, 21:43
* MrC shaped the electrons to say...

>When one of my slimserver's softsqueeze client exits, it seems to cause
>the slimserver to stop. I don't know if slimserver is exiting normally,
>or if it crashes. It seems to happen all the time with this particular client.

What OS are you using? Any information on the crash would help.

Windows will have the crash in the Event Log.

Other OSes will have it on the console.

-D
--
<dr.pox> wtf? a garbled dingbat makes java switch to DWIM?

kdf
2005-06-30, 21:49
On 30-Jun-05, at 9:38 PM, MrC wrote:

>
> Hi,
>
> When one of my slimserver's softsqueeze client exits, it seems to cause
> the slimserver to stop. I don't know if slimserver is exiting
> normally,
> or if it crashes. It seems to happen all the time with this particular
> client.
>
> Has anyone else experienced this? And suggestions for how to
> diagnose/resolve?
>
can you find any messages in the log, or the event viewer from
slimserver when it dies?

-kdf

MrC
2005-06-30, 22:55
Server: 6.1b1
OS: WinXP

Client: SoftSqueeze 2.0b9
OS: WinXP

I don't find anything relevant in the windows event log. On a side note, I do find:


Can't use string ("") as a subroutine ref while "strict refs" in use at /PerlApp/Slim/Buttons/Common.pm line 1078.

It seems that the server just exits, as opposed to crashes.

If there's a log for slimserver itself, I certainly don't find it. Debugging is all disabled.

Dan Sully
2005-06-30, 23:02
* MrC shaped the electrons to say...

>> Can't use string ("") as a subroutine ref while "strict refs" in use at
>> /PerlApp/Slim/Buttons/Common.pm line 1078.
>
>It seems that the server just exits, as opposed to crashes.
>
>If there's a log for slimserver itself, I certainly don't find it.
>Debugging is all disabled.

Is this reproducable? If so, what steps did you take?

Thanks.

-D
--
<dr.pox> does whistling in the dark make me go blind faster?

kdf
2005-06-30, 23:07
Quoting MrC <MrC.1rh8dz (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Server: 6.1b1
> OS: WinXP
>
> Client: SoftSqueeze 2.0b9
> OS: WinXP
>
> I don't find anything relevant in the windows event log. On a side
> note, I do find:
>
> > Can't use string ("") as a subroutine ref while "strict refs" in use at
> > /PerlApp/Slim/Buttons/Common.pm line 1078.

what plugins do you have installed?
what screensavers are you using?
did you install over top of 6.0.2?

This particular error is usually the result of a plugin that isn't loading
correctly, a result of a player mode that didnt' register properly.

can you try the following:

stop the server
open up a command prompt (start->accessories)
cd "\program files\slimserver\server"
slim.exe --d_plugins
watch for any errors in the startup and you can report any of them here.

-kdf

kdf
2005-06-30, 23:07
Quoting MrC <MrC.1rh8dz (AT) no-mx (DOT) forums.slimdevices.com>:

>
> Server: 6.1b1
> OS: WinXP
>
> Client: SoftSqueeze 2.0b9
> OS: WinXP
>
> I don't find anything relevant in the windows event log. On a side
> note, I do find:
>
> > Can't use string ("") as a subroutine ref while "strict refs" in use at
> > /PerlApp/Slim/Buttons/Common.pm line 1078.

what plugins do you have installed?
what screensavers are you using?
did you install over top of 6.0.2?

This particular error is usually the result of a plugin that isn't loading
correctly, a result of a player mode that didnt' register properly.

can you try the following:

stop the server
open up a command prompt (start->accessories)
cd "\program files\slimserver\server"
slim.exe --d_plugins
watch for any errors in the startup and you can report any of them here.

-kdf

MrC
2005-07-01, 00:06
I think I've narrowed the scope a bit more, at least to something that is repeatable.

From the Music Player section of the web interface, when I select a particular player, and then click on the Power button (Music Player section, upper right, default skin), the server quits.

However, when I've selected my own player, the power button on the web interface does not kill the server.

I did install the server over a 6.02 version.

As for the request to post the plugin debug output, here it is:



C:\Program Files\SlimServer\server>slim.exe --d_plugins
2005-07-01 00:01:44.1527 BROWSE_MUSIC does not exist. creating...
2005-07-01 00:01:44.1533 Registering screensaver Now Playing (Jump back on wake.)
2005-07-01 00:01:44.1535 Registering screensaver None
2005-07-01 00:01:46.5953 Requiring Plugins::Lyrics plugin.
2005-07-01 00:01:46.6056 PLUGINS does not exist. creating...
2005-07-01 00:01:46.6058 Requiring Plugins::Rescan plugin.
2005-07-01 00:01:46.6117 Requiring Plugins::Visualizer plugin.
2005-07-01 00:01:46.6168 Requiring Plugins::Archive plugin.
2005-07-01 00:01:46.6260 Requiring Plugins::Favorites::Plugin plugin.
2005-07-01 00:01:46.6304 Adding Favorites::Plugin to menu: PLUGINS
2005-07-01 00:01:46.6306 Requiring Plugins::DateTime::Plugin plugin.
2005-07-01 00:01:46.6343 Requiring Plugins::RadioIO::Plugin plugin.
2005-07-01 00:01:46.6396 Adding RadioIO::Plugin to menu: RADIO
2005-07-01 00:01:46.6397 RADIO does not exist. creating...
2005-07-01 00:01:46.6403 Requiring Plugins::Podcast::Plugin plugin.
2005-07-01 00:01:46.6470 Requiring Plugins::SavePlaylist plugin.
2005-07-01 00:01:46.6513 Requiring Plugins::AlbumReview::Plugin plugin.
2005-07-01 00:01:46.6992 Requiring Plugins::NoSetup::Plugin plugin.
2005-07-01 00:01:46.7049 Requiring Plugins::SlimTris plugin.
2005-07-01 00:01:46.7112 Removing SlimTris from menu: GAMES
2005-07-01 00:01:46.7114 Requiring Plugins::Picks::Plugin plugin.
2005-07-01 00:01:46.7164 Adding Picks::Plugin to menu: RADIO
2005-07-01 00:01:46.7171 Requiring Plugins::Live365::Plugin plugin.
2005-07-01 00:01:46.7590 Adding Live365::Plugin to menu: RADIO
2005-07-01 00:01:46.7605 Requiring Plugins::RssNews plugin.
2005-07-01 00:01:46.7768 Removing RssNews from menu: PLUGINS
2005-07-01 00:01:46.7770 Requiring Plugins::iTunes plugin.
2005-07-01 00:01:46.8824 Requiring Plugins::ShoutcastBrowser::Plugin plugin.
2005-07-01 00:01:46.9045 Adding ShoutcastBrowser::Plugin to menu: RADIO
2005-07-01 00:01:46.9187 Podcast Plugin initializing.
2005-07-01 00:01:46.9188 Podcast Feed Info:
2005-07-01 00:01:46.9189 PodcastAlley Top 50, http://podcastalley.com/PodcastAlleyTop50.opml
2005-07-01 00:01:46.9190 PodcastAlley 10 Newest, http://podcastalley.com/PodcastAlley10Newest.opml
2005-07-01 00:01:46.9191

kdf
2005-07-01, 00:22
On 1-Jul-05, at 12:06 AM, MrC wrote:

>
> I think I've narrowed the scope a bit more, at least to something that
> is repeatable.
>
>> From the Music Player section of the web interface, when I select a
> particular player, and then click on the Power button (Music Player
> section, upper right, default skin), the server quits.
>
> However, when I've selected my own player, the power button on the web
> interface does not kill the server.
>

so, this dies when you accidentally kill the power for some 'other'
player.

are you running the server with several remote clients then?
are some of these http clients? winamp, windows media player, that sort
of thing?

which skin are you using?

-kdf

MrC
2005-07-01, 00:31
so, this dies when you accidentally kill the power for some 'other' player.
Yes. But don't misunderstand - this was just a test I did to see what happens. The real issue I'm reporting is that the server dies when the remote user quits the player.


are you running the server with several remote clients then?
1 or 2 players. But the server quit happens when there is only 1 player.


are some of these http clients? winamp, windows media player, that sort of thing?
As mentioned, only SoftSqueeze clients.


which skin are you using?
On the squeeze? slim
On the web interface? Default2

kdf
2005-07-01, 00:59
will it quit when you power off just from the web interface, or does it
also crash when you hit the softsqueeze power button?

Is it always just a certain client? if so, what screensavers are
selected for that client?

you might also want to try running from command prompt again, this time:
slim.exe --d_files

you'll want to look for a message like: "pushing button mode: xxxxxxx"

-kdf

CavesOfTQLT
2005-07-01, 03:02
Sorry for gatecrashing this thread but my problem is the same as MrC's with the exception that on my XP system the server dies when you try to start Softsqueeze.

kdf: I've done what you suggested to MrC:-


stop the server
open up a command prompt (start->accessories)
cd "\program files\slimserver\server"
slim.exe --d_plugins
watch for any errors in the startup and you can report any of them here.
and it seems to have crashed the command prompt window whilst executing line 6049.


[...]
6044 Slashdot, http://slashdot.org/index.rss
6045 Yahoo! News: Business, http://rss.news.yahoo.com/rss/business
6049

So it does look like it could be a plug-in issue. Any suggestions as to what to try now?

kdf
2005-07-01, 03:16
On 1-Jul-05, at 3:02 AM, CavesOfTQLT wrote:
>>
> and it seems to have crashed the command prompt window whilst executing
> line 6049.
line 6049 of what?

> Code:
> --------------------
> [...]
> 6044 Slashdot, http://slashdot.org/index.rss
> 6045 Yahoo! News: Business, http://rss.news.yahoo.com/rss/business
> 6049
> --------------------
>
>
> So it does look like it could be a plug-in issue. Any suggestions as to
> what to try now?
>
it looks like a lot is missing. Please try to paste the EXACT crash
message from the console or the event viewer.
-kdf

CavesOfTQLT
2005-07-01, 03:28
Please try to paste the EXACT crash
message from the console or the event viewer.
-kdf
Edit: Ignore this, see post below.

CavesOfTQLT
2005-07-01, 03:32
Ah ha, got it.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Program Files\SlimServer\server>slim.exe --d_plugins
2005-07-01 11:29:53.7657 BROWSE_MUSIC does not exist. creating...
2005-07-01 11:29:53.7665 Registering screensaver Now Playing (Jump back on wake.
)
2005-07-01 11:29:53.7666 Registering screensaver None
2005-07-01 11:29:56.4760 Requiring Plugins::Rescan plugin.
2005-07-01 11:29:56.4839 PLUGINS does not exist. creating...
2005-07-01 11:29:56.4841 Requiring Plugins::MusicMagic::Plugin plugin.
2005-07-01 11:30:01.5000 Requiring Plugins::Visualizer plugin.
2005-07-01 11:30:01.5060 Registering screensaver PLUGIN_SCREENSAVER_VISUALIZER_S
PECTRUM_ANALYZER
2005-07-01 11:30:01.5062 Registering screensaver PLUGIN_SCREENSAVER_VISUALIZER_A
NALOG_VUMETER
2005-07-01 11:30:01.5063 Registering screensaver PLUGIN_SCREENSAVER_VISUALIZER_D
IGITAL_VUMETER
2005-07-01 11:30:01.5064 SCREENSAVERS does not exist. creating...
2005-07-01 11:30:01.5066 Requiring Plugins::Scrobbler plugin.
Slim::Player::Playlist::setExecuteCommandCallback( ) will be removed in SlimServe
r v6.2 - please update your plugins.
2005-07-01 11:30:01.5677 Can't load plugin Plugins::Scrobbler - not 6.0+ compati
ble. (displayName must return a string token, strings() must not use _DATA_)
2005-07-01 11:30:01.5680 Requiring Plugins::Favorites::Plugin plugin.
2005-07-01 11:30:01.5733 Adding Favorites::Plugin to menu: PLUGINS
2005-07-01 11:30:01.5741 Requiring Plugins::DateTime::Plugin plugin.
2005-07-01 11:30:01.5792 Registering screensaver PLUGIN_SCREENSAVER_DATETIME
2005-07-01 11:30:01.5797 Requiring Plugins::RadioIO::Plugin plugin.
2005-07-01 11:30:01.5864 Adding RadioIO::Plugin to menu: RADIO
2005-07-01 11:30:01.5866 RADIO does not exist. creating...
2005-07-01 11:30:01.5874 Requiring Plugins::Podcast::Plugin plugin.
2005-07-01 11:30:01.5958 Requiring Plugins::SavePlaylist plugin.
2005-07-01 11:30:01.6017 Requiring Plugins::MoodLogic::Plugin plugin.
2005-07-01 11:30:01.6284 Requiring Plugins::SlimTris plugin.
2005-07-01 11:30:01.6358 Adding SlimTris to menu: GAMES
2005-07-01 11:30:01.6361 GAMES does not exist. creating...
2005-07-01 11:30:01.6364 Requiring Plugins::Picks::Plugin plugin.
2005-07-01 11:30:01.6423 Adding Picks::Plugin to menu: RADIO
2005-07-01 11:30:01.6433 Requiring Plugins::Live365::Plugin plugin.
2005-07-01 11:30:01.6949 Adding Live365::Plugin to menu: RADIO
2005-07-01 11:30:01.6967 Requiring Plugins::RssNews plugin.
2005-07-01 11:30:01.7159 Adding RssNews to menu: PLUGINS
2005-07-01 11:30:01.7163 Registering screensaver PLUGIN_RSSNEWS_SCREENSAVER
2005-07-01 11:30:01.7166 Requiring Plugins::iTunes plugin.
2005-07-01 11:30:01.7373 Requiring Plugins::ShoutcastBrowser::Plugin plugin.
2005-07-01 11:30:01.7651 Adding ShoutcastBrowser::Plugin to menu: RADIO
2005-07-01 11:30:01.7841 Podcast Plugin initializing.
2005-07-01 11:30:01.7844 Podcast Feed Info:
2005-07-01 11:30:01.7846 Amplified, http://feeds.feedburner.com/amplified
2005-07-01 11:30:01.7847 Vinyl, http://vinyl.codyhanson.com/wp-rss2.php
2005-07-01 11:30:01.7848
2005-07-01 11:30:01.7852 RSS Feed Info:
2005-07-01 11:30:01.7854 BBC News World Edition, http://news.bbc.co.uk/rss/newso
nline_world_edition/front_page/rss091.xml
2005-07-01 11:30:01.7855 CNET News.com, http://news.com.com/2547-1_3-0-5.xml
2005-07-01 11:30:01.7856 New York Times Home Page, http://www.nytimes.com/servic
es/xml/rss/nyt/HomePage.xml
2005-07-01 11:30:01.7858 RollingStone.com Music News, http://www.rollingstone.co
m/rssxml/music_news.xml
2005-07-01 11:30:01.7864 Slashdot, http://slashdot.org/index.rss
2005-07-01 11:30:01.7866 Yahoo! News: Business, http://rss.news.yahoo.com/rss/bu
siness
2005-07-01 11:30:01.7868

Strangely this time around all the 'line numbers' have changed.

kdf
2005-07-01, 03:40
On 1-Jul-05, at 3:28 AM, CavesOfTQLT wrote:

>
> kdf Wrote:
>> Please try to paste the EXACT crash
>> message from the console or the event viewer.
>> -kdf
> That's the problem - because the command prompt window has crashed you
> cannot copy anything in the window. I figure the only way is to get a
> screen grab which will then be a PITA to get put on here easily, but
> I'll see what I can do.
>
command prompt you can drag the mouse and select the text. press
enter, and you have copied to clipboard. Open up a new email and press
CTRL-V and you should get the text.

failing that:

slim.exe --logfile c:\mylog.txt

wait for crash, and send c:\mylog.txt

-kdf

mherger
2005-07-01, 03:43
>> Please try to paste the EXACT crash
>> message from the console or the event viewer.
>> -kdf
> That's the problem - because the command prompt window has crashed you
> cannot copy anything in the window. I figure the only way is to get a
> screen grab which will then be a PITA to get put on here easily, but
> I'll see what I can do.

Try to start slimserver from the command line, not by doubleclicking it.
That window won't close.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

kdf
2005-07-01, 03:48
Quoting CavesOfTQLT <CavesOfTQLT.1rhl4c (AT) no-mx (DOT) forums.slimdevices.com>:


> 2005-07-01 11:30:01.7864 Slashdot, http://slashdot.org/index.rss
> 2005-07-01 11:30:01.7866 Yahoo! News: Business,
> http://rss.news.yahoo.com/rss/bu
> siness
> 2005-07-01 11:30:01.7868
>
> --------------------
>
> Strangely this time around all the 'line numbers' have changed.
>
what you have above is a log, with timestamps down to fractions of a second.
nothing there shows a crash of any kind. Does the server really stop after the
yahoo rss line? are you not able to access the web interface after this point?

what shows up when you start softsqueeze, which I belive was where said that you
have your crash?

-kdf

CavesOfTQLT
2005-07-01, 04:09
Does the server really stop after the
yahoo rss line?
What you see in the code window is exactly what happens. Nothing appears after the 7868, so I assumed a crash.


are you not able to access the web interface after this point?
If I fire up the Slimserver web interface it appears to work normally. I can search music with no problem. However the systray icon shows 'Slimserver Stopped'.


what shows up when you start softsqueeze, which I belive was where said that you
have your crash?
Okay a typical scenario is this:
1. PC turns on and Slimserver fires up automatically.
2. Click on the Softsqueeze player icon in Quicklaunch (or via the Softsqueeze entry under 'If you do not own a Squeezebox') and the following occurs
White Softsqueeze2 splash logo appears
The 'Squeezebox' player graphic appears with 'Welcome - Free Your Music' on the display
The display then shows 'Lost contact with Slimserver'
Go into web interface and it shows in the right pane

Connection Failure Error

The connection was refused when attempting to contact localhost:9000.

The browser was unable to connect to the specified site, even though it exists. This may be because the site does not accept connections from your computer, the service may be down, or the site does not support the service or port that you tried to connect to.

Click on 'Home' in the left pane and this pane then shows the above connection error message.

3. Slimserver has stopped.

MrC
2005-07-01, 16:38
will it quit when you power off just from the web interface, or does it
also crash when you hit the softsqueeze power button?
Yes to all.


Is it always just a certain client? if so, what screensavers are selected for that client?
Yes, always with the same client. Screensavers are:
Screensaver (Playing): Now Playing (Jump back on wake.)
Screensaver (Stopped): Now Playing
Screensaver (off): Now Playing


you might also want to try running from command prompt again, this time: slim.exe --d_files

you'll want to look for a message like: "pushing button mode: xxxxxxx"

-kdf

Here's the output of --d_files. I think it shows the cause of the crash.


C:\Program Files\SlimServer\server>slim.exe --d_files
2005-07-01 16:21:35.9651 Got /C:/Documents%20and%20Settings/MrC/My%20Documents/My%20Music/iTunes/iTunes%20Music from file url file://localhost/C:/Documents%20and%20Settings/MrC/My%20Documents/My%20Music/iTunes/iTunes%20Music
2005-07-01 16:21:36.0294 extracted: C:\Documents and Settings\MrC\My Documents\My Music\iTunes\iTunes Music from file://localhost/C:/Documents%20and%20Settings/MrC/My%20Documents/My%20Music/iTunes/iTunes%20Music
2005-07-01 16:21:50.4240 pushing button mode: home
2005-07-01 16:21:50.4298 pushing button mode: INPUT.List
2005-07-01 16:22:17.4823 popped to button mode: empty!
2005-07-01 16:22:17.4934 popped to button mode: empty!
2005-07-01 16:22:17.4949 pushing button mode: off
2005-07-01 16:22:17.5067 pushing button mode: nosaver
2005-07-01 16:22:17.5075 Backtrace:

frame 0: Slim::Buttons::Common::pushMode (/PerlApp/Slim/Buttons/ScreenSaver.pm line 120)
frame 1: Slim::Buttons::ScreenSaver::screenSaver (/PerlApp/Slim/Utils/Timers.pm line 100)
frame 2: Slim::Utils::Timers::checkTimers (slimserver.pl line 610)
frame 3: main::idle (slimserver.pl line 572)
frame 4: main::main (slimserver.pl line 61)
frame 5: PerlSvc::Interactive (perlsvc.pl line 1485)
frame 6: PerlSvc::_interactive (slimserver.pl line 0)
frame 7: (eval) (slimserver.pl line 0)

2005-07-01 16:22:17.5081 Crashing because 'nosaver' has no mode function. Perhaps you mis-typed the mode name.

Use of uninitialized value in subroutine entry at /PerlApp/Slim/Buttons/Common.pm line 1078, <DATA> line 1.
Can't use string ("") as a subroutine ref while "strict refs" in use at /PerlApp/Slim/Buttons/Common.pm line 1078, <DATA> line 1.

ceejay
2005-07-02, 01:04
You can get the same problem with the SB2 itself... I just upgraded to 6.1b1, the SB2 upgraded its firmware to 14. I was playing with the menus (as you do!), set the Screensave (Off) to "None", then turned off the SB2 - and the server crashed. Have tested this several times now and its definitely the screensave option that's the cause of the problem, as I guess the last trace shows...

Platform is WinXP SP2.

ceejay

kdf
2005-07-02, 01:15
Quoting MrC <MrC.1rilgo (AT) no-mx (DOT) forums.slimdevices.com>:

> > Is it always just a certain client? if so, what screensavers are
> > selected for that client?
> Yes, always with the same client. Screensavers are:
> Screensaver (Playing): Now Playing (Jump back on wake.)
> Screensaver (Stopped): Now Playing
> Screensaver (off): Now Playing
>
> > you might also want to try running from command prompt again, this time:
> > slim.exe --d_files
> >
> > you'll want to look for a message like: "pushing button mode: xxxxxxx"
> >
> > -kdf
>
> Here's the output of --d_files. I think it shows the cause of the
> crash.

it does, but I'm confused as to how the log is showing the 'nosaver' mode, if
you have it set to "now playing" for off. 'nosaver' is the mode used for the
"none" screensaver.

I'm not sure why it is attempting to change modes for "none", but maybe I forgot
another part of the code. I'll look into it. In the meantime, you or ceejay
can file a bug report (http://bugs.slimdevices.com) on this so that its not
lost.

thanks,
kdf

kdf
2005-07-02, 01:50
Quoting ceejay <ceejay.1rj8uc (AT) no-mx (DOT) forums.slimdevices.com>:

>
> You can get the same problem with the SB2 itself... I just upgraded to
> 6.1b1, the SB2 upgraded its firmware to 14. I was playing with the
> menus (as you do!), set the Screensave (Off) to "None", then turned off
> the SB2 - and the server crashed. Have tested this several times now
> and its definitely the screensave option that's the cause of the
> problem, as I guess the last trace shows...

I suggested filing a bug report, but I think I have the fix for this already. I
needed to cover the 'off' case. It's too late to get this into the july 2
nightly but it will be in the july 3 build.

-kdf

MrC
2005-07-05, 09:31
I suggested filing a bug report, but I think I have the fix for this already. I
needed to cover the 'off' case. It's too late to get this into the july 2
nightly but it will be in the july 3 build.

-kdf

The July 4th build seems to have solved the crash. Also, players no longer dissappear from the web interface (under Home/Settings) when disconnected.

Thanks!

kdf
2005-07-05, 10:08
Quoting MrC <MrC.1rpggb (AT) no-mx (DOT) forums.slimdevices.com>:


> The July 4th build seems to have solved the crash. Also, players no
> longer dissappear from the web interface (under Home/Settings) when
> disconnected.
>
good to hear! The presistence of players is as designed. If you are not
restarting the server, the players will stay listed. You can click player
settings and 'forget player' if you want to remove any.

-kdf

ceejay
2005-07-05, 14:46
As before, testing with an SB2... upgraded server to 5th July nightly, and sure enough the server no longer crashes when I turn the SB2 off with "Screensaver (off)" set to "none". Excellent.

However I am puzzled by the behaviour of the Screensaver (off) setting.

First, I'm not at all sure why I am presented with the options of having VU meters or Spectrum Analyser (seem to make no sense for an "off" device). However, if I select one of these I get a blank screen when I turn the SB2 off, which is ok.

Second, I'm not sure what the "none" value is meant to do here. It seems to leave the display on date-and-time when I turn it off... so how is that different from the "date and time" value? I was initially expecting "none" to give me a blank screen, though I can see how this might be taken to mean "don't have a screensaver, ie leave the screen as it was....".

ceejay.

kdf
2005-07-05, 15:14
Quoting ceejay <ceejay.1rpv1b (AT) no-mx (DOT) forums.slimdevices.com>:

>
> First, I'm not at all sure why I am presented with the options of
> having VU meters or Spectrum Analyser (seem to make no sense for an
> "off" device). However, if I select one of these I get a blank screen
> when I turn the SB2 off, which is ok.

rather than going through the hassle of tracking every screensaver for every
mode it might be valid for, the server just lists them all. The idea being
that the users would be smart enough no know that the analog VU doesn't really
do much when off (unless they want it that way)

> Second, I'm not sure what the "none" value is meant to do here. It
> seems to leave the display on date-and-time when I turn it off... so
> how is that different from the "date and time" value? I was initially
> expecting "none" to give me a blank screen, though I can see how this
> might be taken to mean "don't have a screensaver, ie leave the screen
> as it was....".
>
none, basically does nothing. Whatever mod ethe player is in, the brightness
just dims to the 'idlebrightness' setting (unless server pref has selected
manual brightness only). When off, the player defaults to date and time
display, so that's what you see. In the case of off, this really isn't any
different than using date and time. The Date and Time screensaver is there
mainly to server as an example of writing a simple screensaver. I guess it
probably isn't needed for that, since there are lots more examples now, but
maybe some peope like to have date and time while the player is on.

-kdf