PDA

View Full Version : Some bugs in 6.1b1



dip
2005-06-30, 00:25
1. When I browse in slim server by album the first shown item reads "All songs" instead of "All albums". When browsing the artists the first item read "All albums" instead of "All artists". Browsing genres shows "All artists", browsing years shows "All albums" and browsing directories shows "All songs". So it seems that there is something messed up with this "All..." line.

2. I had some mp3-files which had their filenames in capital letters. These files were not shown when browsing through artists or albums. Only after renaming the extension of these files from MP3 to mp3 after a rescan these songs were shown. In my opinion scanning of the files should be case insensitive (I use windows XP home edition, so case of filenames should not make a difference).

3. I use Mozilla Firefox as default browser so slim server is shown in Firefox. Sometimes in the right part of the windows (where the Music Player is shown) some of the controls are not displayed (e.g. some of the digits "buttons" where you can change the volume or the word "Repeat"). After making a reload in Firefox all parts are correctly displayed.

4. When I try to store a playlist in the left part of the window only an error message 404 is shown saying that the "browse.html" cannot be found. I tried to copy this file (which I found in some of the slim server's program directory) to several other sub directories but this did not help. I could store the playlist only by clicking on download and then store the playlist.

mherger
2005-06-30, 00:47
> 4. When I try to store a playlist in the left part of the window only
> an error message 404 is shown saying that the "browse.html" cannot be
> found.

Does this also happen if you refresh the status window first? Or empty
firefox' cache? browse.html has been removed and isn't used any more. The
only reference I found was in the docs - not a link you would use. So I
presume (as you reported caching problems as well) you were displayed an
old copy of the status page with the link still pointing to that no more
existing file.

> I tried to copy this file (which I found in some of the slim
> server's program directory) to several other sub directories but this
> did not help. I could store the playlist only by clicking on download
> and then store the playlist.

Did you do an update install over the old slimserver? This file should not
exist any more.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

dip
2005-06-30, 01:07
I did not empty firefox' cache but will try that this evening when I am at home. What do you mean with refreshing the "status window"? Do you mean to refresh the firefox window?
When I place the cursor over the "store" button in the bottom status line of firefox a reference to the browse.html file is shown.

Yes, I did install the 6.1b1 over 6.0.3 which was installed over 6.0.2. So I think I will deinstall slim server this evening completely and do a fresh install of 6.1b1.

mherger
2005-06-30, 01:22
> I did not empty firefox' cache but will try that this evening when I am
> at home. What do you mean with refreshing the "status window"? Do you
> mean to refresh the firefox window?

Yes. I meant the status pane (which is the part on the right).

> When I place the cursor over the "store" button in the bottom status
> line of firefox a reference to the browse.html file is shown.

Mine is:

http://myserver:9000/edit_playlist.html?player=...&saveCurrentPlaylist=1

> Yes, I did install the 6.1b1 over 6.0.3 which was installed over 6.0.2.
> So I think I will deinstall slim server this evening completely and do a
> fresh install of 6.1b1.

I'm not sure whether this will help with the other problems. It's just the
fact that you found browse.html which made me ask.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

dip
2005-06-30, 23:59
>
I'm not sure whether this will help with the other problems. It's just the
fact that you found browse.html which made me ask.

I completely uninstalled slimserver and reinstalled 6.1b1. Now storing of playlists works perfectly and the browse.html does no longer exist. Thanks a lot for pointing to that.

Regarding item 1. (the "All ..." issue) I learned from another thread (in General Discussion) that this behavior is as designed. And I think I am getting used to it now and like as it is.

Points 2. and 3. ("capitalization and refreshing bugs") are still an issue.

mherger
2005-07-01, 00:11
> Points 2. and 3. ("capitalization and refreshing bugs") are still an
> issue.

You might open a bug over at http://bugs.slimdevices.com

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)