PDA

View Full Version : SlimServer 6.1b1, Accented Characters and Display Font



agross
2005-06-28, 17:07
After reading some of the threads about Unicode improvements I was yesterday enticed to make the jump from 6.0.2 to 6.1b1. However I promptly returned back to 6.0.2, because all of the songs which contained accented characters suddenly disappeared from the Squeezebox2 (although the songs were still appearing with all accented characters in the Web interface on my Mac OS X 10.3.8 computer). In 6.0.2 the songs do appear on the Squeezebox2, but with question marks in place of the accented characters.

When will the display font on the Squeezebox2 expected to be Unicode (utf-8) compatible? This seems to be an issue with both 6.0.2 and 6.1b1.

Dan Sully
2005-06-28, 17:19
* agross shaped the electrons to say...

>After reading some of the threads about Unicode improvements I was
>yesterday enticed to make the jump from 6.0.2 to 6.1b1. However I
>promptly returned back to 6.0.2, because all of the songs which
>contained accented characters suddenly disappeared from the Squeezebox2
>(although the songs were still appearing with all accented characters in
>the Web interface on my Mac OS X 10.3.8 computer). In 6.0.2 the songs do
>appear on the Squeezebox2, but with question marks in place of the
>accented characters.

Are you using MusicMagic or iTunes?

>When will the display font on the Squeezebox2 expected to be Unicode
>(utf-8) compatible? This seems to be an issue with both 6.0.2 and 6.1b1.

This issue will take some architectural work - we have plans for it, but I have no timeline.

-D
--
Welcome to hell. Here's your accordion.

agross
2005-06-28, 17:38
Am using iTunes - this and the SlimServer Web application are displaying accented characters correctly.