PDA

View Full Version : AlienBBC plugin error



gorstk
2005-06-28, 09:25
An error is thown out by the Alienbbc plugin at startup as the current
version number is 6.1b1...

Argument "61b1" isn't numeric in numeric gt (>) at
/usr/local/slimserver/Plugins/Alien/Plugin.pm line 541, <DATA> line 1.


# VER: Only required upto v6.0.2
if ($version > 601)


This is resulting in the Alienbbc menu not appearing in the 'radio'
section of the web interface (was the radio section only introduced
after 6.01?)

I guess the problem will sort itself out once 6.1 is released.

Cheers

gorstk
2005-06-28, 09:43
John Gorst wrote:
>
> An error is thown out by the Alienbbc plugin at startup as the current
> version number is 6.1b1...

Sorry - just noticed I posted this is in the beginners forum and not the
plugins forum as intended.

Any replys to the plugins forum - sorry!

Neil Sleightholm
2005-06-28, 11:31
I can't work out how to reply in "3rd party" and keep this linked. I don't think this error actually affects the plugin behaviour but if you want a fix, in plugin.pm line 538, replace:
$version =~ s/\.//g;
with:
$version =~ s/\.|[A-Za-z]//g; # Remove .'s (or alpha to get round 6.1b1 problem)

Neil