PDA

View Full Version : ISO-8859-1 issues with 6.0.2-1



pcamps
2005-06-21, 14:22
Hi there,

I've got a problem with ISO-8859-1 encoded file names and directory names. They don't show up at all on the SlimServer.

My environment:

slimserver-6.0.2-1

Red Hat 9

Linux home.pere.net 2.6.10 #1 Tue Jan 25 09:34:18 CET 2005 i686 athlon i386 GNU/Linux

This is perl, v5.8.0 built for i386-linux-thread-multi

(root@home) ~ # locale charmap
ISO-8859-1
(root@home) ~ # echo $LC_CTYPE
en_US.ISO-8859-1
(root@home) ~ # echo $LANG
en_US.ISO-8859-1

If I do an "ls" I get, for example:

-rwxr-xr-x 1 root root 3237180 Mar 22 20:54 02 - AntÚnia Font - Vitamina Sol.mp3
drwxr-xr-x 2 root root 4096 Jun 21 23:20 AntÚnia

Any ideas at all? Should I fill up a bug report?

Thanks,

Dan Sully
2005-06-21, 14:30
* pcamps shaped the electrons to say...

>I've got a problem with ISO-8859-1 encoded file names and directory
>names. They don't show up at all on the SlimServer.

Please give the 6.1 tree a go - there have been a lot of Unicode/character set improvements.

-D
--
Ya gotta love UNIX, where else do you wonder whether
you can kill a zombie spawned by a daemon's fork?

pcamps
2005-06-21, 14:56
Hi,

Just upgraded to:

slimserver-2005_06_21-1

And no luck.

I should specifiy a little bit more the issue however.

It's not all ISO-8859-1 encoded file/dir names that aren't shown, just the ones that contain (at least that I have notice) accented characters (ie, ŠťŪůķ, etc)

I have a folder with the following contents:

-rwxr-xr-x 1 root root 3237180 Mar 22 20:54 02 - AntÚnia Font - Vitamina Sol.mp3
drwxr-xr-x 2 root root 4096 Jun 21 23:20 AntÚnia

And neither the file name or the directory show up when you browse through them through "Browse Music Folder" on the SlimServer's web page.

Thanks for your help,