PDA

View Full Version : Disabling cuesheets?



Cerb
2005-06-16, 08:10
What would be the easiest way to disable cuesheet parsing by slimserver? My collection is multiple flac files, and I use EAC's non-standard cuesheets for burning to CDR...but those don't appear to work well with slimserver, since total times are not listed. Perhaps a better solution would be to be able to identify these non-standard cuesheets and parse them correctly - but for now I'd just prefer to have them disabled.

JJZolx
2005-06-16, 08:31
What would be the easiest way to disable cuesheet parsing by slimserver? My collection is multiple flac files, and I use EAC's non-standard cuesheets for burning to CDR...but those don't appear to work well with slimserver, since total times are not listed. Perhaps a better solution would be to be able to identify these non-standard cuesheets and parse them correctly - but for now I'd just prefer to have them disabled.

Open types.conf and comment out the line beginning with "cue":

.
.
.
css css text/css -
#cue cue audio/x-cue playlist
cur - audio/x-cue-referenced -
dir - application/directory list
.
.
.

It's a makeshift fix but it works. Keep in mind that if you install a new version of SlimServer this file will be overwritten. I keep a custom version and after any installation of SlimServer I copy the custom version over top of types.conf and restart the server.

Cerb
2005-08-04, 06:17
I'm using SlimServer 6.1.1 - 3774, and even after commenting out the 'cue' entry in the types.conf file, it still appears to use part of the cue (screwing up my playlist in the process.) For example, directories with cuesheets in them, when added to the playlist, will have N-1 tracks at the beginning of the list with the name of the last track on the album, followed by the N correct tracks of the disc. Any further ideas?