PDA

View Full Version : Accented characters become garbled in SlimServer



Spies
2005-06-14, 10:00
I am having problems with accented characters in SlimServer when using
MusicMagic Mixer. The file names and tags show up properly in
MusicMagic Mixer but become garbled in SlimServer if they contain
accented characters. I can select the garbled files in SlimServer but
they will not play. Any suggestions? Should I file a bug report? I am
running SlimServer 6.0.2, MusicMagic Mixer 1.1.5.1 on Mac OS X 10.4.1.
Thanks!

kdf
2005-06-14, 10:17
Quoting Steven Spies <sspies (AT) gmail (DOT) com>:

> I am having problems with accented characters in SlimServer when using
> MusicMagic Mixer. The file names and tags show up properly in
> MusicMagic Mixer but become garbled in SlimServer if they contain
> accented characters. I can select the garbled files in SlimServer but
> they will not play. Any suggestions? Should I file a bug report? I am
> running SlimServer 6.0.2, MusicMagic Mixer 1.1.5.1 on Mac OS X 10.4.1.
> Thanks!

Its a known issue which has had some attempts to fix:
Try 6.1 nightly builds, wipe cache, and let us know.

-kdf

Spies
2005-06-14, 10:50
Yes! That did it! Thank you kdf, you are a gentleman and a scholar. I
will report if anything else comes up with this build. Now I can use
MusicMagic Mixer as my FLAC file manager on Mac OS X in addition to
MusicMagic mixing all of my tunes! How close is 6.1 becoming final?
Thanks again, Steven

On 6/14/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
> Quoting Steven Spies <sspies (AT) gmail (DOT) com>:
>
> > I am having problems with accented characters in SlimServer when using
> > MusicMagic Mixer. The file names and tags show up properly in
> > MusicMagic Mixer but become garbled in SlimServer if they contain
> > accented characters. I can select the garbled files in SlimServer but
> > they will not play. Any suggestions? Should I file a bug report? I am
> > running SlimServer 6.0.2, MusicMagic Mixer 1.1.5.1 on Mac OS X 10.4.1.
> > Thanks!
>
> Its a known issue which has had some attempts to fix:
> Try 6.1 nightly builds, wipe cache, and let us know.
>
> -kdf
>
>
>

kdf
2005-06-14, 11:01
Quoting Steven Spies <sspies (AT) gmail (DOT) com>:

> Yes! That did it! Thank you kdf, you are a gentleman and a scholar. I
> will report if anything else comes up with this build. Now I can use
> MusicMagic Mixer as my FLAC file manager on Mac OS X in addition to
> MusicMagic mixing all of my tunes! How close is 6.1 becoming final?
> Thanks again, Steven

Thank Dan. They were his fixes. There is no date for 6.1, and I get the
impression that there won't really be any fixed date. However, there is a lot
of activity on the buglist, sorting out which ones should be tackled for 6.1,
and very little work is going into patching 6.0.3. Currently there are 79 bugs
marked for 6.1. That usually means it is getting close, at least intended to
be.

-kdf

mikerob
2005-06-25, 10:15
I installed the 24-Jun 6.1 nightly and it looks like the fix for this issue is broken - tracks, artists and albums with accents in their titles appear twice in listings. One record is garbled (accents don't display properly) and has the "mm" icon next to it and the other record is displayed correctly but doesn't have the "mm" icon.

This doesn't appear to be the only issue with accents which has reoccurred.

I raised bug report 1709 yesterday (http://bugs.slimdevices.com/show_bug.cgi?id=1709) for another issue with the latest 6.1 nightly where tracks with accents in their title crash the Slimserver and a very similar issue was reported and fixed back in April (http://forums.slimdevices.com/showthread.php?t=1746&highlight=accent)

Dan Sully
2005-06-25, 10:22
* mikerob shaped the electrons to say...

>I installed the 24-Jun 6.1 nightly and it looks like the fix for this
>issue is broken - tracks, artists and albums with accents in their
>titles appear twice in listings. One record is garbled (accents don't
>display properly) and has the "mm" icon next to it and the other record
>is displayed correctly but doesn't have the "mm" icon.

Are you running MusicMagic or MoodLogic?

Can you please send me your slimserversql.db file?

Thanks.

>I raised bug report 1709 yesterday
>(http://bugs.slimdevices.com/show_bug.cgi?id=1709) for another issue
>with the latest 6.1 nightly where tracks with accents in their title
>crash the Slimserver and a very similar issue was reported and fixed
>back in April
>(http://forums.slimdevices.com/showthread.php?t=1746&highlight=accent)

Is this with a Graphical or Character based SB1? You don't specify in the bug.

Thanks.

-D
--
<Djall> and I also learned that a meat vortex takes meat away from you.

Spies
2005-06-27, 19:29
I just downloaded and installed SlimServer 6.1b1 and the garbled
characters are back :( Going back to SlimServer_v2005-06-14 solves the
problem. I have not tried any other versions. Any ideas? Thanks again,
Steven Spies

On 6/14/05, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
> Quoting Steven Spies <sspies (AT) gmail (DOT) com>:
>
> > Yes! That did it! Thank you kdf, you are a gentleman and a scholar. I
> > will report if anything else comes up with this build. Now I can use
> > MusicMagic Mixer as my FLAC file manager on Mac OS X in addition to
> > MusicMagic mixing all of my tunes! How close is 6.1 becoming final?
> > Thanks again, Steven
>
> Thank Dan. They were his fixes. There is no date for 6.1, and I get the
> impression that there won't really be any fixed date. However, there is a lot
> of activity on the buglist, sorting out which ones should be tackled for 6.1,
> and very little work is going into patching 6.0.3. Currently there are 79 bugs
> marked for 6.1. That usually means it is getting close, at least intended to
> be.
>
> -kdf
>

Dan Sully
2005-06-28, 08:21
* Steven Spies shaped the electrons to say...

>I just downloaded and installed SlimServer 6.1b1 and the garbled
>characters are back :( Going back to SlimServer_v2005-06-14 solves the
>problem. I have not tried any other versions. Any ideas? Thanks again,
>Steven Spies

Steven - I've just reverted the changes I made to the MMM plugin - they will
be in the 6/29 build, or are in Subversion if you are keeping up with that.

Please let me know if the problem is fixed.

Also - what version of MMM are you running?

Thanks.

-D
--
<dr.pox> NO, NETBSD IS NOT REALLY BUILT WITH ELITE FORTRAN77!!@$#$

Spies
2005-06-29, 07:34
I just tried SlimServer_v2005-06-29 and the garbled characters are
still there. I did a "Rescan Music Library" with "Clear library before
rescan" checked but it did not make a difference. Once again going
back to SlimServer_v2005-06-14 solves the problem. Did the change make
it into SlimServer_v2005-06-29? I am currently running Mac OS X 10.4.1
and MusicMagic Mixer 1.1.6 Beta.

On 6/28/05, Dan Sully <dan (AT) slimdevices (DOT) com> wrote:
> * Steven Spies shaped the electrons to say...
>
> >I just downloaded and installed SlimServer 6.1b1 and the garbled
> >characters are back :( Going back to SlimServer_v2005-06-14 solves the
> >problem. I have not tried any other versions. Any ideas? Thanks again,
> >Steven Spies
>
> Steven - I've just reverted the changes I made to the MMM plugin - they will
> be in the 6/29 build, or are in Subversion if you are keeping up with that.
>
> Please let me know if the problem is fixed.
>
> Also - what version of MMM are you running?
>
> Thanks.
>
> -D
> --
> <dr.pox> NO, NETBSD IS NOT REALLY BUILT WITH ELITE FORTRAN77!!@$#$
>