PDA

View Full Version : ShoutCast Connection Errors on SB2



Jimsngc
2005-06-10, 08:28
Hi,

I am not sure if this should be in the Plugins forum or here but anyway - shot me if I'm in the wrong place :)

On both my SB2 and SoftSqueeze I get this message most times when I try and connect to ShoutCast:
Error: ShoutCast Web Site Not Available

OK - before anyone starts to shot me again, I have checked from the server (Linux: Fedora Core 1) and it's up (www.shoutcast.com) and running just fine. If I sit there and keep trying to reconnect eventually it will get a connection but it takes a lot of trying!

Any ideas? Anyone know the exact URL we're trying to connect to here? Also, this is in the slimserver.log at the time of trying:
Use of uninitialized value in concatenation (.) or string at /usr/local/slimserver/Plugins/ShoutcastBrowser.pm line 950.
Use of uninitialized value in hash element at /usr/local/slimserver/Plugins/ShoutcastBrowser.pm line 958.
Use of uninitialized value in hash element at
/usr/local/slimserver/Plugins/ShoutcastBrowser.pm line 958.

This is the offending line of code:
if (keys %{ $stream_data{$current_genre}{$current_stream} } > 1) {


I'm on slimserver-6.0.2-1.rpm

Happy to try some troubleshooting if anyone has any ideas!

Jim

Ben Sandee
2005-06-10, 08:42
On 6/10/05, Jimsngc <Jimsngc.1qf2rz (AT) no-mx (DOT) forums.slimdevices.com> wrote:
> On both my SB2 and SoftSqueeze I get this message most times when I try
> and connect to ShoutCast:
> Error: ShoutCast Web Site Not Available

Jim,

You might try raising the "Radio Station Timeout" setting (Server
Settings -> Network) to a higher value (the default value is 5 I
think, at least it is on mine). If the shoutcast web site is usually
taking longer than this to respond it could explain what you are
seeing.

Ben