PDA

View Full Version : SlimServer 6.02 doesn't work



full_fire
2005-06-05, 10:47
Hi!

Recently i used SlimServer 5.4.0 on Debian Sarge and it works very fine. Now i try SlimServer 6.02 and get the following message when i start the Server.
"'x' outside of string in unpack at /full_fire/slim6/SlimServer_v6.0.2/Slim/Music/Info.pm line 1357"

What can i do to make slimserver 6.0.2 work.

Greetings

Maditude
2005-06-05, 11:29
Hi!

Recently i used SlimServer 5.4.0 on Debian Sarge and it works very fine. Now i try SlimServer 6.02 and get the following message when i start the Server.
"'x' outside of string in unpack at /full_fire/slim6/SlimServer_v6.0.2/Slim/Music/Info.pm line 1357"

What can i do to make slimserver 6.0.2 work.

Greetings
What version of Perl do you have? I believe 5.8 is now the minimum (at least it was for me, on freebsd)...

full_fire
2005-06-05, 12:26
Hi!

The perl version is ok. perl -v displays 5.8.4

Any other ideas?

Greetings

Dan Sully
2005-06-05, 12:31
* full_fire shaped the electrons to say...

>Recently i used SlimServer 5.4.0 on Debian Sarge and it works very
>fine. Now i try SlimServer 6.02 and get the following message when i
>start the Server.
>"'x' outside of string in unpack at
>/full_fire/slim6/SlimServer_v6.0.2/Slim/Music/Info.pm line 1357"

SlimServer is having an issue parsing a PIC/APIC tag from a MP3 file.

Add a 'print "fullpath of file with (A)PIC is: [$fullpath]\n"; at line 1356

If you can send us that file, it would help in debugging.

-D
--
<jwb> if only a gigantic walking octopus would come along and strangle the entire nutjob religious right