PDA

View Full Version : crash when open shoutcast



heiwil
2005-06-04, 07:08
Hello,
when I try to open Shoutcast, the slimserver crashes with the message:
Can't find unicode character property definition via Plugins::ShoutcastBrowser->ToLower or To/Lower.pl at /usr/local/src/SlimServer_6_0_x_v2005-06-04/Plugins/ShoutcastBrowser.pm line 437
Same error if I use version 6.0.2
My system:
Debian Sarge, kernel 2.6.9
perl 5.6.1.
My system is based on a linVDR distribution. To get slimserver running I had to install a couple of perl-modules. So I feel, errors reason is a missing or wrong module.

Any Idea?

mherger
2005-06-04, 07:31
> when I try to open Shoutcast, the slimserver crashes with the message:
> Can't find unicode character property definition via
> Plugins::ShoutcastBrowser->ToLower or To/Lower.pl at
> /usr/local/src/SlimServer_6_0_x_v2005-06-04/Plugins/ShoutcastBrowser.pm
> line 437
> Same error if I use version 6.0.2
> My system:
> Debian Sarge, kernel 2.6.9
> perl 5.6.1.
> My system is based on a linVDR distribution. To get slimserver running
> I had to install a couple of perl-modules. So I feel, errors reason is
> a missing or wrong module.

Strange... Do you try to download a large number of streams? If this is
the case, try reducing it.

Please note that Perl 5.6.1 isn't up to date when handling unicode. It
causes problems in other places, too. Best would be if you could update to
perl 5.8.x - it's possible to have both version installed alongside each
other.

I have compiled a perl 5.8.x for redhat 7.x based system. It is said to
work with other distros, too. But I can't say it for Debian. If you're
brave enough you could give it a try :-). If you follow the instructions
it shouldn't touch your existing system, you could safely remove it if it
fails.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

heiwil
2005-06-04, 09:10
Hi Michael,
it works fine now !!!
I just installed perl5.8.6 like you have shown here:
http://www.herger.net/slim/detail.php?nr=612&kategorie=slim

Thanks


> when I try to open Shoutcast, the slimserver crashes with the message:
> Can't find unicode character property definition via
> Plugins::ShoutcastBrowser->ToLower or To/Lower.pl at
> /usr/local/src/SlimServer_6_0_x_v2005-06-04/Plugins/ShoutcastBrowser.pm
> line 437
> Same error if I use version 6.0.2
> My system:
> Debian Sarge, kernel 2.6.9
> perl 5.6.1.
> My system is based on a linVDR distribution. To get slimserver running
> I had to install a couple of perl-modules. So I feel, errors reason is
> a missing or wrong module.

Strange... Do you try to download a large number of streams? If this is
the case, try reducing it.

Please note that Perl 5.6.1 isn't up to date when handling unicode. It
causes problems in other places, too. Best would be if you could update to
perl 5.8.x - it's possible to have both version installed alongside each
other.

I have compiled a perl 5.8.x for redhat 7.x based system. It is said to
work with other distros, too. But I can't say it for Debian. If you're
brave enough you could give it a try :-). If you follow the instructions
it shouldn't touch your existing system, you could safely remove it if it
fails.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

mherger
2005-06-04, 11:00
> it works fine now !!!
> I just installed perl5.8.6 like you have shown here:
> http://www.herger.net/slim/detail.php?nr=612&kategorie=slim

Excellent! Now I can add one more system to the list of successful
installations :-)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)