PDA

View Full Version : SlimServer: Page Cannot be Displayed



takashi37
2005-06-02, 23:19
I'm having an intermittent issue and would love any advice.

Setup is SqueezeBox 2, Slim Server 6.02, Windows XP Pro, 802.11b

Essentially, the SlimServer shows me a web page "cannot be displayed" that looks like it uses the IE rendering engine.

And in the room with the SqueezeBox, when it happens, the song will keep playing for a bit but the screen goes to "Connecting to SlimServer..." for a few seconds then goes blank.

Thanks for any info,
TL

mherger
2005-06-02, 23:41
> Essentially, the SlimServer shows me a web page "cannot be displayed"
> that looks like it uses the IE rendering engine.

It does.

> And in the room with the SqueezeBox, when it happens, the song will
> keep playing for a bit but the screen goes to "Connecting to
> SlimServer..." for a few seconds then goes blank.

I'd say your slimserver has gone away. Could you run it from the command
line? Go to c:\program files\slimserver\server (or wherever it is
installed) and run slim.exe. Does it give some error message before
crashing?

Do you run it as a service?


--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

takashi37
2005-06-03, 14:37
Thanks for your reply!


command line

I will try running it from the command line as soon as I get home from work and see what happens. What should I expect?


Does it give some error message before crashing?

I'm not sure it it gives an error message or not. There's nothing visible in terms of error messaging though... is there an error log I could inspect?


Do you run it as a service?

I'm really not sure. I remember reading about setting it up this way somewhere but couldn't find it anywhere on the site or forums when searching last night.

The only thing I found that was close was how to improve performance by changing the processor to focus more attention on background tasks than on applications which I've done.

Also, fyi, I'm pretty sure that I can "force" this to happen when I try to use the Top Hits and Recently Played tracks plug-ins, though sometimes it just happens for no reason.

Lastly, as I posted in my original message, I'm using 6.0.x instead or 6.1.X becuase I'm reluctant to install a buggy nightly build. Is there a v6.1 that's considered stable. And fwiw, I'm using firmware v 11.

Thanks again for any help or info!

TL




> Essentially, the SlimServer shows me a web page "cannot be displayed"
> that looks like it uses the IE rendering engine.

It does.

> And in the room with the SqueezeBox, when it happens, the song will
> keep playing for a bit but the screen goes to "Connecting to
> SlimServer..." for a few seconds then goes blank.

I'd say your slimserver has gone away. Could you run it from the command
line? Go to c:\program files\slimserver\server (or wherever it is
installed) and run slim.exe. Does it give some error message before
crashing?

Do you run it as a service?


--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

takashi37
2005-06-03, 16:19
Okay, I ran slim.exe from the command line and got the following...

-------------------------------------------------

Use of uninitialized value in concatenation (.) or string at /PerlApp/Slim/Buttons/Plugins.pm line 82, <DATA> line 1.

Use of uninitialized value in string comparison (cmp) at /PerlApp/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

Use of uninitialized value in string comparison (cmp) at /PerlApp/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

Use of uninitialized value in string comparison (cmp) at /PerlApp/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

Use of uninitialized value in string comparison (cmp) at /PerlApp/Slim/Buttons/Plugins.pm line 90, <DATA> line 1.

-------------------------------------------------

Again, thanks.

TL

mherger
2005-06-04, 00:54
> Also, fyi, I'm pretty sure that I can "force" this to happen when I try
> to use the Top Hits and Recently Played tracks plug-ins, though
> sometimes it just happens for no reason.

I think the Recently played isn't compatible with 6.x (there was a thread
about it a few days ago. Top Hits might have the same problem. Remove
these two and try to crash slimserver again.

The error messages you sent in the other mail point in this direction, too.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)