PDA

View Full Version : unix Digest, Vol 2, Issue 27



Richard Atkinson
2005-05-30, 01:41
Hi Triode,

> Looks to me that perl-devel includes EXTERN.h
>
> The exact version I have is: perl-devel-5.8.6-6.1.102mdk

Based on this I tried: urpmi perl-devel
To which I got: The package(s) are already installed

So I tried a: urpmq -i perl-devel

Which yielded the following:

Name : perl-Devel-Symdump
Version : 2.03
Release : 4mdk
Group : Development/Perl
Size : 21061 Architecture: noarch
Source RPM : perl-Devel-Symdump-2.03-4mdk.src.rpm Build Host:
klama.mandrake.org
Packager : Jean-Michel Dault <jmdault (AT) mandrakesoft (DOT) com>
URL : http://www.cpan.org
Summary : Devel-Symdump module for perl
Description :
Devel-Symdump module for perl


Hmmm... so then I tried:

urpmi perl-devel-5.8.6-6.1.102mdk

But alas, 'no package named perl-devel-5.8.6-6.1.102mdk'

>
> As of this weekend I am on Mandriva 2005 LE and the slim build script
> worked fine.

Thanks for that, I think this confirms my status as noob :)
Could it be that I have some kind of conflict between the multiple
versions of perl that are installed? Am very happy to take further
guidance.

Thanks much for help so far.

- richard

mherger
2005-05-30, 01:47
> urpmi perl-devel-5.8.6-6.1.102mdk
>
> But alas, 'no package named perl-devel-5.8.6-6.1.102mdk'

Why don't you just use drakconf? No need to know a packages exact name.

I know: real men don't click. But sometimes I'm not real man enough and
enjoy the conveniance of a GUI :-)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

Triode
2005-05-30, 02:04
Hi Richard,

does urpmi perl-devel-5.8.6 work? If not:

Are you using X? If so I would suggest using drakconf to install new software and see what is already installed.

Start drakconf, select "Software Management". If you then select "Install Software", it gives you a browser for all installable software.

Type in "perl-devel" and you should see a list. If this does not include perl-devel-5.8.6-6.1.102mdk then go back a page and select "Uninstall Software" and do the same - the should give a list of installed packages. Using this method you can also search for packages by files which are included - in this case "EXTERN.h"